PowerFlex 4.5 - Помилка під час розгортання "Не вдалося скопіювати профіль конфігурації сервера на мережевий ресурс".

Summary: PowerFlex 4.5 - Помилка під час розгортання "Не вдалося скопіювати профіль конфігурації сервера на мережевий ресурс".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Помилка в тонких журналах розгортача PowerFlex Manager Platform (PFMP): -

Debug: Result = #\n\n  \n    http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous\n    http://schemas.xmlsoap.org/ws/2004/09/transfer/GetResponse\
n    uuid:55c86fb7-0a34-1a34-8002-c3e575a07eee\n    uuid:5d393a92-0a39-1a39-81bf-4e1296d64bc8\n  \n  \n    \n      0\n      JID_000913530199\n      NA\n   
   Failed\n      NA\n      Unable to copy the Server Configuration Profile to the network share.\n      NA\n      SYS045\n      Export Configuration\n   
   100\n    \n  \n\n">

Помилка в PowerFlex Manager під час розгортання: -


Помилка RG 


 

 

Cause

Дозволи на папки неправильно встановлено під час розгортання.

Resolution

Спосіб вирішення проблеми

Успішне тестування з'єднання з відкритим сервісним портом
nfs-server-0 Перейдіть до iDRAC і спробуйте експортувати журнал життєвого циклу до спільного ресурсу NFS, щоб переконатися, що NFS налаштовано правильно та чи відкрито всі необхідні порти.

Замініть IP-адресу на IP-адресу OOB nfs-server-service-tcp-flex-oob-mgmt-r на знімку екрана нижче.

Ви можете виконати команду "kubectl get service -n powerflex | grep nfs" для отримання IP-адреси маршрутизації nfs-server-service-tcp-flex-oob-mgmt-r.

Шлях до спільного доступу: /var/containerpath/idrac_config_xml


image.png

У випадку, якщо NFS налаштована неправильно і є проблеми, завдання не вдається виконати завдання з помилкою «Завдання JID_XXXXXXXXXXX не вдалося, тому що не вдається записати в мережевий ресурс»


IDRAC Job ID 

Переконайтеся, що відкриті такі порти:

Port 111 (TCP and UDP)
Port 2049 (TCP and UDP)
Port 32765 (TCP and UDP)
Port 32767 (TCP and UDP)


Після цього запустіть наведену нижче команду для кожного з наведених вище портів з IP-адресою iDRAC, на якій не вдалося експортувати журнали життєвого циклу до спільного ресурсу NFS на попередньому кроці.

echo > /dev/tcp/XX.XX.XX.XX/111 && echo "Port is open" || echo "not open"
echo > /dev/tcp/XX.XX.XX.XX/2049 && echo "Port is open" || echo "not open"
echo > /dev/tcp/XX.XX.XX.XX/32765 && echo "Port is open" || echo "not open"
echo > /dev/tcp/XX.XX.XX.XX/32767 && echo "Port is open" || echo "not open"
echo > /dev/udp/XX.XX.XX.XX/111 && echo "Port is open" || echo "not open"
echo > /dev/udp/XX.XX.XX.XX/2049 && echo "Port is open" || echo "not open"
echo > /dev/udp/XX.XX.XX.XX/32765 && echo "Port is open" || echo "not open"
echo > /dev/udp/XX.XX.XX.XX/32767 && echo "Port is open" || echo "not open"




Перевірка відкриття порту 

Після того, як ви переконаєтеся, що всі порти відкриті, змініть фокус на дозволи, оскільки IDRAC не міг ЗАПИСУВАТИ до спільного ресурсу NFS. Але IDRAC міг підключитися до нього.

Перейдіть до папки /opt/platform/fileshare/ і перевірте дозволи на папку на idrac_config_xml.

Вони повинні бути встановлені на drwxrwxrwx 1 ніхто ніхто На
скріншоті нижче ви можете помітити, що права доступу до папки були встановлені на drwxr-xr-x 1 root root. Які не є правильними дозволами.


image.png

Змініть дозволи, виконавши наведені нижче команди.

chmod 777 /opt/platform/fileshare/idrac_config_xml
chown nobody:nobody /opt/platform/fileshare/idrac_config_xml

Після того, як дозволи правильно встановлені на drwxrwxrwx 1, ніхто, ніхто не в папці /opt/platform/fileshare/idrac_config_xml .

Виконайте команду  "kubectl exec -it nfs-server-0 -n powerflex -- /bin/bash" і перейдіть до папки /var/containerpath і перевірте дозволи папки на idrac_config_xml папці. Ви помітили, що тепер права доступу до папок правильно встановлені і в цій папці.


image.png

 

Article Properties
Article Number: 000219658
Article Type: Solution
Last Modified: 10 Feb 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.