NetWorker : smtpmail ne prend pas en charge l’authentification sur le serveur SMTP
Summary: NetWorker Server utilise sa propre commande smtpmail. Toutefois, il ne prend actuellement pas en charge la spécification d’un nom d’utilisateur et d’un mot de passe pour se connecter à un serveur SMTP qui nécessite cette authentification pour relayer les messages. ...
Symptoms
Le NetWorker Server est configuré pour utiliser smtpmails dans les politiques, les workflows et d’autres types de notifications.
Cependant, le courrier n’est pas reçu sur le serveur de messagerie.
Le serveur de messagerie SMTP est configuré avec l’authentification, mais les options de commande smtpmail ne fournissent pas d’options de syntaxe pour ajouter un nom d’utilisateur et un mot de passe.
Lors d’un test manuel smtpmai commande, elle échoue :
C:\> smtpmail -h mail.server.com -s subject sender@sender.com 0 1711515859 2 0 0 20288 10440 0 nwserver smtpmail NSR warning 2 %s 1 0 115 protocol failure; got 550 5.7.1 <sender@sender.com>... we do not relay SYSTEM@nwserver
Cause
L’équipe NetWorker smtpmail ne fonctionne pas avec le nom d’utilisateur et le mot de passe, et ne peut pas envoyer d’e-mails à un serveur SMTP si l’authentification est requise.
Resolution
À l’heure actuelle, il n’y a pas de solution à ce problème plutôt que :
- Utiliser un serveur SMTP non authentifié
- Autorisez l’adresse IP du NetWorker Server à contourner l’authentification.
RFE NW-I-1925 a été ouvert pour demander la présence de cette fonctionnalité dans NetWorker. Il n’y a pas d’ETA ni de confirmation si cette amélioration sera dans un avenir proche dans NetWorker.