Cisco MDS : Instellen van opstartvariabelen mislukt met 'mismatch tussen werkelijk imagetype en opstartvariabele (0x4045001E)'

Summary: Klant die een onderbrekende upgrade uitvoert van NX-OS 6.2.23 naar 9.4.2a.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Syntaxis die moet worden gebruikt om opstartvariabelen als volgt in te stellen:
switch(config)#
no boot system
switch(config)#
boot bootflash:<kickstart new_kickstart_image_name>
switch(config)#
boot bootflash:<system new_system_image_name>
switch(config)#
end
switch#
copy running-config startup-config
switch#
reload

Klant die de volgende opdracht uitvoert op een MDS 9148S:
MDS9148S(config)# boot kickstart bootflash:m9148-s6ek9-kickstart-mz.9.4.2a.bin

Performing image verification and compatibility check, please wait....
Failed to configure bootvar kickstart for sup-1: mismatch between actual image type and boot variable (0x4045001E)

Cause

Onjuiste image die wordt gebruikt voor Cisco MDS9148s platform:
From MDS9148s:
MDS9148s# show version
  kickstart image file is: bootflash:///m9100-s5ek9-kickstart-mz.6.2.23.bin
  kickstart compile time:  3/31/2018 23:00:00 [02/20/2018 18:47:57]
  system image file is:    bootflash:///m9100-s5ek9-mz.6.2.23.bin
  system compile time:     3/31/2018 23:00:00 [02/20/2018 19:58:46]

Merk op dat de versie van de switch is :
-m9100-s5ek9
Maar ik probeer opstartvariabelen in te stellen met een afbeelding van een ander platform, wat mislukt :
-m9148-s6ek9

Resolution

Ervoor zorgen dat voor elk platform
de juiste systeem-/kickstartimages worden gebruikt Platformimages kunnen worden gedownload van voor elk switchtype:
https://www.dell.com/support/home/en-ie/product-support/product/connectrix/drivers

Affected Products

Connectrix MDS-9148S
Article Properties
Article Number: 000249589
Article Type: Solution
Last Modified: 12 Mar 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.