PowerFlex:複寫中斷後重新初始化複寫
Summary: 由於各種原因,複製一致性組可能會被刪除,並且源網站和目標網站之間的複製將停止。所有案件的共同點是日誌容量的終結。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
在命令列中,我們可以找到警告訊息,指出「磁碟區位於損壞的複製一致性群組中」。
# scli --query_all_replication_pairs
query_all_replication_pairs returned 0 Replication Pairs.
WARNING: The System contains 2 volumes in broken replication consistency groups
# scli --query_all_replication_consistency_groups
Protection Domain aef4ce8300000000 Name: RHEL7-PD
WARNING: The Protection Domain contains 2 volumes in broken replication consistency groups
在使用者介面中,複寫一致性群組 (RCG) 狀態會顯示以下錯誤「系統已刪除 RCG」。

這些日誌檔的目的是實現網站之間複製的順利重新初始化。日誌檔用於在中斷原因解決后快速重新啟動複製過程。
Cause
可能導致複製中斷的原因範例:
a。來源和目標網站
之間的長期網路故障二.來源或目標網站的容量突然降低 - 例如在資料不可用 (DU) 情況下
複製中斷後,MDM 會自動刪除來源和目標網站之間的所有複製一致性群組 (RCG)。並會產生複寫記錄檔 其中包含與已刪除的 RCG 相關的所有資訊
Resolution
一個。在主要 MDM 底下找到下列格式的自動產生複寫中斷記錄檔 -
Auto-DeletedOnEndOfJournalCapacityRplCg_<RCG_ID>_<RCG_name>
範例:
# cd /opt/emc/scaleio/mdm/logs
# ls -l AutoDelete*
-rw-r--r-- 1 root root 953 Apr 14 12:15 AutoDeletedOnEndOfJournalCapacityRplCg_4ca1bc9600000000_Rep_Beta1
b.驗證導致複製中斷的問題是否已修復。
c. 使用以下兩種方法 之一 重新初始化複製:使用指令檔或手動。
使用指令檔:
-
產生一個檔案,其中包含自動產生的紀錄檔中的所有相關命令,以便重新初始化複製
範例:
for i in `ls /opt/emc/scaleio/mdm/logs/AutoDeletedOnEndOfJournalCapacity*`;do sed -e '1,/Recreation CLIs/d' $i >> full_replication_restore_$(date +%s); done -
驗證檔案已成功建立及其內容
範例:
[root@112AX-7 logs]# cat full_replication_restore_1587387678 scli --add_replication_consistency_group --replication_consistency_group_name rcg_sanity --destination_system_object_id 416af83800000000 --protection_domain_id b3dd0a5900000000 --remote_protection_domain_id 4ff0744e00000000 --rpo 60 --target_volume_access_mode no_access scli --add_replication_pair --replication_consistency_group_name rcg_sanity --source_volume_id 0da61f0d00000003 --destination_volume_id 1981bbaf00000005 --copy_type full scli --add_replication_consistency_group --replication_consistency_group_name rcg_SANITY2 --destination_system_object_id 416af83800000000 --protection_domain_id b3dd0a5900000000 --remote_protection_domain_id 4ff0744e00000000 --rpo 60 --target_volume_access_mode no_access scli --add_replication_pair --replication_consistency_group_name rcg_SANITY2 --source_volume_id 0da61f2500000000 --destination_volume_id 1981bbb000000006 --copy_type full scli --add_replication_consistency_group --replication_consistency_group_name rcg_sanity3 --destination_system_object_id 416af83800000000 --protection_domain_id b3dd0a5900000000 --remote_protection_domain_id 4ff0744e00000000 --rpo 60 --target_volume_access_mode no_access scli --add_replication_pair --replication_consistency_group_name rcg_sanity3 --source_volume_id 0da61f2600000001 --destination_volume_id 1981bbb100000007 --copy_type full [root@112AX-7 logs]# -
使產生的檔案可執行,然後以管理員身分登入主要 MDM 並執行建立的檔案。
範例:
# scli --login --username admin --password xxxxxxxxxx Logged in. User role is SuperUser. System ID is xxxxxxxxxxxxxxx # # chmod +x full_replication_restore_1587387678 ; ./full_replication_restore_1587387678 Successfully created Replication Consistency Group rcg_sanity. Object ID 357a6c4f00000001 Successfully created the Pair, ID = a1f1819900000001 Successfully created Replication Consistency Group rcg_SANITY2. Object ID 357a6c5300000003 Successfully created the Pair, ID = a1f1819a00000002 Successfully created Replication Consistency Group rcg_sanity3. Object ID 357a6c5500000005 Successfully created the Pair, ID = a1f1819b00000003 - 驗證是否已成功建立複寫,方法是執行
-
scli --query_all_replication_consistency_groups scli --query_all_replication_pairs
-
手動:
-
檢查每個自動刪除的 RCG 是否都有自動產生的記錄檔:
範例:
# ls /opt/emc/scaleio/mdm/logs/AutoDeletedOnEndOfJournalCapacity* /opt/emc/scaleio/mdm/logs/AutoDeletedOnEndOfJournalCapacityRplCg_357a454600000001_rcg_sanity /opt/emc/scaleio/mdm/logs/AutoDeletedOnEndOfJournalCapacityRplCg_357a6c4b00000002_rcg_SANITY2 /opt/emc/scaleio/mdm/logs/AutoDeletedOnEndOfJournalCapacityRplCg_357a6c4c00000003_rcg_sanity3 -
對清單中的每個檔案重複上述
a 的步驟 1。檢查 CLI 命令是否已產生,並驗證其在「重新建立 CLI」下是否有相關資訊範例:
#cat AutoDeletedOnEndOfJournalCapacityRplCg_357a6c4900000001_rcg_sanity REPLICATION CONSISTENCY GROUP LocalId:357a6c4900000001 RemoteId:4ca1e3ab00000001 Name:rcg_sanity PeerMdmId:416af83800000000 RpoSeconds:60 Direction:LOCAL_TO_REMOTE DRState:NONE DeletionDecisionTime:20/04 08:37:35 DeletionReason:AUTOMATIC_ON_END_OF_CAPACITY FailureDomainId:b3dd0a5900000000 RemoteFailureDomainId:4ff0744e00000000 PAIR 0 LocalId:a1f1819600000001 RemoteId:2dfad1c100000001 LocalVolumeId:0da61f0d00000003 LocalVolumeName:test1 RemoteVolumeId:1981bbaf00000005 RemoteVolumeName:test1 Recreation CLIs: scli --add_replication_consistency_group --replication_consistency_group_name rcg_sanity --destination_system_object_id 416af83800000000 --protection_domain_id b3dd0a5900000000 --remote_protection_domain_id 4ff0744e00000000 --rpo 60 --target_volume_access_mode no_access scli --add_replication_pair --replication_consistency_group_name rcg_sanity --source_volume_id 0da61f0d00000003 --destination_volume_id 1981bbaf00000005 --copy_type fullb.執行「Recreation CLI」區段下出現的所有命令
範例:
# scli --add_replication_consistency_group --replication_consistency_group_name rcg_sanity --destination_system_object_id 416af83800000000 --protection_domain_id b3dd0a5900000000 --remote_protection_domain_id 4ff0744e00000000 --rpo 60 --target_volume_access_mode no_access Successfully created Replication Consistency Group rcg_sanity. Object ID 357a6c4f00000001 [root@112AX-7 logs]# scli --add_replication_pair --replication_consistency_group_name rcg_sanity --source_volume_id 0da61f0d00000003 --destination_volume_id 1981bbaf00000005 --copy_type full Successfully created the Pair, ID = a1f1819900000001 [root@112AX-7 logs]# -
驗證是否已成功建立複寫,方法是執行
-
scli --query_all_replication_consistency_groups scli --query_all_replication_pairs
-
Affected Products
PowerFlex rack, ScaleIO, PowerFlex SoftwareArticle Properties
Article Number: 000260985
Article Type: Solution
Last Modified: 03 Jul 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.