Avamar. Восстановление на уровне файлов VMware может завершиться сбоем из-за настройки NAT

Summary: Данная статья базы знаний предназначена для устранения проблем, наблюдаемых при использовании Avamar File Level Restore (FLR) с преобразованием сетевых адресов (NAT). Операции FLR могут завершаться сбоем из-за несоответствия IP-адресов, вызванного NAT. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Задания FLR сначала запускаются, но не завершаются.
  • Файлы меньшего размера (например, от 20 Кбайт до 2,7 Мбайт) восстанавливаются успешно, а файлы большего размера (например, 25 Мбайт или 90 Мбайт) — нет.
  • Эта проблема затрагивает все виртуальные машины при восстановлении на уровне файлов в данной среде.
  • Ошибки сервера HTTP (Jetty) 500 отображаются в журналах доступа при попытках восстановления.
  • Журнал доступа Jetty показывает необычные IP-адреса (например, IP-адрес клиента заканчивается на 0.1 или 0.254, что, скорее всего, является адресом шлюза).

Cause

Проблема возникает из-за того, как FLR обрабатывает операции передачи файлов в зависимости от размера задания:

  1. Tiny Restore Jobs:

    • Когда задание FLR передает небольшой объем данных (всего байтов < 5 Мбайт и всего файлов < 10), оно использует API vSphere для восстановления файлов. При передаче файлов API vSphere конфигурации NAT обходятся, так как гостевая сеть виртуальной машины не участвует в передаче.
  2. Крупные задания восстановления:

    • Для более крупных заданий FLR, которые превосходят критерии крошечного задания восстановления, Avamar переключается на использование безопасных сценариев wget/BatchDownload для более эффективной передачи файлов.
    • Этот метод создает временные файлы и маркеры для управления безопасной передачей, которая зависит от IP-адреса клиента, соответствующего ожидаемому значению.

Когда NAT включен в сети, он изменяет исходный IP-адрес клиента в запросе. Это приводит к несовпадению между сохраненным IP-адресом клиента в таблице маркеров и IP-адресом, с которого сделан запрос. Поэтому процесс проверки маркера завершается сбоем, что приводит к сбою при восстановлении файла.

    Resolution

    Использование NAT с Avamar FLR не поддерживается. Вот рекомендуемые шаги:

    1. Отключите DNAT:

      • Совместно с сетевым отделом отключите DNAT для среды, в которой используется Avamar FLR. Это наиболее эффективный способ гарантировать, что операции FLR могут выполняться без несоответствия IP-адресов.
    2. Определите, активирован ли DNAT.

      • Вместе с сетевыми специалистами уточните, включен ли DNAT. В примерах журналов могут отображаться несовпадающие IP-адреса исходной системы, например 192.168.1.1, которые могут быть IP-адресами шлюза из-за DNAT.
    3. Временное решение. Отключите рабочий процесс BatchDownload.exe/WGET:

    В качестве временного решения можно отключить рабочий процесс BatchDownload.exe и заставить FLR использовать вместо него операции с гостевыми файлами vSphere. Это влияет на скорость выполнения операций FLR, замедляя их работу.
    I. На прокси отредактируйте конфигурационный файл:
    /usr/local/avamarclient/bin/config.xml
    II.  Измените следующую строку с:
    <enablewgetrestore>1</enablewgetrestore>
    Для этого: 
    <enablewgetrestore>0</enablewgetrestore>

    III. После внесения изменений в конфигурацию перезапустите vmwareflr.service.
    systemctl restart vmwareflr && systemctl restart avagent.service
         

    Affected Products

    Avamar
    Article Properties
    Article Number: 000283981
    Article Type: Solution
    Last Modified: 22 May 2025
    Version:  2
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.