Avamar: Gendannelse af VMware-filniveau kan mislykkes på grund af NAT-konfiguration

Summary: Denne Knowledge Base-artikel har til formål at løse de problemer, der er opstået ved brug af Avamar File Level Restore (FLR) med NAT (Network Address Translation). FLR-handlinger kan mislykkes på grund af IP-uoverensstemmelser forårsaget af NAT. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • FLR-job starter oprindeligt, men fuldføres ikke.
  • Mindre filer (f.eks. 20 KB til 2,7 MB) gendannes, men større filer (f.eks. 25 MB eller 90 MB) mislykkes.
  • Dette problem påvirker alle virtuelle maskiners gendannelse på filniveau i dette miljø.
  • HTTP-server (anløbsbro) 500-fejl vises i adgangslogfiler under gendannelsesforsøg.
  • Anløbsbroens adgangslog viser usædvanlige IP-adresser (f.eks. klient-IP'en, der ender på 0,1 eller 0,254, hvilket sandsynligvis er en gateway-adresse).

Cause

Problemet opstår på grund af den måde, FLR håndterer filoverførselsoperationer på, afhængigt af jobstørrelsen:

  1. Små gendannelsesjob:

    • Når FLR-jobbet overfører en lille mængde data (samlede byte < 5 MB og samlede filer < 10), bruges vSphere API til at gendanne filer. vSphere API-filoverførsler omgår VM NAT-konfigurationer, da VM-gæstenetværket ikke er involveret i overførslen.
  2. Store gendannelsesjob:

    • For større FLR-job, der overgår de små gendannelsesjobkriterier, skifter Avamar til at bruge sikre wget/BatchDownload-scripts til at overføre filer mere effektivt.
    • Denne metode opretter midlertidige filer og tokens til at administrere den sikre overførsel, som er afhængig af, at klientens IP-adresse matcher en forventet værdi.

Når NAT er aktiveret i netværket, ændres klientens kilde-IP-adresse i anmodningen. Dette medfører en uoverensstemmelse mellem den gemte klient-IP i tokentabellen og den IP-adresse, hvorfra anmodningen foretages. Derfor mislykkes tokenbekræftelsesprocessen, hvilket fører til fejl i filgendannelse.

    Resolution

    Brug af NAT med Avamar FLR understøttes ikke. Her er de anbefalede trin:

    1. Deaktiver DNAT:

      • Samarbejd med netværksteamet om at deaktivere DNAT for det miljø, hvor Avamar FLR bruges. Dette er den mest effektive måde at sikre, at FLR-handlinger kan fortsætte uden uoverensstemmelser i IP-adresser.
    2. Identificer, om DNAT er aktiveret:

      • Bekræft med netværksteamet, om DNAT er aktiveret. Eksempellogfiler kan vise uoverensstemmende kilde-IP'er som 192.168.1.1, som kan være gatewayens IP på grund af DNAT.
    3. Løsning – Deaktiver BatchDownload.exe/wget-arbejdsgang:

    Du kan løse problemet ved at deaktivere arbejdsprocessen for BatchDownload.exe og tvinge FLR til at bruge vSphere-gæstefilhandlinger i stedet. Dette påvirker hastigheden af FLR-operationer, hvilket gør dem langsommere.
    I. Rediger konfigurationsfilen på proxyen:
    /usr/local/avamarclient/bin/config.xml
    II.  Skift følgende linje fra:
    <enablewgetrestore>1</enablewgetrestore>
    Til dette: 
    <enablewgetrestore>0</enablewgetrestore>

    III. Når du har foretaget konfigurationsændringen, skal du genstarte vmwareflr.service.
    systemctl restart vmwareflr && systemctl restart avagent.service
         

    Affected Products

    Avamar
    Article Properties
    Article Number: 000283981
    Article Type: Solution
    Last Modified: 22 May 2025
    Version:  2
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.