PowerProtect: Oracle Incremental Merge (OIM) -varmuuskopiointi ARCHIVELOG- tai CONTROLFILE-tiedostolle epäonnistuu

Summary: ARCHIVELOG- tai CONTROLFILE -Oracle Incremental Merge (OIM) -varmuuskopiointi epäonnistuu, mutta niiden varmuuskopiointi onnistuu, kun se suoritetaan täyden tai lisäävän varmuuskopioinnin osana. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Oracle-tietokannan täydellinen tai lisäävä varmuuskopiointi OIM (Incremental Merge) -toiminnolla sisältää varmuuskopiolokin (ARCHIVELOG) ja hallintatiedostot.

Jos OIM-varmuuskopio sisältää vain CONTROLFILE- tai ARCHIVELOG-tiedoston, varmuuskopiointi voi epäonnistua ja aiheuttaa virheen:

sub directory creation failed Unable to open PowerProtect DD dir path: oim_qa/CLIENT_NAME.DOMAIN.COM/2720304786/controlfile/tags.json 

Opening the directory 'oim_qa/ CLIENT_NAME.DOMAIN.COM /2720304786/controlfile/tags.json' failed [5008] ([249168] [140483246442560]

ddp_open_dir() failed, su_name=, path_name=oim_qa/CLIENT_NAME.DOMAIN.COM/2720304786/controlfile/tags.json, Err: 5008-not a directory

Cause

Ongelma ilmenee, kun RMAN Agent -ohjelmisto ei pysty tunnistamaan oikein Data Domain -varmuuskopiorakenteissa olevia CONTROLFILE- ja ARCHIVELOG-tiedostoja.
Esimerkiksi: Kun varmuuskopiot on aiemmin poistettu manuaalisesti ddutil-komennolla:

./ddutil -O OIM -n [arch|full|ctl|incr] -a version=2.0 -b <begin_time> -e <end_time> -d -z <DD_host>:/<storage_unit> <Backup Path>. 

 

Resolution

Ongelma on korjattu RMAN Agentin versiossa 19.20 ja sitä uudemmissa versioissa.

  • Käytettävissä on kiertotapa, joka vaatii tarvittaessa teknistä tukea. Jos näin on, lähetä tukipyyntö ja viittaa tähän artikkeliin.

Affected Products

Oracle RMAN agent

Products

PowerProtect App Direct
Article Properties
Article Number: 000312073
Article Type: Solution
Last Modified: 07 Aug 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.