NVP-vProxy: FLR-Mount schlägt fehl "REST-Service ist auf DD-Hostname deaktiviert"

Summary: Eine NetWorker VMware Protection (NVP) Virtual Machine (VM) Restore auf Dateiebene (File Level Restore – FLR) kann nicht gemountet werden. Die Wiederherstellung mit sofortigem Zugriff schlägt möglicherweise ebenfalls fehl. Die Fehlerprotokollierung gibt zurück, dass sich der vProxy nicht bei der Data Domain anmelden konnte, da der REST-Service auf der Data Domain deaktiviert ist. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Der NVP-FLR-Mount-Vorgang oder die sofortige Recovery schlägt mit dem folgenden Fehler fehl:

159373:nsrvproxy_flr: vProxy Log: YYYY-MM-DDTHH:mm:SSZ ERROR:  [@(#) Build number: ##] Unable to create NFS export at 'DD_HOSTNAME:/data/col1/NETWORKER_MTREE/FLR-nsr-VPROXY_NAME-ABC-###': Unable to login while creating NFS export at 'DD_HOSTNAME:/data/col1/NETWORKER_MTREE/FLR-nsr-VPROXY_NAME-ABC-###': Failed to login to DataDomain service at 'https:/DD_HOSTNAME:3009/rest/v1.0/auth'.  A 'POST' method to DataDomain at 'https:/DD_HOSTNAME:3009/rest/v1.0/auth' responded with code 400.  Failed to decode error message:  Failed to decode type '*datadomain.DataDomainApiError' from '<?xml version="1.0" encoding="UTF-8"?>
159373:nsrvproxy_flr: vProxy Log: YYYY-MM-DDTHH:mm:SSZ ERROR:  [@(#) Build number: ##] <service_status><details>**** REST service is disabled on "DD_HOSTNAME".</details><code>5454</code></service_status>
159373:nsrvproxy_flr: vProxy Log: YYYY-MM-DDTHH:mm:SSZ ERROR:  [@(#) Build number: ##] ': invalid character '<' looking for beginning of value
152793:nsrvproxy_flr: vProxy Log Ends =================================================
150017:nsrvproxy_flr: Saveset Mount was terminated...

Diese Fehlermeldung wird während der Wiederherstellung im NMC-Wiederherstellungsassistenten (NetWorker Management Console) angezeigt. Diese finden Sie auch in den Wiederherstellungsprotokollen:

Für FLR:

NetWorker-Server:

  • Linux: /nsr/logs/adhoc/nsrvproxy_flr/jobid.Log
  • Windows: C:\Programme\EMC NetWorker\nsr\logs\adhoc\nsrvproxy_flr\jobid.log
vProxy:
  • Der Job wird aktiv ausgeführt: /opt/emc/vproxy/runtime/logs/vflrd/mount-SESSION-ID.log
  • Vorherige (abgeschlossene) Jobs: /opt/emc/vproxy/runtime/logs/recycle/vflrd/DATE/mount-SESSION-ID.log
Für sofortige Recovery:

NetWorker-Server:

  • Linux: /nsr/logs/recover/RECOVER-SESSION-NAME.Log
  • Windows: C:\Program Files\EMC NetWorker\nsr\logs\recover\RECOVER-SESSION-NAME.Log
vProxy:  /opt/emc/vproxy/runtime/logs/recycle/vrecoverd/DATE/InstantRecover-SESSION-ID.log

Cause

Der REST-Service ist auf der Data Domain deaktiviert.

sysadmin@ddve01# adminaccess show
Service       Enabled   Allowed Hosts
-----------   -------   -------------
ssh           yes       -
scp           yes       (same as ssh)
telnet        no        -
ftp           no        -
ftps          no        -
http          no        -
https         yes       -
web-service   no        N/A
-----------   -------   -------------

Während der FLR- oder Instant Access-Recovery stellt die vProxy-Appliance eine Verbindung mit Data Domain her und authentifiziert sich mit einem Data Domain-Administratorkonto. Dieser Prozess ist erforderlich, um die NFS-Datenspeicher (Network File System) zu erstellen, die für FLR- und Instant Recover-Verfahren erforderlich sind. Wenn der REST-Service auf der Data Domain deaktiviert ist, kann sich die vProxy-Appliance nicht bei der DD authentifizieren und kann den NFS-Datenspeicher nicht erstellen.

Resolution

  1. Öffnen Sie eine SSH-Sitzung auf der Data Domain und melden Sie sich als sysadmin an.
  2. Web-Service aktivieren: adminaccess enable web-service
  3. Überprüfen Sie, ob der Webdienst jetzt als aktiviert angezeigt wird: adminaccess show
  4. Durchführen der VM-Recovery

Siehe: Data Domain: REST-API-Fehler – REST-Service ist deaktiviert

Affected Products

Data Domain, NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000397486
Article Type: Solution
Last Modified: 28 Nov 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.