Avamar: A restauração do arquivo falha com o erro "Unable to BackupWrite"

Summary: A restauração do arquivo apresenta falha com o erro "Unable to BackupWrite" devido a permissões insuficientes da conta SYSTEM local para gravar na pasta especificada.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Erro de falha de restauração.

A restauração de arquivos usando o plug-in do sistema de arquivos do Windows pode falhar e produzir o erro abaixo:

  • Falha na operação de restauração 
  • A mensagem de erro é exibida
avtar Error <5737>: I/O error: Unable to BackupWrite(4)

Cause

Permissões insuficientes

A conta configurada para o serviço avagent (agente de backup) não tem permissões suficientes para gravar na pasta especificada.

Por padrão, o serviço avagent é executado com a conta SYSTEM local, que não tem o acesso necessário de leitura/gravação à pasta e subpastas de destino.

Esse problema de permissão é mostrado nesta mensagem de erro:

Error <5737>: I/O error: Unable to BackupWrite(4)

 

Resolution

Restaurando a funcionalidade de backup de arquivo

Para resolver o problema, conceda à conta SYSTEM local acesso de leitura/gravação à pasta e subpastas de destino. Isso pode ser feito modificando as permissões da pasta.

Siga estas etapas para ajustar as permissões:

  • Localize a pasta de destino no Windows Explorer.
  • Clique com o botão direito do mouse na pasta e selecione Propriedades.
  • Na janela Propriedades, vá para a guia Segurança.
  • Clique em Edit para alterar as permissões.
  • Na janela Permissions, clique em Add.
  • Digite "SYSTEM" no campo Enter the object names to select e clique em Check Names.
  • Depois que a conta do SISTEMA for adicionada, selecione-a e marque as caixas de permissão de leitura e gravação.
  • Clique em Apply e em OK para salvar as alterações.

Como alternativa, configure o serviço Backup Agent para ser executado com uma conta de usuário de domínio com, no mínimo, privilégios de leitura/gravação na pasta de destino.

  1. Configure os serviços do Avamar:

    • Abra o console de gerenciamento de serviços (services.msc).
    • Localize o serviço Avamar Backup Agent.
    • Clique com o botão direito do mouse no serviço e selecione Propriedades.
    • Vá para a guia Logon.
    • Selecione Essa conta e digite as credenciais do usuário do domínio (nome de usuário e senha).
    • Clique em Aplicar e, em seguida, em OK.
  2. Reinicie o serviço: Volte para a guia Geral e clique em Iniciar para reiniciar o serviço.

    Depois de atualizar as permissões, verifique se o problema foi resolvido tentando restaurar arquivos usando o plug-in do sistema de arquivos do Windows.

    Se os problemas persistirem, entre em contato com o Suporte Dell para obter assistência.

    Affected Products

    Avamar Client for Windows

    Products

    Avamar, Avamar Client
    Article Properties
    Article Number: 000030795
    Article Type: Solution
    Last Modified: 20 May 2025
    Version:  4
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.