Avamar. Сбой резервного копирования Hyper-V с ошибкой «Не удалось извлечь файлы резервных копий vss для всех целевых устройств».

Summary: В этой статье базы знаний (KB) описывается решение, касающееся сбоя резервного копирования Hyper-V из-за работы модулей записи служб теневого копирования томов (VSS).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Может произойти сбой резервного копирования Avamar Hyper-V с ошибками, подобными следующим: 

avhypervvss Error <41606>: Failed to fetch vss backup files for all the targets. Internal error.
avhypervvss Error <41586>: Failed to backup targets. Unable to assign vss reported backup files for all targets
avhypervvss Error <41662>: Failed to validate and expand the targets.
avhypervvss Error <41659>: Backup did not complete successfully

Cause

Возможно, модуль записи VSS Hyper-V находится в состоянии сбоя. Это можно проверить, открыв командную строку Windows или PowerShell и выполнив vssadmin list writers (без кавычек):
 

Writer name: 'Microsoft Hyper-V VSS Writer'
   Writer Id: {66841cd4-6ded-4f4b-8f17-fd23f8ddc3de}
   Writer Instance Id: {5713fd6b-5154-4a3b-a6ef-4973bfea66c9}
   State: [1] Failed
   Last error: No error



 

Resolution

Откройте файл services.msc консоли и перезапустите службу управления виртуальными машинами Hyper-V на хост-компьютере Hyper-V. 

Консоль управления службами MS

 

Убедитесь, что устройство записи VSS Hyper-V находится в хорошем или стабильном состоянии, выполнив следующую команду из командной строки Windows или PowerShell:

vssadmin list writers

 

Affected Products

Avamar, Avamar Plug-in for Hyper-V VSS, Integrated Data Protection Appliance Family
Article Properties
Article Number: 000039786
Article Type: Solution
Last Modified: 11 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.