PowerScale OneFS: <Yol> için <İstemci IP>sinden bağlama isteği başarısız oldu
Summary: Yinelenen "İsteği bağlama yeri" uyarılarını ele alma.
Symptoms
En büyük suçlulardan biri aşağıdaki uyarıdır:
Recurring: Mount request from <Client IP Address> on <Node IP Address> for <Share> failed with errno: <2 or 13>
Bu uyarıyı doğru şekilde ele alarak CELOG üzerindeki yükü azaltabilir ve uyarı/olay çalışmasını ve raporlamasını iyileştirebiliriz.
Cause
İstemci, dışa aktarma olarak mevcut olmayan veya erişim iznine sahip olmayan bir paylaşıma erişmeye çalışarak bu uyarıları tetikler.
Güvenlik tarayıcıları, InsightIQ veya Ağ Dosya Sistemi (NFS) Hizmetleri etkinleştirilmiş olabilecek Windows istemcileri genellikle bu uyarıları tetikler.
Resolution
Bu uyarıları düzgün bir şekilde ele almak için, belirtilen Paylaşıma sorunlu İstemci IP Adresinden kimin eriştiğini belirlememiz gerekir:
# isi event events list | grep "Mount.*fail" | awk '{print $10}' | sort | uniq -c | sort -rn
110 xxx.xxx.xxx.57
63 xxx.xxx.xxx.63
61 xxx.xxx.xxx.54
39 xxx.xxx.xxx.55
37 xxx.xxx.xxx.250
37 xxx.xxx.xxx.240
24 xxx.xxx.xxx.61
23 xxx.xxx.xxx.65
22 xxx.xxx.xxx.44
20 xxx.xxx.xxx.45
19 xxx.xxx.xxx.56
16 xxx.xxx.xxx.62
Ve yaşadıkları başarısızlık:
# isi event events list | grep "Mount.*fail" |awk '{print $NF}' | sort | uniq -c|sort -rn
876 STATUS_NOT_FOUND
63 STATUS_ACCESS_DENIED
Yukarıdaki bilgilerle, dışa aktarımlara kimin erişmeye çalıştığını ve bunun neden başarısız olduğunu belirleyebilir ve böylece bir olay oluşturabilirsiniz.
Soruna neden olan istemcileri ele almak mümkün değilse uyarılar OneFS 9.3 ve üzeri sürümlerden başlayarak bastırılabilir.
WebUI'da bu, Olaylar ve Uyarılar - >Uyarı Yönetimi ->Olay Türü Kimliğinde bağlama araması altında yapılabilir.
CLI'dan aşağıdaki komut kullanılabilir:
# isi event suppress modify --suppress=true --id=400130001
Olay Kimliği, sayfa 54'teki aşağıdaki belgede görülebilir.