VBA 크랙: Var 파일 시스템에 사용 가능한 공간이 없습니다.
Summary: NetWorker VBA(VMware Backup Appliance)의 /var 파일 시스템이 가득 찼습니다.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
참고: NetWorker VBA(VMware Backup Appliance)는 더 이상 지원되지 않습니다. 이제 VMware 보호는 NVP(NetWorker VMware Protection) vProxy 어플라이언스를 사용하여 수행됩니다.
VBA /var 파일 시스템이 꽉 찼습니다.
admin@VBA-Name:~/>: df -kh
Filesystem Size Used Avail Use% Mounted on
/dev/sda2 7.9G 5.7G 1.8G 77% /
udev 3.9G 136K 3.9G 1% /dev
tmpfs 3.9G 0 3.9G 0% /dev/shm
/dev/sda1 130M 38M 86M 31% /boot
/dev/sda7 1.5G 1.4G 0 100% /var
/dev/sda9 70G 13G 54G 20% /space
/dev/sdb1 256G 20G 237G 8% /data01
/dev/sdd1 256G 13G 244G 5% /data02
/dev/sdc1 256G 12G 245G 5% /data03
Cause
Tomcat은 포트 9443을 수신하고 tomcat 서비스가 실행되지 않을 때마다 tomcat 서비스에 액세스하려고 할 때마다 tomcat이 실행되지 않는 것과 관련된 오류가 /var/log/apache2/mod_jk.log에 플러딩됩니다.
메모: 기본 웹 서비스 구성은 보존되는 로그의 수나 각 로그의 크기를 제한하지 않습니다. 대규모 작업이 있는 환경에서는 기본 tomcat 웹 서비스 구성으로 인해 var 파일 시스템이 가득 찰 수 있습니다.
Resolution
vProxy 어플라이언스에서 다음을 수행합니다.
1. VBA에 대한 SSH 세션을 열고 admin으로 로그인한 다음 루트로 전환합니다.
2. 디렉토리를 apache2 디렉토리로 변경합니다.
cd /var/log/apache2/
3. 다음 du 명령을 사용하여 디스크 공간 사용량을 확인합니다.
root@ VBA-Name:/var/log/apache2/#: du -sh
1.3G
4. 다음 ls 명령을 실행하여 파일 크기 및 디스크 사용량을 검토합니다.
root@ VBA-Name:/var/log/apache2/#: ls -lhtr
total 1.3G
-rw-r----- 1 root root 53K Aug 28 2016 access_log-20160828.bz2
-rw-r----- 1 root root 27K Sep 14 2016 ssl_request_log-20160914.bz2
-rw-r----- 1 root root 30K Oct 14 2016 ssl_request_log-20161014.bz2
-rw-r----- 1 root root 56K Nov 3 2016 access_log-20161103.bz2
-rw-r----- 1 root root 25K Nov 13 2016 ssl_request_log-20161113.bz2
-rw-r----- 1 root root 27K Dec 13 2016 ssl_request_log-20161213.bz2
-rw-r----- 1 root root 51K Jan 9 2017 access_log-20170109.bz2
-rw-r----- 1 root root 26K Jan 12 2017 ssl_request_log-20170112.bz2
-rw-r----- 1 root root 26K Feb 11 2017 ssl_request_log-20170211.bz2
-rw-r----- 1 root root 30K Mar 13 2017 ssl_request_log-20170313.bz2
-rw-r----- 1 root root 56K Mar 17 2017 access_log-20170317.bz2
-rw-r----- 1 root root 28K Apr 11 2017 ssl_request_log-20170411.bz2
-rw-r----- 1 root root 28K May 11 12:30 ssl_request_log-20170511.bz2
-rw-r----- 1 root root 54K May 23 12:30 access_log-20170523.bz2
-rw-r----- 1 root root 39K Jun 7 12:30 ssl_request_log-20170607.bz2
-rw-r----- 1 root root 31K Jul 6 12:30 ssl_request_log-20170706.bz2
-rw-r----- 1 root root 70K Jul 22 12:30 access_log-20170722.bz2
-rw-r----- 1 root root 29K Aug 4 12:30 ssl_request_log-20170804.bz2
-rw-r----- 1 root root 30K Sep 1 12:30 ssl_request_log-20170901.bz2
-rw------- 1 root root 10 Oct 16 02:43 rcapache2.out
-rw-r----- 1 root root 2.6M Nov 7 10:46 ssl_request_log
-rw------- 1 root root 1.2G Nov 7 10:46 mod_jk.log
-rw------- 1 root root 292K Nov 7 10:46 error_log
-rw-r----- 1 root root 3.8M Nov 7 10:46 access_log
참고: mod_jk.log 파일은 apache2 디스크 사용량의 대부분을 차지합니다.
5. 서비스를 중지합니다.
root@ VBA-Name:/var/log/apache2/#: website stop
===Shutting down website
Shutting down httpd2 (waiting for all children to terminate) done
root@ VBA-Name:/var/log/apache2/#: rm mod_jk.log
7. 웹 사이트 서비스를 시작합니다.
root@ VBA-Name:/var/log/apache2/#: website start
===Starting website
Starting httpd2 (prefork) done
8. 디스크 공간 사용량이 감소했는지 확인합니다.
root@ VBA-Name:/var/log/apache2/#: df -kh
Filesystem Size Used Avail Use% Mounted on
/dev/sda2 7.9G 5.7G 1.8G 77% /
udev 3.9G 136K 3.9G 1% /dev
tmpfs 3.9G 0 3.9G 0% /dev/shm
/dev/sda1 130M 38M 86M 31% /boot
/dev/sda7 1.5G 172M 1.2G 13% /var
/dev/sda9 70G 13G 54G 20% /space
/dev/sdb1 256G 21G 235G 9% /data01
/dev/sdd1 256G 13G 244G 5% /data02
/dev/sdc1 256G 12G 245G 5% /data03
9. 새 mod_jk.log 생성되었는지 확인합니다.
root@ VBA-Name:/var/log/apache2/#: ls -lhtr | grep -i mod_jk.log
-rw------- 1 root root 600 Nov 8 14:32 mod_jk.log
Additional Information
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000040499
Article Type: Solution
Last Modified: 22 Apr 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.