VxRail: Redirecting system logs to a vSAN object causes an ESXi host lock up

Summary: Host going into non-responsive state and unable to run any cli commands.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


When systems logs or the ESXi host scratch partition are stored on the vSAN datastore, it can cause the ESXi host to become unresponsive to vCenter Server and the host CLI.

SSH to the affected node and run ls -ltrh which lists the file partition details.

To verify if the host is configured with a default scratch partition run the below command and check the local log output field.
 

localcli system syslog config get


Example:

SyslogConfiguration:
   Default Network Retry Timeout: 180
   Dropped Log File Rotation Size: 100
   Dropped Log File Rotations: 10
   Enforce SSL Certificates: false
   Local Log Output: /scratch/log  
   Local Log Output Is Configured: false
   Local Log Output Is Persistent: true
   Local Logging Default Rotation Size: 1024
   Local Logging Default Rotations: 8
   Log To Unique Subdirectory: false
   Message Queue Drop Mark: 90
   Remote Host: udp://192.168.10.XXX:514

Cause

In certain rare scenarios, the system logger and other processes on the ESXi host may not be able to update files in the scratch space. This is typically, though not exclusively, associated with another event that causes vSAN storage operations to fail to process IO from these processes. When this issue occurs, it can cause the host to become non-responsive, including the inability to interact with the host via a command-line interface

Resolution

If this issue occurs, reboot the ESXi host to recover manageability of the host.

After reboot change back the scratch location to default /scratch/log , run the below command to set /scratch/log
 

esxcli system syslog config set --logdir=/scratch/log


To prevent this issue from occurring, do not store system logs or scratch locations on the vSAN datastore.
 
For more information about configuring system scratch partitions and the syslog configuration, see:

Additional Information

To prevent this issue occurring, do not store system logs or scratch locations on the vSAN datastore. See VMware KB: Redirecting system logs to a vSAN object causes an ESXi host lock upThis hyperlink is taking you to a website outside of Dell Technologies. 
 

Affected Products

VxRail, VxRail Appliance Series, VxRail Software
Article Properties
Article Number: 000040607
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  4
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