Менеджер даних PowerProtect: Виявлення SQL Agent не показує жодних ресурсів у розділі Assets/SQL DATABASES

Summary: У цій статті розглядається проблема, коли SQL бази даних не відображаються після запуску виявлення.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ресурси > SQL БАЗИ даних не показують жодних SQL-баз даних після ручного запуску Discover кілька разів.

У SQL Server журнал ADM показує (ADM log: C:\Program Files\DPSAPPS\MSAPPAGENT\ADM Agent\logs):

...
(

Disposition: form-data; name="results"; filename="C:\\Windows\\TEMP\\ecdmruncmd775979743"
Content-Type: application/octet-stream

{
    "response": {
        "APIVersion": "2.2",
        "applicationInstances": []
    },
    "errors": [
        {
            "type": "systemErr",
            "text": "General exception when detecting AAG information for SQL Server '<SQL SERVER name>'.\n"
        }
    ]
}

 

Cause

PowerProtect Database Manager Console не може підключитися до SQL-сервера через обліковий запис LocalSystem.

 

Resolution

Процедура:

  1. На Windows SQL Server перейдіть на services.msc.
  2. Виберіть агента ADM .
  3. Клацніть правою кнопкою миші та виберіть Властивості.
  4. Натисніть «Увійти».
  5. Натисніть «Цей обліковий запис » і введіть користувача Windows з доступом до SQL-сервера.
    Примітка: Іноді програмне забезпечення працює краще, якщо користувач Windows також є адміністратором домену. Якщо можливо, переконайтеся, що користувач Windows має доступ до SQL Server і є адміністратором домену.
  6. Перезапустіть сервіс.

 

Affected Products

PowerProtect Data Manager

Products

PowerProtect Data Manager, PowerProtect X400 Appliance
Article Properties
Article Number: 000042143
Article Type: Solution
Last Modified: 25 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.