PowerFlex: Logisches Volume auf Scini-Gerät wird nach dem Hochfahren nicht automatisch aktiviert

Summary: LVs (logisches Volume), die auf Scini-Geräten als physische Volumes (PVs) erstellt werden, werden nach dem SDC-Start nicht aktiviert.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SDC-Treiber wird geladen und scini*-Geräte werden erstellt, nachdem VGs und LVs während des Startvorgangs aktiviert wurden. Ein Volume wird während des Startvorgangs automatisch gemountet.

lvdisplay zeigt an, dass der LV-Status "Nicht verfügbar" ist:

lvdisplay zeigt an, dass der LV-Status

 

Auswirkungen

LV werden nicht automatisch aktiviert.

Cause

Standardmäßig verwendet lvmetad die ereignisbasierte LV-Aktivierung, stützt sich auf udev Regeln, um LVM-Metadaten in den Cache zu scannen, und aktiviert VGs und LVs, wenn neue Geräte, die PVs sind, konfiguriert werden. lvmetad funktioniert jedoch nicht mit scini-Geräten.

Wenn lvmetad deaktiviert ist, verwendet systemd  lvm-activation-generator um systemd-Einheiten zu erzeugen, um LVs an verschiedenen Punkten während der Boot-Sequenz zu aktivieren. Dies schließt jedoch nicht die Möglichkeit aus, dass die Aktivierung vor der Konfiguration von Scini-Geräten versucht wird.

Resolution

Fügen Sie die folgende Zeile hinzu in /etc/udev/rules.d/20-scini.rules Datei (60-scini.rules in älteren SDC-Versionen):

ACTION=="add", DEVPATH=="*scini*", RUN+="/sbin/lvm pvscan --cache --activate ay /dev/$name"

 

Wenn Sie RHEL7 verwenden, muss lvmetad auch in aktiviert sein. /etc/lvm/lvm.conf Damit diese Udev-Regel funktioniert:

use_lvmetad = 1

 

Bei Verwendung von RHEL8 ist lvmetad veraltet. Die udev-Regeln allein sind ausreichend.

 

Betroffene Versionen 

ScaleIO 2.x

VxFlex 3.0.x.x

PowerFlex 3.5.x

PowerFlex 3.6.x

Affected Products

PowerFlex appliance Intelligent Catalog Software, PowerFlex rack RCM Software, PowerFlex Software
Article Properties
Article Number: 000047739
Article Type: Solution
Last Modified: 27 Oct 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.