PowerFlex: Logisch volume op Scini apparaat wordt niet automatisch geactiveerd na het opstarten

Summary: LV's (logisch volume) die zijn gebouwd op scini-apparaten als fysieke volumes (PV's) worden niet geactiveerd na het opstarten van SDC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De SDC-driver wordt geladen en scini*-apparaten worden gemaakt nadat VG's en LV's zijn geactiveerd tijdens het opstartproces. Tijdens het opstarten wordt automatisch een volume gekoppeld.

lvdisplay commando toont dat de LV-status "Not available" is:

lvdisplay geeft aan dat de LV-status

 

Impact

LV worden niet automatisch geactiveerd.

Cause

lvmetad maakt standaard gebruik van op gebeurtenissen gebaseerde LV-activering, is afhankelijk van udev regels om LVM-metadata in de cache te scannen, en activeert VG's en LV's wanneer nieuwe apparaten die PV's zijn, worden geconfigureerd. lvmetad werkt echter niet met scini-apparaten.

Als lvmetad is uitgeschakeld, gebruikt de systemd  lvm-activation-generator om systemd-eenheden te genereren om LV's op verschillende punten tijdens de opstartvolgorde te activeren. Dit sluit de mogelijkheid niet uit dat de activering kan worden geprobeerd voordat scini-apparaten worden geconfigureerd.

Resolution

Voeg de volgende regel toe aan /etc/udev/rules.d/20-scini.rules bestand (60-scini.rules in oudere SDC-versies):

ACTION=="add", DEVPATH=="*scini*", RUN+="/sbin/lvm pvscan --cache --activate ay /dev/$name"

 

Als u RHEL7 gebruikt, moet lvmetad ook worden ingeschakeld in /etc/lvm/lvm.conf Om deze udev-regel te laten werken:

use_lvmetad = 1

 

Als u RHEL8 gebruikt, is lvmetad verouderd. De udev-regels alleen zijn voldoende.

 

Versies waarop dit van toepassing is 

ScaleIO 2.x

VxFlex 3.0.x.x

PowerFlex 3.5.x

PowerFlex 3.6.x

Affected Products

PowerFlex appliance Intelligent Catalog Software, PowerFlex rack RCM Software, PowerFlex Software
Article Properties
Article Number: 000047739
Article Type: Solution
Last Modified: 27 Oct 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.