SourceOne Discover Mnager - The transaction log for database 'DiscoveryManager' is full

Summary: Customer receives below error while performing Discovery manger search : The transaction log for database 'DiscoveryManager' is full due to 'ACTIVE_BACKUP_OR_RESTORE'.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



You receive the  below error while performing Discovery manger search :
The transaction log for database 'DiscoveryManager' is full due to 'ACTIVE_BACKUP_OR_RESTORE'. 

Stack Trace: 

at EMC.EX.DiscoveryCollector.Core.Commands.WebServiceCommandBase.ThrowException(Exception e) 
at EMC.EX.DiscoveryCollector.Core.Commands.GetNpmXmlCommand.Execute() 
at EMC.EX.DiscoveryCollector.Common.Framework.CAB.Services.ExPresentationService..ctor() 

Inner Stack Trace: 
Source: 
ExDisCoCore 
Target Site: 
Void ThrowException(System.Exception) 

Cause

A full backup of Discovery manger Database has not been taken for a long time and Transaction log file had not been backed up and flushed using up the space.

Resolution

Performed full backup of Discovery Manager database for reducing the size of transaction logs. 

Additional Information

Make Sure to suspend SourceOne servers before taking backup as provided in the administration guide.

Affected Products

SourceOne Discovery Manager

Products

SourceOne, SourceOne Discovery Manager
Article Properties
Article Number: 000051978
Article Type: Solution
Last Modified: 26 May 2025
Version:  4
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