VNX: Помилка CAVA VC: 3: 32: Сервер 'x.x.x.x' повернув помилку 'FAIL' під час перевірки файлу

Summary: Помилки в журналах перейменування даних вказують на те, що службі ВК не вдалося просканувати файл

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Під час перевірки на віруси в логах помилка, яка вказує на те, що сервіс ВК не зміг його перевірити:

2016-03-29 11:38:44: ВК: 3: 32: Сервер 'x.x.x.x' повернув помилку 'FAIL' під час перевірки файлу '\root_vdm_id\mount_path\filename.ext'

Cause

Повідомлення 'FAIL' виникає, коли відкривається запит на сканування (служба ВК на перейменовувачі даних надсилає запит на сервери CAVA), і коли сервер CAVA намагається його відкрити, файл не знаходить.  Це означає, що файл було видалено до того, як його можна було відсканувати.  Є кілька сценаріїв, коли це може статися:
  • Одним із способів цього є те, що файл був файлом cookie, тимчасовим файлом або файлом блокування.  Microsoft Office, наприклад, створює тимчасові файли у форматі ~$<original_filename.xxxx>.  Ці файли зазвичай зникають, коли файл зберігається або закривається, і якщо це відбувається швидко, файл може зникнути, перш ніж його встигнуть просканувати, що призведе до повідомлення FAIL у журналі перейменовувача даних.  Імена файлів, які не вдається сканувати, зазвичай вказують на це як джерело проблеми.
  • Іншим способом це може статися, якщо файл має спеціальне «розташування».  У SMB та SMB2 користувач може встановити диспозицію 'видалити при закритті' під час відкриття файлу.  Якщо файл, який було направлено на сканування, відкриває інший користувач із цим встановленим розташуванням, файл видаляється раніше, ніж його можна буде сканувати, що призводить до повідомлення FAIL у журналах перейменування даних.  Цей параметр можна побачити в трасуванні пакетів, переглянувши виклики SMB 'Create' або 'SetInfo', але його буде встановлено користувачем, який виконує видалення, а ймовірно, не серверами CAVA.  Це може ускладнити роботу, оскільки необхідно відстежувати звичайний трафік (а не лише AV-сервер), щоб визначити, хто встановлює прапорець.

Resolution

Найкращим рішенням є зупинка того, що видаляє файл (зовнішні користувачі видаляють файл).  Це може означати вимкнення використання тимчасових файлів в Office або зберігання інших тимчасових файлів чи файлів cookie в локальному каталозі замість спільного.  Якщо це неможливо зробити, то змініть viruschecker.conf, щоб виключити ці типи файлів з перевірки, змінивши рядок 'excl' для виключення ~$*.* (для файлів Office), *.tmp або будь-яке інше розширення, яке може спричиняти ці помилки.

viruschecker.conf:
CIFSserver=<Сервер CIFS на перейменовувачі
>даних addr=<configured CAVAсервери excl=~$*.*:*.accdb:*.laccdb:*.ldb:*.mdb:*.pst:*.tmp:????????
>
masks=*.*
shutdown=перевірка вірусів

Additional Information

додаткові ресурси:
https://support.microsoft.com/en-us/kb/211632 (Опис того, як Word створює тимчасові файли)
https://wiki.wireshark.org/SMB2/SMB2_FILE_DISPOSITION_INFO (SMB2_FILE_DISPOSITION_INFO адреси 'видаляти при закритті') функція

Affected Products

VNX1 Series

Products

Celerra, VNX1 Series, VNX2 Series
Article Properties
Article Number: 000052379
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.