Dell EMC Unity: Při pokusu o nahrání bitové kopie upgradu .gpg pomocí příkazu uemcli -upload dojde k chybě 0x100000a (oprava společností Dell EMC)
Summary: Nahrávání souborů do systému Dell EMC Unity prostřednictvím rozhraní UEMCLI selže kvůli nedostatku místa v oddílech Unity, ačkoli je v systému Unity dostatek volného místa.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Upgrade prostředí Dell EMC Unity OE
Pokus o upgrade pole Dell EMC Unity pomocí rozhraní Windows UEMCLI selže s obecnou chybou 0x100000a. Ta se zobrazí jako „There is not enough free disk space on the client machine to complete this operation“ a může se také zobrazit jako Error Code:0x100000a nebo Error Code:0x1000102
C:\Users\admin>uemcli… -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Exit code: 1
Output: Operation failed. Kód chyby: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Pokus o upgrade pole Dell EMC Unity pomocí rozhraní Windows UEMCLI selže s obecnou chybou 0x100000a. Ta se zobrazí jako „There is not enough free disk space on the client machine to complete this operation“ a může se také zobrazit jako Error Code:0x100000a nebo Error Code:0x1000102
C:\Users\admin>uemcli… -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Exit code: 1
Output: Operation failed. Kód chyby: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
I v poli Dell EMC Unity:
service@(none) spb:/$ uemcli … -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Uploaded 1.94 GB of 1.94 GB [ 100.0% ] at 36.44 MB/s
Operation failed. Kód chyby: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Cause
Systém Dell EMC Unity potřebuje dvaapůlkrát více místa pro upgradovanou bitovou kopii v těchto oddílech:
/cores
/var/tmp (which is from root partition, "/")
Řekněme, že pokud má bitová kopie operačního prostředí 2 GB, pak potřebujeme 5 GB volného místa ve složce /cores a přibližně totéž ve složce /var/tmp. V adresáři /var/tmp se může pokusit uvolnit staré bitové kopie, ale pokud v adresáři /cores není dostatek místa, dojde k selhání s chybou 0x1000000a.
/cores
/var/tmp (which is from root partition, "/")
Řekněme, že pokud má bitová kopie operačního prostředí 2 GB, pak potřebujeme 5 GB volného místa ve složce /cores a přibližně totéž ve složce /var/tmp. V adresáři /var/tmp se může pokusit uvolnit staré bitové kopie, ale pokud v adresáři /cores není dostatek místa, dojde k selhání s chybou 0x1000000a.
Resolution
V systému Dell EMC Unity povolte SSH a poté se přihlaste jako uživatel „service“.
NESPOUŠTĚJTE příkaz svc_purge_logs -c --force (může dojít k neočekávanému restartování procesoru úložiště, a dokonce k nedostupnosti dat).
Z výstupu svc_purge_logs -help:
--clear[-c] --force Attempts to clear space on the root filesystem.
Files will not be removed unless --force is used.
VÝSTRAHA: Using this option could cause irreversible
damage to the system.
Po přihlášení do pole Unity zadejte příkaz „df -h“, abyste měli jistotu, že je v oddílu „/“ alespoň 4,5 GB volného místa. Pokud tomu tak není, zkontrolujte vnitřní oddíly pomocí příkazů df a du.
Můžete také spustit příkaz svc_purge_logs -f a zkontrolovat výsledné sestavy využití fs. Opatrně odstraňte nechtěné soubory, POKUD víte jistě, že nejsou potřeba.
Pokud je v oddílu „/“ alespoň 4,5 GB volného místa, pravděpodobně došlo k problému s funkcí přenosu velkých souborů UEMCLI. V rozhraní UEMCLI verze 4.0.x pro systém Windows došlo k problému, který ovlivňuje možnost nahrávat soubory o velikosti téměř 2 GB (jedná se o 32bitové omezení).
Zde je návod, jak ověřit instalaci UEMCLI v místním systému Windows.
C:\Users\admin>uemcli -v
Version: 4.0.0.1.2825
Branch: upc-Unity.2.8
Revision:
308352
Dále pokračujte takto:
Pokud k tomuto problému dochází v rozhraní UEMCLI v poli Dell EMC Unity, je nejčastějším důvodem to, že v oddílu /cores není alespoň 5 GB volného místa.
Pokud se jedná o pole UnityVSA (virtuální), musí uživatel k provedení upgradu použít grafické uživatelské rozhraní Unisphere nebo vzdálený systém Unity. Pokud se jedná o hardware Unity, lze použít partnerský procesor úložiště, jak je uvedeno níže:
Postup upgradu pomocí partnerského procesoru úložiště v poli Unity (hardwarové modely):
NESPOUŠTĚJTE příkaz svc_purge_logs -c --force (může dojít k neočekávanému restartování procesoru úložiště, a dokonce k nedostupnosti dat).
Z výstupu svc_purge_logs -help:
--clear[-c] --force Attempts to clear space on the root filesystem.
Files will not be removed unless --force is used.
VÝSTRAHA: Using this option could cause irreversible
damage to the system.
Po přihlášení do pole Unity zadejte příkaz „df -h“, abyste měli jistotu, že je v oddílu „/“ alespoň 4,5 GB volného místa. Pokud tomu tak není, zkontrolujte vnitřní oddíly pomocí příkazů df a du.
Můžete také spustit příkaz svc_purge_logs -f a zkontrolovat výsledné sestavy využití fs. Opatrně odstraňte nechtěné soubory, POKUD víte jistě, že nejsou potřeba.
Pokud je v oddílu „/“ alespoň 4,5 GB volného místa, pravděpodobně došlo k problému s funkcí přenosu velkých souborů UEMCLI. V rozhraní UEMCLI verze 4.0.x pro systém Windows došlo k problému, který ovlivňuje možnost nahrávat soubory o velikosti téměř 2 GB (jedná se o 32bitové omezení).
Zde je návod, jak ověřit instalaci UEMCLI v místním systému Windows.
C:\Users\admin>uemcli -v
Version: 4.0.0.1.2825
Branch: upc-Unity.2.8
Revision:
308352
Dále pokračujte takto:
- Upgradujte rozhraní Windows UEMCLI na nejnovější verzi dostupnou na stránkách podpory.
- Spusťte rozhraní UEMCLI z partnerského procesoru úložiště, pokud upgrade UEMCLI v systému Windows není možný.
- Použijte grafické uživatelské rozhraní Unisphere
Pokud k tomuto problému dochází v rozhraní UEMCLI v poli Dell EMC Unity, je nejčastějším důvodem to, že v oddílu /cores není alespoň 5 GB volného místa.
Pokud se jedná o pole UnityVSA (virtuální), musí uživatel k provedení upgradu použít grafické uživatelské rozhraní Unisphere nebo vzdálený systém Unity. Pokud se jedná o hardware Unity, lze použít partnerský procesor úložiště, jak je uvedeno níže:
Postup upgradu pomocí partnerského procesoru úložiště v poli Unity (hardwarové modely):
- Přihlaste se do pole pomocí SSH a servisního účtu [Příklad: SPA je správcovský procesor úložiště a procesor SPB je partnerský/sekundární procesor úložiště.]
- Získejte soubor s bitovou kopií pro upgrade pomocí winSCP nebo sftp do složky /cores/service (pozor: od prostředí Unity OE 4.5 použijte místo toho umístění /cores/service/user).
- Zkopírujte bitovou kopii z primárního procesoru úložiště do partnerského/sekundárního procesoru úložiště:
Až do verze Unity OE 4.4.x: scp /cores/service/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service
Od verze Unity OE 4.5.x: scp /cores/service/user/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service/user
Od verze Unity OE 4.5.x: scp /cores/service/user/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service/user
- Odstraňte bitovou kopii z místního procesoru úložiště (v tomto příkladu SPA): rm /cores/service/Unity-4.x.x.xxxxxxx.tgz.bin.gpg
- Přihlaste se k partnerskému procesoru úložiště pomocí ssh: ssh peer
- Nahrajte soubory pomocí rozhraní UEMCLI: uemcli -d peer -u admin -securepassword -no -upload -f /path/to/gpgfile upgrade
- Spusťte upgrade dle plánu v případě potřeby pomocí rozhraní UEMCLI nebo grafického uživatelského rozhraní Unisphere
Additional Information
Příklad nahrání souboru s bitovou kopií pomocí partnerského procesoru úložiště:
service@(none) spa:~$ sftp anonymous@ftp.emc.com
sftp> get Unity-4.1.2.9257522.tgz.bin.gpg
Fetching /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg to Unity-4.1.2.9257522.tgz.bin.gpg
/pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg 100% 2042MB 5.8MB/s 05:54
sftp> bye
service@(none) spa:~$ scp /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg peer:/cores/service (for Unity OE 4.5 or above, use /cores/service/user instead)
Unity-4.1.2.9257522.tgz.bin.gpg
service@(none) spa:~$ ssh peer
Last login: Mon May 22 22:39:10 2017 from 128.221.255.100
service@(none) spb:~$ uemcli -d peer -u admin -securepassword -no -upload -f /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg upgrade
(for Unity OE 4.5 or above, use /cores/service/user instead)
Password:
Uploaded 1.99 GB of 1.99 GB [ 100.0% ] -PROCESSING-
Operation completed successfully.
service@(none) spb:~$ logout
Connection to peer closed.
service@(none) spa:~$ uemcli /sys/soft/ver show -detail
1: ID = INST_1
Type = installed
Version = 4.1.1.9138882
Release date = 2017-02-09 14:30:02
Image type =
Reboot required =
Pause allowed =
Image filename =
2: ID = CAND_1 <--- upgrade image is ready to proceed
Type = candidate
Version = 4.1.2.9257522
Release date = 2017-04-11 04:23:24
Image type = software
Reboot required = yes
Pause allowed = yes
Image filename = Unity-4.1.2.9257522.tgz.bin
service@(none) spa:~$ sftp anonymous@ftp.emc.com
sftp> get Unity-4.1.2.9257522.tgz.bin.gpg
Fetching /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg to Unity-4.1.2.9257522.tgz.bin.gpg
/pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg 100% 2042MB 5.8MB/s 05:54
sftp> bye
service@(none) spa:~$ scp /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg peer:/cores/service (for Unity OE 4.5 or above, use /cores/service/user instead)
Unity-4.1.2.9257522.tgz.bin.gpg
service@(none) spa:~$ ssh peer
Last login: Mon May 22 22:39:10 2017 from 128.221.255.100
service@(none) spb:~$ uemcli -d peer -u admin -securepassword -no -upload -f /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg upgrade
(for Unity OE 4.5 or above, use /cores/service/user instead)
Password:
Uploaded 1.99 GB of 1.99 GB [ 100.0% ] -PROCESSING-
Operation completed successfully.
service@(none) spb:~$ logout
Connection to peer closed.
service@(none) spa:~$ uemcli /sys/soft/ver show -detail
1: ID = INST_1
Type = installed
Version = 4.1.1.9138882
Release date = 2017-02-09 14:30:02
Image type =
Reboot required =
Pause allowed =
Image filename =
2: ID = CAND_1 <--- upgrade image is ready to proceed
Type = candidate
Version = 4.1.2.9257522
Release date = 2017-04-11 04:23:24
Image type = software
Reboot required = yes
Pause allowed = yes
Image filename = Unity-4.1.2.9257522.tgz.bin
Affected Products
Dell EMC Unity FamilyProducts
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
...
Article Properties
Article Number: 000052819
Article Type: Solution
Last Modified: 12 Dec 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.