Avamar: El respaldo falla; no se puede cargar la caché de hash
Summary: El respaldo de Avamar falla con los mensajes "No se puede cargar el archivo de caché de hash" y "No se pueden ejecutar varios respaldos con el mismo nombre de caché de hash al mismo tiempo" ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Un respaldo de Avamar falla inmediatamente después de iniciarse con los siguientes mensajes de error informados en los registros.
2017-03-18 18:11:06 avtar Error <5064>: Cannot open file '/usr/local/avamar/var/EMC/root_vdm_1_EMC_p_cache.dat' 2017-03-18 18:11:06 avtar Error <18907>: Unable to load hash cache file '/usr/local/avamar/var/EMC/root_vdm_1_EMC_p_cache.dat' (Log #1) 2017-03-18 18:11:06 avtar FATAL <5224>: Cannot run multiple backups with the same hash cache name at the same time. Consider changing VARDIR or using --cache-prefix option.
Cause
Causa raíz del problema
La falla del respaldo de Avamar se puede atribuir a dos causas principales:
- Una configuración incorrecta de los parámetros "vardir" o "--cache-prefix", lo que hace que varias instancias de avtar intenten acceder al mismo archivo de caché simultáneamente.
- Si el proceso avtar deja de responder, lo que puede ocurrir debido a que un respaldo antiguo o un proceso avtar se bloquea en el cliente de Linux o en el nodo acelerador del protocolo de administración de datos en red (NDMP), lo que hace que la caché se bloquee.
Los mensajes de error en los siguientes registros muestran la causa de las fallas.
2017-03-18 18:11:06 avtar Error <5064>: Cannot open file '/usr/local/avamar/var/EMC/root_vdm_1_EMC_p_cache.dat'
2017-03-18 18:11:06 avtar Error <18907>: Unable to load hash cache file '/usr/local/avamar/var/EMC/root_vdm_1_EMC_p_cache.dat'
2017-03-18 18:11:06 avtar FATAL <5224>: Cannot run multiple backups with the same hash cache name at the same time. Consider changing VARDIR or using --cache-prefix option.
Resolution
Resolución de la falla de respaldo de Avamar
Para resolver la falla del respaldo de Avamar, siga estos pasos:
Por la causa #1,
- Una configuración incorrecta de los parámetros "vardir" o "--cache-prefix"
- Compruebe si el cliente está apuntando al mismo archivo de caché que otro respaldo de cliente en curso. Si es cierto
- Compruebe la configuración del respaldo: Parámetros VARDIR o de prefijo de caché
- Compruebe las opciones avanzadas del conjunto de datos y el archivo de avtar.cmd cliente para asegurarse de que el cliente no esté configurado de modo que varios procesos avtar no apunten a los mismos archivos vardir/cache.
Por la causa #2, un proceso de respaldo/avtar antiguo dejó de responder en el cliente Linux o en el nodo acelerador de NDMP, lo que provocó el bloqueo de la caché. Para comprobarlo, siga estos pasos:
- Inicie sesión en el sistema como raíz.
- Detenga el servicio avagent para asegurarse de que no se intenten iniciar más respaldos
service avagent stop - Compruebe si hay procesos avtar en ejecución:
ps -ef | grep av- Si hay respaldos en ejecución, deténgalos desde la interfaz de usuario de Avamar Administrator. Como alternativa, utilice
kill - O bien,
kill -9 - Para forzar, cierre el proceso.
- Si hay respaldos en ejecución, deténgalos desde la interfaz de usuario de Avamar Administrator. Como alternativa, utilice
- Cuando se borren todos los procesos antiguos, reinicie avagent:
service avagent start - Pruebe el respaldo nuevamente.
Additional Information
Nota: El archivo avtar.cmd se encuentra en el nodo acelerador de NDMP en la dirección del cliente: /usr/local/avamar/var/<client>
Affected Products
AvamarProducts
AvamarArticle Properties
Article Number: 000054871
Article Type: Solution
Last Modified: 15 Aug 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.