Avamar: Back-up mislukt Kan hashcache niet laden

Summary: Avamar back-up mislukt met de melding Kan hashcachebestand niet laden en Kan niet meerdere back-ups met dezelfde hashcachenaam tegelijk uitvoeren

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Een Avamar-back-up mislukt onmiddellijk na het opstarten met de volgende foutmeldingen die in de logboeken worden gemeld.
 

2017-03-18 18:11:06 avtar Error <5064>: Cannot open file '/usr/local/avamar/var/EMC/root_vdm_1_EMC_p_cache.dat'
2017-03-18 18:11:06 avtar Error <18907>: Unable to load hash cache file '/usr/local/avamar/var/EMC/root_vdm_1_EMC_p_cache.dat' (Log #1)
2017-03-18 18:11:06 avtar FATAL <5224>: Cannot run multiple backups with the same hash cache name at the same time. Consider changing VARDIR or using --cache-prefix option.

Cause

Hoofdoorzaak van het probleem

De Avamar back-upfout kan worden toegeschreven aan twee hoofdoorzaken:

  • Een verkeerde configuratie van de parameters 'vardir' of '--cache-prefix', waardoor meerdere avtar-instanties tegelijkertijd toegang proberen te krijgen tot hetzelfde cachebestand.
  • Als het avtar-proces niet meer reageert, kan dit gebeuren doordat een oude back-up of avtar-proces vastloopt op de Linux-client of het Network Data Management Protocol (NDMP)-acceleratorknooppunt, waardoor de cache wordt vergrendeld.

De foutmeldingen in de onderstaande logboeken geven de oorzaak van de fouten weer.

2017-03-18 18:11:06 avtar Error <5064>: Cannot open file '/usr/local/avamar/var/EMC/root_vdm_1_EMC_p_cache.dat'
2017-03-18 18:11:06 avtar Error <18907>: Unable to load hash cache file '/usr/local/avamar/var/EMC/root_vdm_1_EMC_p_cache.dat'
2017-03-18 18:11:06 avtar FATAL <5224>: Cannot run multiple backups with the same hash cache name at the same time. Consider changing VARDIR or using --cache-prefix option.



 

Resolution

De Avamar back-upfout oplossen

Volg deze stappen om de Avamar-back-upfout op te lossen:

Voor oorzaak #1,

  • Een verkeerde configuratie van de parameters 'vardir' of '--cache-prefix'
    • Controleer of de client naar hetzelfde cachebestand wijst als een ander clientback-upbestand dat bezig is. Indien waar
    • Controleer de configuratie van de back-up:  Parameters voor VARDIR of cache-prefix
  • Controleer de geavanceerde opties van de dataset en het client-avtar.cmd bestand om er zeker van te zijn dat de client niet zo is geconfigureerd dat meerdere avtar-processen niet naar dezelfde vardir/cache-bestanden verwijzen.

Voor oorzaak #2 reageert een oud back-up/avtar-proces niet meer op de Linux-client of NDMP-acceleratorknooppunt, waardoor de cache werd vergrendeld. Om dit te controleren, volgt u deze stappen:

  • Meld u aan bij het systeem als root.
  • Stop de avagent-service om ervoor te zorgen dat er geen verdere back-uppogingen worden gestart
    service avagent stop
        
  • Controleer of avtar-processen worden uitgevoerd:
    ps -ef | grep av
    • Als er back-ups worden uitgevoerd, stopt u deze via de Avamar Administrator UI. U kunt ook
      kill 
    • Of
      kill -9 
    • Om te forceren, sluit u het proces. 
  • Wanneer alle oude processen zijn gewist, start u avagent opnieuw:
    service avagent start
  • Test de back-up opnieuw.

     

Additional Information

Opmerking: Het avtar.cmd bestand bevindt zich op het NDMP-versnellerknooppunt onder de clientrichtr.: /usr/local/avamar/var/<client>  

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000054871
Article Type: Solution
Last Modified: 15 Aug 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.