AppSync:SudoユーザーがLinuxプラグインのインストールまたはアップデートに失敗する

Summary: AppSync:SudoユーザーがLinuxプラグインのインストールまたはアップデートに失敗する

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



sudoユーザーがLinuxプラグインのインストールまたはアップデートに失敗する

Linuxプラグイン ホスト上のディレクトリー構造は作成されますが、デフォルトの場所である/opt/emc/appsyncに存在するはずの.rspファイルは作成されません。

AppSyncサーバー ログの最後のメッセージとエラーは次のとおりです。

日付/時刻 INFO [Thread-1081 (HornetQ-client-global-threads-432334325)] [com.emc.archway.service.sshservice.SshServiceBean] [ASServername] [] cat LinuxName.fully.qual.name.orgappsync.pub >> authorized_keys

日付/時刻エラー[Thread-1081(HornetQ-client-global-threads-432334325)] [com.emc.archway.service.sshservice.SshServiceBean] [ASServername] []authorized_keysエントリの追加に失敗しました 

Cause

<sudouser>/.ssh/authorized_keysファイルはrootが所有していました。sudoユーザーには、読み取りまたは書き込みの権限がありませんでした。

Resolution

sudoユーザーが <sudouser>/.ssh/authorized_keysに対する読み取りおよび書き込み権限を持っていることを確認します。

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000055169
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.