Avamar: DNS 쿼리에 너무 많은 시간이 소요되어 백업이 실패함 - avtar FATAL<8941>: Fatal server connection problem, aborting initialization. 올바른 서버 주소와 로그인 자격 증명을 확인합니다.

Summary: 이 KB 문서의 목적은 avtar 핸드셰이크가 실패하지만 ping이 작동하고 필요한 TCP 포트 번호도 열려 있는 특수한 시나리오를 설명하는 것입니다.

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Symptoms



이 시나리오에서 일부 클라이언트는 영향을 받았지만 다른 클라이언트는 영향을 받지 않았습니다.
영향을 받는 클라이언트의 경우 Win FS 백업과 VSS 백업 모두에서 문제가 발생합니다.

avtar 로그에서 다음 오류 메시지를 볼 수 있습니다.
avtar FATAL <8941>: Fatal server connection problem, aborting initialization. Verify correct server address and login credentials.
avtar Info <5694>: - Failed initial handshake, trying again
avtar Info <5562>: - - Connect: Trying 10.xx.xx.xx:29000
Adding log debugging we can see the extra bit of information in the log:

[avtar]  sslcertificate::verify_certificate_ip CN Name='Avamar Server RSA TLS'
    [avtar]  sslcertificate::verify_cnname Performing CN Name validation for Avamar Server RSA TLS
    [avtar]  uwrapper::gethostbyaddr DnsQuery(dns)  returned (9002) for 10.xx.xx.xx
    [avtar]  sslcertificate::verify_certificate_ip CN Name='<avamar-server-fqdn>'
    [avtar]  sslcertificate::verify_cnname Performing CN Name validation for <avamar-server-fqdn>
    [avtar]  uwrapper::gethostbyaddr DnsQuery(dns)  returned (9002) for 10.xx.xx.xx
    [avtar]  sslcertificate::verify_certificate_ip CN Name field did not match Hostname - Checking SA Names
    [avtar]  sslcertificate::verify_certificate_ip rawIPAddrLen = 4
    [avtar]  sslcertificate::verify_certificate_ip Comparing 10.xx.xx.xx with 10.xx.xx.xx
    [avtar]  sslcertificate::verify_certificate_ip Certificate successfully verified
    [avtar]  <-- SSL
    [avtar]  <-- TLS 1.2 Handshake, ServerHelloDone
    [avtar]  --> SSL
    [avtar]  --> TLS 1.2 Handshake, ClientKeyExchange
    [avtar]  --> SSL
    [avtar]  --> TLS 1.2 ChangeCipherSpec
    [avtar]  --> SSL
    [avtar]  --> TLS 1.2 Handshake, Finished
>[avtar]  sslsockimpl::open  connect failure  (setrslt 1)  (conrslt 0)
>[avtar]  Printing ssl error stack
    [avtar]  certlock::~certlock() success to remove SSL cert lock 'C:\Program Files\avs\etc\.tmp\.certlock'
    [avtar]  sslsockimpl::save_server_cert saving cert='C:\Program Files\avs\etc\servercert.pem'
    [avtar]  sslsockimpl::save_server_cert cipher='AES256-SHA'
>[avtar]  sslsockimpl::open  failure
> avtar Info <5694>: - Failed initial handshake, trying again
For the troubleshooting purpose we checked and confirmed that the TCP ports 28001, 28002, 27000 and 29000 were all open and within the correct TCP directions as per Avamar security guide, ping and DNS resolution were also working fine.


 

Cause

이 문제는 DNS 쿼리의 긴 응답 시간으로 인해 발생하며, 실제로 "DnsQuery (dns) 반환"이 매번 10 초 이상 걸리는 것을 볼 수 있습니다.

예를 들면 다음과 같습니다.
2019/03/05-10:22:41.39299 [avtar]  sslcertificate::verify_cnname Performing CN Name validation for Avamar Server RSA TLS
2019/03/05-10:22:53.30100 [avtar]  uwrapper::gethostbyaddr DnsQuery(dns)  returned (9002) for 10.xx.xx.xx
And the entire handshake process would require about 50 seconds to complete and fail:

2019/03/05-10:22:14.89800 [avtar]  sslsockimpl::open  initclient success
....
2019/03/05-10:23:05.41599 [avtar]  sslsockimpl::open  failure

For comparison here is an example from a working client where we see that the the "DnsQuery" is returned in less than 1 second:
2019/03/05-11:56:06.97600 [avtar]  sslcertificate::verify_cnname Performing CN Name validation for <avamar-server-fqdn>
2019/03/05-11:56:07.79600 [avtar]  uwrapper::gethostbyaddr DnsQuery(dns)  returned (9002) for 10.xx.xx.xx
And the entire handshake process would complete in about 13 seconds:

2019/03/05-11:55:54.12400 [avtar]  sslsockimpl::open  initclient success
...
2019/03/05-11:56:07.82899 [avtar]  sslsockimpl::open  initclient success, cipher: AES256-SHA
In a summary, the root cause is identified as DnsQuery spent too much time on the affected client machines.

Resolution

이러한 유형의 문제를 해결하려면 시스템 관리자가 DNS 서버에서 조치를 취하여 이 지연을 해결해야 합니다.

문제가 Avamar 백업 제품의 범위를 벗어나므로 시스템 관리자가 개입해야 합니다.

Additional Information

동일한 오류가 발생하지만 DNS가 1 초 이내에 복원되는 경우 다른 유형의 문제가 발생할 수 있습니다.
먼저 Dell EMC 기술 자료에서 이 문제를 해결하는 데 도움이 될 수 있는 다른 KB 문서가 있는지 확인하십시오. 그렇지 않으면 Avamar 지원 팀에 문의하십시오.

Affected Products

Avamar

Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000055434
Article Type: Solution
Last Modified: 11 Oct 2024
Version:  3
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