Dell EMC Unity: Nie można uzyskać dostępu do Unisphere System jest zajęty. Spróbuj ponownie później (możliwość naprawienia przez użytkownika)

Summary: Dell EMC Unity: Nie można uzyskać dostępu do Unisphere System jest zajęty. Spróbuj ponownie później (możliwość naprawienia przez użytkownika)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

W Unity 4.5.0 i nowszych numer modułu obsługi żądań ECOM został zmieniony na ograniczoną liczbę, aby uniknąć problemu z brakiem pamięci, gdy zbyt wiele programów obsługi żądań obsługuje żądania. Ten limit jest ustawiany przy uruchamianiu ECOM na podstawie dostępnych zasobów (liczba procesora, rozmiar wolnej pamięci) na macierzy. Ta zmiana zwiększyła prawdopodobieństwo napotkania problemu.
 

Unisphere zgłasza następujący komunikat podczas próby uzyskania dostępu do Unisphere: System jest zajęty. Spróbuj ponownie później.  Macierz jest nadal pingowana i dostępna przez CLI. Po sprawdzeniu macierzy za pośrednictwem interfejsu wiersza polecenia usługa zarządzania zgłasza wyłączenie.

Aby potwierdzić stan usług zarządzania, można uruchomić następujące polecenie.
Zarządzanie stanem svc_restart_service>> poleceń

 
19:52:00 service@test spa:~/user# svc_restart_service status MGMT
MGMT jest wyłączony

 


Plik server.log pokazuje nieudaną próbę, gdy nie można uruchomić graficznego interfejsu użytkownika:

Lokalizacja dziennika:  /spx/usr/apache-tomcat/logs/server.log:

 

UnirestExceptionUtil:convertUnirestExceptionIntoError-- [Kod błędu: 0x7d13002] [Wiadomość: System jest zajęty. Spróbuj ponownie później. Jeśli problem nie ustąpi, wyszukaj kod błędu w witrynie pomocy technicznej lub na forach produktowych lub skontaktuj się z usługodawcą, jeśli to możliwe. (Kod błędu:0x7d13002)]
 

Cause

Zidentyfikowaliśmy problem z oprogramowaniem dostawcy zewnętrznego, który powoduje problemy z połączeniami z usługą zarządzania macierzą, przez co oprogramowanie nie zawsze kończy połączenia. Po wyłączeniu usługi oprogramowania innej firmy na hostach, na których jest uruchomiona, widzimy, że problem został uniknięty, a połączenia zostały pomyślnie przerwane. Zaobserwowaliśmy ten problem w przypadku oprogramowania innej firmy, takiego jak ServiceNow.

Aby zidentyfikować oznaki tego problemu, możemy przejrzeć memory.log na Unity. Plik Memory.log zgłasza okresową migawkę liczby wątków. Widzimy, że liczba wątków wzrasta w różnych odstępach czasu przed wystąpieniem problemu.

Lokalizacja dziennika:  /spx/EMC/C4Core/log/memory.log:

Uwaga: Liczba wątków będzie 18. wpisem po zgłoszeniu "(ECOM)".
Przykładowy podział, Łączna liczba wątków to "130", ponieważ jest to 18. wpis:
INDEKS 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
(ECOM) S 18113 14403 14403 0 -1 1077944576 108196161 1356451908 6646 6975 806452 398756 1292712 773547 20 0 130 0

Poniżej znajduje się przykładowy wynik pokazujący liczbę wątków zwiększających się w miarę nadgodzin. (Należy pamiętać, że liczba wątków będzie unikatowa dla każdej macierzy)

Wpis dziennika pokazuje, że łączna liczba wątków wynosi obecnie 153 wątki: 
 
8601923 Mon Aug 12 23:20:51 18269 (ECOM)S 18268 9054 9054 0 -1 1077944576 65520255 586277653 10129 5401 2695418 483364 566839 333778 20 01530 805147515 867745792 20558 <..>

Wpis dziennika około 1 dzień później pokazuje, że łączna liczba wątków wzrosła do 161:
 
8648731 Tue Aug 13 12:21:00 18269 (ECOM)S 18268 9054 9054 0 -1 1077944576 71093367 637402755 11337 6302 2943828 526182 617259 363530 20 0 1610 805147515 868909056 20858 <..>

Resolution

Jako tymczasowe obejście dostępu można przywrócić przez "svc_restart_service MGMT restart".
Należy pamiętać, że to obejście problemu polega na odzyskaniu tymczasowego dostępu do Unisphere, ponieważ problem z oprogramowaniem innej firmy nadal występuje w środowisku, może być konieczne okresowe ponowne zastosowanie obejścia do momentu rozwiązania problemu w oprogramowaniu innej firmy.
             
 Polecenie >> svc_restart_service ponownego uruchomienia MGMT

 
19:58:00 service@test spa:~/user# svc_restart_service uruchom ponownie MGMT
Znaleziono ECOM na spb

 

Additional Information

Informacje te przetłumaczono na inne języki: 
https://downloads.dell.com/TranslatedPDF/AR-SA_537221.pdf
https://downloads.dell.com/TranslatedPDF/DE_537221.pdf
https://downloads.dell.com/TranslatedPDF/ES_537221.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_537221.pdf
https://downloads.dell.com/TranslatedPDF/FR_537221.pdf
https://downloads.dell.com/TranslatedPDF/IT_537221.pdf
https://downloads.dell.com/TranslatedPDF/JA_537221.pdf
https://downloads.dell.com/TranslatedPDF/KO_537221.pdf
https://downloads.dell.com/TranslatedPDF/NL_537221.pdf
https://downloads.dell.com/TranslatedPDF/PT_537221.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_537221.pdf
https://downloads.dell.com/TranslatedPDF/RU_537221.pdf
https://downloads.dell.com/TranslatedPDF/SV_537221.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_537221.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_537221.pdf

Affected Products

Dell EMC Unity Family

Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...
Article Properties
Article Number: 000056109
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.