Dell EMC Unity: Det går inte att komma åt Unisphere Systemet är upptaget. Försök igen senare (kan korrigeras av användaren)

Summary: Dell EMC Unity: Det går inte att komma åt Unisphere Systemet är upptaget. Försök igen senare (kan korrigeras av användaren)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

I Unity 4.5.0 och senare har numret på ECOM-förfrågningshanteraren ändrats till ett begränsat antal för att undvika problem med slut på minne när för många förfrågningshanterare hanterar begäranden. Den här gränsen ställs in vid ECOM-start baserat på tillgängliga resurser (CPU-nummer, ledigt minnesstorlek) i disksystemet. Den här ändringen gjorde det mer sannolikt att problemet skulle uppstå.
 

Unisphere rapporterar följande meddelande när du försöker få åtkomst till Unisphere Systemet är upptaget. Försök igen senare.  Disksystemet är fortfarande pingbart och tillgängligt via CLI. Vid granskning av disksystemet via CLI rapporterar hanteringstjänsten som inaktiverad.

Följande kommando kan köras för att bekräfta status för hanteringstjänster.
Kommando >>svc_restart_service statushantering

 
19:52:00 service@test spa:~/user# svc_restart_service status MGMT
MGMT är NERE

 


Den server.log filen visar ett misslyckat försök när det grafiska användargränssnittet inte kan startas:

Loggplats:  /spx/usr/apache-tomcat/logs/server.log:

 

UnirestExceptionUtil:convertUnirestExceptionIntoError-- [ErrorCode: 0x7d13002] [Meddelande: Systemet är upptaget. Försök igen senare. Om problemet kvarstår söker du efter felkoden på supportwebbplatsen eller produktforumen eller kontaktar din tjänsteleverantör, om en sådan finns. (Felkod:0x7d13002)]
 

Cause

Vi har identifierat ett problem med programvara från tredje part som utfärdar anslutningar till disksystemets hanteringstjänst, där tredjepartsprogramvaran inte alltid avslutar anslutningarna. När programvarutjänsten från tredje part inaktiveras på de värdar där den körs ser vi att problemet undviks och att anslutningarna avslutas. Vi har sett det här problemet med programvara från tredje part, t.ex. ServiceNow.

För att identifiera indikationer på det här problemet kan vi granska memory.log på Unity. Den Memory.log filen rapporterar en periodisk ögonblicksbild av antalet trådar. Vi kan se att trådantalet ökar med olika intervall innan problemet uppstår.

Loggplats:  /spx/EMC/C4Core/log/memory.log:

Notera: Antalet trådar kommer att vara den 18:e posten efter att "(ECOM)" har rapporterats.
Exempel på uppdelning, det totala antalet trådar här är "130" eftersom det är den 18:e posten:
INDEX 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
(ECOM) S 18113 14403 14403 0 -1 1077944576 108196161 1356451908 6646 6975 806452 398756 1292712 773547 20 0 130 0

Nedan visas exempelutdata som visar antalet trådar som ökar med tiden. (Observera att trådantalet är unikt för varje disksystem)

Loggposten visar att det totala antalet trådar för närvarande är 153 trådar: 
 
8601923 Mon Aug 12 23:20:51 18269 (ECOM)S 18268 9054 9054 0 -1 1077944576 65520255 586277653 10129 5401 2695418 483364 566839 333778 20 01530 805147515 867745792 20558 <..>

Loggposten cirka 1 dag senare visar att det totala antalet trådar har ökat till 161 trådar:
 
8648731 Tue Aug 13 12:21:00 18269 (ECOM)S 18268 9054 9054 0 -1 1077944576 71093367 637402755 11337 6302 2943828 526182 617259 363530 20 0 1610 805147515 868909056 20858 <..>

Resolution

Som en tillfällig lösning kan åtkomsten återställas genom svc_restart_service omstart av MGMT.
Observera att den här lösningen är till för att återfå tillfällig åtkomst till Unisphere. Eftersom problemet med programvaran från tredje part fortfarande finns i miljön kan lösningen behöva tillämpas på nytt med jämna mellanrum tills problemet är löst på programvaran från tredje part.
             
 Kommando >> svc_restart_service starta om MGMT

 
19:58:00 service@test spa:~/user# svc_restart_service starta om MGMT
Hittade ECOM på SPB

 

Additional Information

Detta innehåll är översatt till olika språk: 
https://downloads.dell.com/TranslatedPDF/AR-SA_537221.pdf
https://downloads.dell.com/TranslatedPDF/DE_537221.pdf
https://downloads.dell.com/TranslatedPDF/ES_537221.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_537221.pdf
https://downloads.dell.com/TranslatedPDF/FR_537221.pdf
https://downloads.dell.com/TranslatedPDF/IT_537221.pdf
https://downloads.dell.com/TranslatedPDF/JA_537221.pdf
https://downloads.dell.com/TranslatedPDF/KO_537221.pdf
https://downloads.dell.com/TranslatedPDF/NL_537221.pdf
https://downloads.dell.com/TranslatedPDF/PT_537221.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_537221.pdf
https://downloads.dell.com/TranslatedPDF/RU_537221.pdf
https://downloads.dell.com/TranslatedPDF/SV_537221.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_537221.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_537221.pdf

Affected Products

Dell EMC Unity Family

Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...
Article Properties
Article Number: 000056109
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.