Dell EMC Unity: Не вдається отримати доступ до Unisphere Система зайнята. Повторіть спробу пізніше (виправлено користувачем)

Summary: Dell EMC Unity: Не вдається отримати доступ до Unisphere Система зайнята. Повторіть спробу пізніше (виправлено користувачем)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

У Unity 4.5.0 і пізніших версіях номер обробника запитів ECOM було змінено на обмежене число, щоб уникнути проблеми з нестачею пам'яті, коли занадто багато обробників запитів обробляють запити. Це обмеження встановлюється при запуску ECOM на основі доступних ресурсів (номер процесора, вільний обсяг пам'яті) на масиві. Ця зміна підвищила ймовірність виникнення проблеми.
 

Unisphere повідомляє про наступне повідомлення при спробі отримати доступ до Unisphere: система зайнята. Повторіть спробу пізніше.  Масив все ще доступний для пінгування та через CLI. Після перегляду масиву через CLI служба управління повідомляє про відключення.

Для підтвердження статусу служб керування можна запустити наступну команду.
Статус команди >>svc_restart_service MGMT

 
19:52:00 service@test спа:~/користувач# svc_restart_service статус MGMT
НЕ ПРАЦЮЄ

 


Файл server.log показує невдалу спробу, коли графічний інтерфейс не може бути запущений:

Розташування журналу:  /spx/usr/apache-tomcat/logs/server.log:

 

UnirestExceptionUtil:convertUnirestExceptionIntoError-- [Код помилки: 0x7d13002] [Повідомлення: Система зайнята. Повторіть спробу пізніше. Якщо проблема не зникає, виконайте пошук за кодом помилки на веб-сайті служби підтримки або на форумі продукту або зверніться до свого постачальника послуг (якщо він доступний). (Код помилки:0x7d13002)]
 

Cause

Ми виявили проблему з програмним забезпеченням стороннього постачальника, яка створює з'єднання зі службою керування масивом, де стороннє програмне забезпечення не завжди розриває з'єднання. Коли служба Third-Party Software відключена на хості, на яких вона запущена, ми бачимо, що проблема уникається і підключення успішно припиняються. Ми бачили цю проблему зі стороннім програмним забезпеченням, таким як ServiceNow.

Щоб виявити ознаки цієї проблеми, ми можемо розглянути memory.log на Єдність. Файл Memory.log повідомляє про періодичний знімок кількості потоків. Ми бачимо, що кількість ниток збільшується через різні проміжки часу, перш ніж проблема виникне.

Місцезнаходження журналу:  /spx/EMC/C4Core/log/memory.log:

Примітка. Кількість потоків буде 18-м записом після повідомлення
"(ECOM)".Приклад розбивки, загальна кількість ниток тут становить «130», оскільки це 18-й запис:
ІНДЕКС 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
(ECOM) S 18113 14403 14403 0 -1 1077944576 108196161 1356451908 6646 6975 806452 398756 1292712 773547 20 0 130 0

Нижче наведено приклад виведення, що показує кількість потоків, що збільшується з часом. (Зверніть увагу, що кількість потоків буде унікальною для кожного масиву)

Запис у журналі показує, що загальна кількість потоків наразі становить 153 потоки: 
 
8601923 Пн Серпень 12 23:20:51 18269 (ECOM)S 18268 9054 9054 0 -1 1077944576 65520255 586277653 10129 5401 2695418 483364 566839 333778 20 01530 805147515 867745792 20558 <..>

Запис у журналі приблизно через 1 день показує, що загальна кількість ниток зросла до 161 потоку:
 
8648731 Вт серпня 13 12:21:00 18269 (ECOM)S 18268 9054 9054 0 -1 1077944576 71093367 637402755 11337 6302 2943828 526182 617259 363530 20 0 1610 805147515 868909056 20858 <..>

Resolution

Як тимчасовий обхідний шлях, доступ можна відновити за допомогою «svc_restart_service перезапуску MGMT».
Зауважте, що цей обхідний шлях призначений для відновлення тимчасового доступу до Unisphere, оскільки проблема зі стороннім програмним забезпеченням все ще існує в середовищі, можливо, доведеться періодично застосовувати обхідний шлях, доки проблема не буде вирішена на сторонньому програмному забезпеченні.
             
 Команда >> svc_restart_service перезапуску MGMT

 
19:58:00 service@test спа:~/користувач# svc_restart_service перезапустити MGMT
Found ECOM на spb

 

Additional Information

Цей контент перекладено різними мовами: 
https://downloads.dell.com/TranslatedPDF/AR-SA_537221.pdf
https://downloads.dell.com/TranslatedPDF/DE_537221.pdf
https://downloads.dell.com/TranslatedPDF/ES_537221.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_537221.pdf
https://downloads.dell.com/TranslatedPDF/FR_537221.pdf
https://downloads.dell.com/TranslatedPDF/IT_537221.pdf
https://downloads.dell.com/TranslatedPDF/JA_537221.pdf
https://downloads.dell.com/TranslatedPDF/KO_537221.pdf
https://downloads.dell.com/TranslatedPDF/NL_537221.pdf
https://downloads.dell.com/TranslatedPDF/PT_537221.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_537221.pdf
https://downloads.dell.com/TranslatedPDF/RU_537221.pdf
https://downloads.dell.com/TranslatedPDF/SV_537221.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_537221.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_537221.pdf

Affected Products

Dell EMC Unity Family

Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...
Article Properties
Article Number: 000056109
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.