VNX: server_df kommandot misslyckas

Summary: VNX: server_df kommandot misslyckas

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kommandot "server_df server_2" misslyckas med "Error 2: server_2 : Ingen sådan fil eller katalog kunde inte slutföra kommandot":

[nasadmin@ssgnas03cs0 ~]$ server_df server_2
server_2 :
Error 2: server_2 : No such file or directory
failed to complete command

Hälsokontroller före uppgradering misslyckas med följande fel:

Blades : Check if root filesystem is too large
Error HC_DM_14505148436: Output from command "/nas/bin/server_df
         server_2" has no information on file system root_fs_2

Blades : Check if root filesystem has enough free space
Error HC_DM_14505148440: Output from command "/nas/bin/server_df
         server_2" has no information on file system root_fs_2

Blades : Check if file system usage is under limit
Error HC_DM_14505148563: Could not determine available disk space for
         the mounted file systems on the following Blades:
         * server_2

Alla andra server_df-kommandon fungerar mot andra dataöverförare:

[nasadmin@ssgnas03cs0 ~]$ server_df server_3
server_3 :
Filesystem          kbytes         used        avail capacity Mounted on
root_fs_common       15368         5280        10088   34%    /.etc_common
root_fs_3           258128         6184       251944    2%    /

 

Cause

Grundorsaken i det här fallet var att rotfilsystemet för server_2 var avmonterat.

[nasadmin@ssgnas03cs0 ~]$ server_mount ALL
server_2 :
                       <------ nothing mounted
server_3 :
root_fs_3 on / uxfs,perm,rw
root_fs_common on /.etc_common uxfs,perm,ro

När du listar alla filsystem var det tydligt att rotfilsystemet "root_fs_2" för server_2 listades som inte i bruk eftersom det var avmonterat.

[nasadmin@ssgnas03cs0 ~]$ nas_fs -l
id      inuse type acl   volume    name                server
1         n    1   0     10        root_fs_1
2         y    1   0     40        root_fs_common      3,2
3         n    5   0     73        root_fs_ufslog
4         n    5   0     76        root_panic_reserve
5         n    5   0     93        root_fs_d3
6         n    5   0     94        root_fs_d4
7         n    5   0     95        root_fs_d5
8         n    5   0     96        root_fs_d6
9         n    1   0     12        root_fs_2              <------------ inuse = n
10        y    1   0     14        root_fs_3           2

 

Resolution

Innan kunden begärde hjälp från supporten slutfördes en omstart av dataöverföraren utan att någon förbättring sågs. Lös problemet genom att logga in som rotanvändare på den primära kontrollstationen och återmontera filsystemets root_fs_2 på dataöverföraren server_2:

[root@ssgnas03cs0 nasadmin]# server_mount server_2 root_fs_2 /
server_2 : done

Kontrollera att rotfilssystemet är återmonterat:

[root@ssgnas03cs0 nasadmin]# server_mount ALL
server_2 :
root_fs_2 on / uxfs,perm,rw
root_fs_common on /.etc_common uxfs,perm,ro

server_3 :
root_fs_3 on / uxfs,perm,rw
root_fs_common on /.etc_common uxfs,perm,ro

När rotfilssystemet har monterats kör du kommandot "server_df server_2" för att säkerställa att det slutförs:

[root@ssgnas03cs0 nasadmin]# server_df server_2
server_2 :
Filesystem          kbytes         used        avail capacity Mounted on
root_fs_common       15368         5280        10088   34%    /.etc_common
root_fs_2           258128         6264       251864    2%    /

 

Additional Information

I det här fallet utförde kunden en rensning av onödiga filsystem för att frigöra utrymme för NAS-poolen. Som en del av rensningen demonterade de permanent och försökte ta bort rotfilsystemets "root_fs_2" för dataöverföraren server_2. Rotfilsystemet för en dataöverförare ska aldrig tas bort.

 

Affected Products

VNX2 Series

Products

Celerra, VNX1 Series, VNX2 Series
Article Properties
Article Number: 000056821
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.