VNX: comando server_df non riuscito

Summary: VNX: comando server_df non riuscito

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Il comando 'server_df server_2' ha esito negativo con "Errore 2: server_2 : Nessun file o directory di questo tipo non è riuscito a completare il comando":

[nasadmin@ssgnas03cs0 ~]$ server_df server_2
server_2 :
Error 2: server_2 : No such file or directory
failed to complete command

I controlli integrità pre-aggiornamento hanno esito negativo con i seguenti errori:

Blades : Check if root filesystem is too large
Error HC_DM_14505148436: Output from command "/nas/bin/server_df
         server_2" has no information on file system root_fs_2

Blades : Check if root filesystem has enough free space
Error HC_DM_14505148440: Output from command "/nas/bin/server_df
         server_2" has no information on file system root_fs_2

Blades : Check if file system usage is under limit
Error HC_DM_14505148563: Could not determine available disk space for
         the mounted file systems on the following Blades:
         * server_2

Tutti gli altri comandi server_df funzionano correttamente su altri data mover:

[nasadmin@ssgnas03cs0 ~]$ server_df server_3
server_3 :
Filesystem          kbytes         used        avail capacity Mounted on
root_fs_common       15368         5280        10088   34%    /.etc_common
root_fs_3           258128         6184       251944    2%    /

 

Cause

La root cause in questa istanza è stata l'unmount del file system root per server_2.

[nasadmin@ssgnas03cs0 ~]$ server_mount ALL
server_2 :
                       <------ nothing mounted
server_3 :
root_fs_3 on / uxfs,perm,rw
root_fs_common on /.etc_common uxfs,perm,ro

Quando si elencano tutti i file system, è chiaro che il file system root "root_fs_2" per server_2 è stato elencato come non in uso perché era stato smontato.

[nasadmin@ssgnas03cs0 ~]$ nas_fs -l
id      inuse type acl   volume    name                server
1         n    1   0     10        root_fs_1
2         y    1   0     40        root_fs_common      3,2
3         n    5   0     73        root_fs_ufslog
4         n    5   0     76        root_panic_reserve
5         n    5   0     93        root_fs_d3
6         n    5   0     94        root_fs_d4
7         n    5   0     95        root_fs_d5
8         n    5   0     96        root_fs_d6
9         n    1   0     12        root_fs_2              <------------ inuse = n
10        y    1   0     14        root_fs_3           2

 

Resolution

Prima che il cliente richiedesse assistenza al supporto, veniva completato un riavvio del data mover e non veniva rilevato alcun miglioramento. Per risolvere questo problema, accedere come utente "root" alla control station primaria e montare nuovamente il file system "root_fs_2" sul data mover server_2:

[root@ssgnas03cs0 nasadmin]# server_mount server_2 root_fs_2 /
server_2 : done

Assicurarsi che il file system root sia montato nuovamente:

[root@ssgnas03cs0 nasadmin]# server_mount ALL
server_2 :
root_fs_2 on / uxfs,perm,rw
root_fs_common on /.etc_common uxfs,perm,ro

server_3 :
root_fs_3 on / uxfs,perm,rw
root_fs_common on /.etc_common uxfs,perm,ro

Dopo aver montato il file system root, usare il comando "server_df server_2" per assicurarsi che venga completato correttamente:

[root@ssgnas03cs0 nasadmin]# server_df server_2
server_2 :
Filesystem          kbytes         used        avail capacity Mounted on
root_fs_common       15368         5280        10088   34%    /.etc_common
root_fs_2           258128         6264       251864    2%    /

 

Additional Information

In questo caso specifico, il cliente stava eseguendo una pulizia dei file system non necessari per recuperare spazio per il pool NAS. Come parte della pulizia, hanno eseguito l'unmount permanente e hanno tentato di eliminare il file system root "root_fs_2" per il data mover server_2. Il file system root di un data mover non deve mai essere eliminato.

 

Affected Products

VNX2 Series

Products

Celerra, VNX1 Series, VNX2 Series
Article Properties
Article Number: 000056821
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.