AppSync: L'aggiornamento di Postgres non riesce

Summary: AppSync: L'aggiornamento di Postgres non riesce

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Postgres viene aggiornato per KB 000504125 e non riesce.

La appsync_dbupgrade.log mostra:
 

Comando.run(): C:\Users\userid\AppData\Local\Temp\2\011266.tmp\executeScriptTmp0.bat:stdout [Errore, uscita]
Command.complete(): processo completato con codice di uscita: 1


La pg_upgrade_utility.log mostra:
 

command: xcopy /e /y /q /r "E:\EMC\AppSync\jboss\datastore\data/pg_clog" "E:\EMC\AppSync\NewDatastore\data/pg_clog\" >> "pg_upgrade_utility.log" 2>&1
Specifica
unità non valida 0 File copiati


Nota: La pg_upgrade_utility.log che si trova in %AppData% verrà rimossa quando si clicca su OK quando viene visualizzato il messaggio di aggiornamento non riuscito durante la finestra di dialogo dell'aggiornamento. Pertanto, questo file deve essere raccolto prima di cliccare su OK ed esistere la finestra di dialogo di aggiornamento.

Nota: Il database AppSync si trova in una posizione non predefinita, l'unità E: in questo esempio.

Cause

Il trigger è un problema relativo alle autorizzazioni di cui non si conosce la causa precisa.
L'utilità di aggiornamento viene eseguita come amministratore e l'utente che ha effettuato l'accesso quando l'utilità di aggiornamento viene eseguita come amministratore tramite il metodo del clic destro è un amministratore di dominio presente nel gruppo di amministratori locali che dispone dei diritti completi sull'unità E:.

Indipendentemente da ciò, se si utilizza procmon per eseguire il debug, si troveranno errori di autorizzazione per l'utente che ha effettuato l'accesso all'unità E:.

Resolution

Fornire in modo esplicito i diritti amministrativi completi sull'unità E: per l'utente specifico che ha effettuato l'accesso durante l'esecuzione del processo di aggiornamento.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000057208
Article Type: Solution
Last Modified: 19 Sept 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.