NetWorker NMM 备份失败: 备份级别“MSSQL:”已过时。将备份级别更改为仅日志,然后重新启动备份。
Summary: NMM SQL VDI 备份失败,备份级别“MSSQL:”已过时。将备份级别更改为仅日志,然后重新启动备份。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
从 NMM 8.x 升级到 NMM 9.x
Windows Server 2012 R2
上的 NetWorker 服务器:9.2.1 SQL Server 2008
NMM 9.2.1.1.Build.194
运行级别为增量的 NMM SQL VDI 备份时,备份失败,并显示以下错误:
Windows Server 2012 R2
上的 NetWorker 服务器:9.2.1 SQL Server 2008
NMM 9.2.1.1.Build.194
运行级别为增量的 NMM SQL VDI 备份时,备份失败,并显示以下错误:
157931:(pid 10772):备份级别“MSSQL:”已过时。将备份级别更改为仅日志,然后重新启动备份。 37758:(PID 10772):用法:nsrsqlsv [<options>] {path} 选项:[-CGjqRTvkuHXZ][-A SQL 虚拟服务器名称][-s NetWorker 服务器] [-c NetWorker 客户端][-N 名称][-b 池][-g组] [-S 计数][-l 级别][-m 化装舞会] [-O “sqlOption1[,sqlOption2][,...]”] [-D debuglevel][-I <textfilename>] [-U <SQL Server 用户名>] [-P <SQL Server 用户密码>] [-h “DB_to_exclude1[,DB_to_exclude2][,...]”] [-h [“DB_to_exclude_wildcards”]] [-f aes][-w 浏览][-y retention] [-a <optionKey=value>] 路径: D-路径 |i-路径 D 路径: MSSQL: |[MSSQL:]s-path [[MSSQL:]s-path [...]] i-路径: MSSQL $ inst-name:|MSSQL $ inst-名称: s-路径 [...] S 路径: 数据库 |数据库。|数据库.文件组 | database.filegroup。|database.filegroup.file
Cause
在 NMM SQL VDI 9.x 中,不再支持备份级别增量。
唯一支持的级别是(完整、仅日志、累积增量)
支持的级别可在 Dell EMC NetWorker Module for Microsoft 管理指南
中找到。下表说明了三个级别的备份:
唯一支持的级别是(完整、仅日志、累积增量)
支持的级别可在 Dell EMC NetWorker Module for Microsoft 管理指南
中找到。下表说明了三个级别的备份:
| 备份级别 | 描述 |
| 完整 | 整个数据库备份,包括数据库中的所有文件组或文件。 |
| 仅面向本地的备份 | 仅日志备份对应于 SQL Server 事务日志备份。日志文件备份本身不能用于恢复数据库。数据库恢复后使用日志文件备份将数据库恢复到原始故障点。 提醒:NMC 中将显示仅日志备份选项。使用命令行 执行仅日志备份时,请使用 txnlogs 命令。 |
| 累积增量 | 累积增量捕获自上次完整备份以来的所有更改。 |
Resolution
将Action/Client schedule从Incremental更改为Logs Only。此外,请确保在作属性中正确设置客户端覆盖行为设置,以避免错误的备份级别优先。例如,客户端属性可能配置了旧计划,即使作属性已设置为“仅日志”,该计划仍使用 “incr”。在这种情况下,将客户端覆盖行为设置为“客户端不能覆盖”。
Affected Products
NetWorker Module for MicrosoftProducts
NetWorker, NetWorker Module for MicrosoftArticle Properties
Article Number: 000057387
Article Type: Solution
Last Modified: 29 Jul 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.