NetWorker: Exchange yedeklemesi şu hatayla başarısız oluyor: nsrnmmsv Exchange2010 Kabuk arabirimi başlatılmadı
Summary: Exchange yedeklemesi şu hatayla başarısız oluyor: nsrnmmsv Exchange2010 Kabuk arabirimi başlatılmadı.
Symptoms
NMM Exchange yedeklemesi veya "nsrnmmsv -P" komutu şu hatayla başarısız olur:
Exchange2010 Shell interface is not initialised.
Örnek olarak:
C:\Users\Administrator>nsrnmmsv -P 17092:nsrnmmsv: Version information for C:\Program Files\EMC NetWorker\nsr\bin\nsrnmmsv.exe: Original file name: nsrnmmsv.exe Version: 9.1.1 (ntx64) Comments: Supporting Microsoft Volume Shadow Copy Service Changing backup name EX01N3 to primary name ex01n3.group.com for multi-NIC configured client. 136553:nsrnmmsv: NMM .. Exchange2010 Shell interface is unavailable. This may indicate that the EMC powershell library was not properly registered. 111867:nsrnmmsv:Exchange2010 Shell interface is not initialised. 145370:nsrnmmsv: Initialization error -- Exchange shell failed to initialize. Required for Exchange. 117296:nsrnmmsv: Failed to list supported save sets. 102332:nsrnmmsv: Exiting with success.
Cause
"Exchange2010 Kabuk arabirimi" hata iletisi başlatılmadı, temel olarak şunlardan kaynaklanmaktadır:
- NetWorker lib, Exchange Powershell'i başlatamıyor (Bkz. KB 493540 - Powershell sorunları nedeniyle Exchange 2010 DAG başarısız).
- Kitaplığı çağıran kullanıcı, kabuğu çalıştırmak için doğru izinlere sahip değil.
- Çok nadir durumlarda, Exchange Powershell gerçekleştirilemeyen IIS yapılandırması altında bozulur.
Resolution
Kayıt defteri girişinin mevcut olup olmadığını kontrol edin ve bu durumda girişi, çalışan Exchange düğümlerinden biriyle karşılaştırın:
reg query HKEY_LOCAL_MACHINE\software\legato\networker\vssclient
Mevcut değilse, aşağıdaki adımları izleyin:
-
Aşağıdaki kayıt defteri anahtarlarını oluşturun: HKEY_LOCAL_MACHINE\software\legato\networker\vssclient
*** N.B. Put the appropriate username and domain name. Exchange Username REG_SZ admin Exchange Domain REG_SZ fall.localdomain Exchange Password REG_BINARY
<örnek>
Kullanıcı adı= sadece kullanıcı adı ör: backup.manager
Etki Alanı= ör: BWK.comNot: Exchange Etki Alanı, kullanıcı hesabı değil, Exchange sunucusunun etki alanı düzeyidir. Etki alanı hesabı farklı bir düzeydeyse (ör. child.fall.localdomain), etki alanını kullanıcı etki alanıyla eşleşecek şekilde düzenleyin veya Exchange Server ile tam olarak aynı etki alanı düzeyinde yeni bir kullanıcı oluşturun. -
Ardından NMM Exchange Admin yapılandırma aracını çalıştırın ve Yönetici parolasını güncelle'yi seçin. Bu işlem başarılı olursa Exchange Password kayıt defteri anahtarını güncelleştirmelidir.
-
Ardından Exchange düğümü bağlantısını test etmek için komutu çalıştırın:
nsrnmmsv -P