Moduł NetWorker dla Microsoft: Nsrpush nie może uaktualnić klientów z zainstalowanym NMM GLR
Summary: Funkcja NetWorker NMC Push lub Nsrpush nie może uaktualnić modułu NetWorker dla klientów Microsoft (NMM) z zainstalowanym GLR.
Symptoms
Funkcja NetWorker NMC Push lub Nsrpush nie może uaktualnić klientów NetWorker, gdy na komputerach klienckich jest zainstalowany moduł NetWorker Module for Microsoft (NMM).
W plikach dziennika widoczny jest następujący błąd:
nsrcpd NSR severe Error occurred in 'Upgrading' phase of client 'client_name': Feature 'NW_GLR_FEATURE' cannot be remotely upgraded.
Cause
Jest to oczekiwane zachowanie, gdy klienci NMM mają zainstalowaną funkcję GLR.
Nie dzieje się tak, jeśli klient NMM ma zainstalowany NMM bez funkcji GLR.
Resolution
W przypadku korzystania z uaktualnienia oprogramowania NMC (push) w celu uaktualnienia klienta NetWorker, który ma również zainstalowany moduł NetWorker dla firmy Microsoft, należy wziąć pod uwagę pewne warunki. Poniżej przedstawiono warunki aktualizacji lub uaktualnienia NMM z funkcją aktualizacji oprogramowania NetWorker (push).
Obsługiwane:
Moduł NetWorker dla Microsoft — obsługuje tylko
wypychanie NMCNieobsługiwane:
Moduł NetWorker dla Microsoft — nie obsługuje ograniczeń nsrpush
interfejsu wiersza poleceń:
- W celu uaktualnienia wybierz razem pakiety NetWorker i NetWorker Module dla Microsoft (NMM).
- Obsługiwana jest tylko aktualizacja NMM w środowisku nieklastrowanym.
- Menedżer pakietów lub Push klienta nie obsługują aktualizacji NMM z włączoną funkcją GLR
Rozwiązanie:
Jeśli NMM jest zainstalowany na kliencie bez funkcji GLR :
- Uaktualnienie klienta NetWorker i NMM — NALEŻY wybrać i uaktualnić jednocześnie klienta i NMM.
- Do tej operacji należy użyć uaktualnienia oprogramowania NMC — nie należy korzystać z nsrpush CLI.
Jeśli na kliencie zainstalowano NMM z funkcją GLR :
- Nie można uaktualnić NMM z wypchnięciem NMC, ponieważ funkcja GLR uniemożliwia uaktualnienie.
- Nie można uaktualnić klienta NetWorker za pomocą NMC push, ponieważ samo uaktualnienie klienta bez uaktualnienia NMM nie jest obsługiwane.
W powyższym przypadku użytkownik musi ręcznie usunąć oprogramowanie NMM i NetWorker, a następnie ręcznie zainstalować najnowszego klienta NetWorker i oprogramowanie NMM.