NetWorker: Das Upgrade schlägt fehl mit der Meldung "Server kann nicht verbunden werden, Remotesystemfehler..."

Summary: Server kann nicht verbunden werden, Remotesystemfehler, Es konnte keine Verbindung hergestellt werden, weil der Zielcomputer sie aktiv abgelehnt hat.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Führen Sie ein Upgrade auf NetWorker 9.1 durch, um vSphere 6.5 verwenden zu können.

 

Die folgende Fehlermeldung in NMC:

Unable to connect server, Remote system error, No connection could be made because the target machine actively refused it


nsrctld NSR notice Daemon nsrd terminated


C:\Program Files\EMC NetWorker\nsr\logs>nsrrpcinfo -t <Networker_server_name> 390103
nsrrpcinfo: Remote system error - Only one usage of each socket address (protocol/network address/port) is normally permitted.


nsrjobd severe Unable to query RAP database for initial RDZ value: RPC send operation failed; peer = ::1:[8992], errno = An existing connection was forcibly closed by the remote host.

 

Cause

Der Prozess nsrd schlägt immer wieder fehl und wird neu gestartet.
NSRDB ist beschädigt.

 

Resolution

Schritte:

  1. Befolgen Sie das Verfahren zur Wiederherstellung nsrdbbenutzend nsrdraus.
    Öffnen Sie eine Eingabeaufforderung als Administrator oder Root-Nutzer und führen Sie Folgendes aus:
    mminfo -B

  2. Wenn MM nicht verfügbar ist, melden Sie sich an bei \nsr\logs\policy\Server Protection\Server backup, suchen Sie nach dem neuesten Bootstrap-Backup und notieren Sie sich die hervorgehobenen Informationen.
    Beispiel:

129292:save: Successfully established Client direct save session for save-set ID '2025432100' (networker.com:bootstrap) with Data Domain volume 'POOLFILESERVER.001'.
Picked up JAVA_TOOL_OPTIONS: -Djava.vendor="New Oracle"
save: bootstrap                   level=full,     36 MB 00:00:23    412 files
completed savetime=1488561188
7167:save: save completion time: 3/3/2017 11:13:31 AM
94694:save: The backup of save set 'bootstrap' succeeded
Bootstrap saveset: 2025432100
Volume:POOLFILESERVER.001

 

  1. Innerhalb nsr\logs\policy\Server Protection\Server backupfinden Sie möglicherweise auch eine Datei mit den Informationen zum Pool oder Volume. Zum Beispiel:

3/3/2017 11:13:08 AM  2025432100  POOLFILESERVER.001 datadomain datadomain_FILESERVER datadomain:/ddnw/FILESERVER

 

  1. Beenden Sie alle NetWorker-Services.

    Umbenennen des res Ordners unter <NetWorker Installation path>\nsr

  2. Starten Sie die NetWorker-Services.

  3. Öffnen Sie NMC und konfigurieren Sie das Gerät neu, auf dem das Saveset gespeichert wurde.

  4. Führen Sie über eine Eingabeaufforderung als Nutzer, Administrator oder Root den folgenden Befehl aus:

nsrdr -B {bootstrap_saveset_id} -d {device}

 

  1. Zum Öffnen von nsrdr im interaktiven Modus. Zum Beispiel:
    nsrdr -B 2025432100 -d ddnw

  1. Starten Sie nach Abschluss des Vorgangs alle NetWorker-Services neu.

 

Öffnen Sie NMC, wenn es leer ist oder eine Fehlermeldung angezeigt wird:

An error occurred while validating user credentials. Verify that NetWorker Authentication Service is running.

 

  1. Beenden Sie die GST-Services.

  2. Autorisieren Sie NMC erneut mit NWS.

gstauthcfg -ct -h New_authentication_service_hostname -p port_number
nsrauthtrust -H Authentication_service_host -P Authentication_service_port_number
nsraddadmin -H Authentication_service_host -P Authentication_service_port_number

 

Additional Information

Affected Products

NetWorker
Article Properties
Article Number: 000063048
Article Type: Solution
Last Modified: 25 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.