NetWorker:アップグレードが「サーバーに接続できません。リモート システム エラー...」で失敗する
Summary: サーバーに接続できません、リモート システム エラー、ターゲット マシンがアクティブに拒否したため、接続できませんでした。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
vSphere 6.5を使用するには、NetWorker 9.1にアップグレードします。
NMCに次のエラー メッセージが表示されます。
Unable to connect server, Remote system error, No connection could be made because the target machine actively refused it nsrctld NSR notice Daemon nsrd terminated C:\Program Files\EMC NetWorker\nsr\logs>nsrrpcinfo -t <Networker_server_name> 390103 nsrrpcinfo: Remote system error - Only one usage of each socket address (protocol/network address/port) is normally permitted. nsrjobd severe Unable to query RAP database for initial RDZ value: RPC send operation failed; peer = ::1:[8992], errno = An existing connection was forcibly closed by the remote host.
Cause
プロセス nsrd が失敗し続け、再起動します。
NSRDBが破損しています。
Resolution
手順:
-
手順に従ってリカバリーします
nsrdb使用nsrdr.
ユーザー管理者またはrootとしてコマンド プロンプトを開き、次のコマンドを実行します。mminfo -B -
MMが使用できない場合は、次にログインします:
\nsr\logs\policy\Server Protection\Server backupをクリックし、最新のブートストラップ バックアップを検索して、ハイライトされた情報をメモします。
例:
129292:save: Successfully established Client direct save session for save-set ID '2025432100' (networker.com:bootstrap) with Data Domain volume 'POOLFILESERVER.001'. Picked up JAVA_TOOL_OPTIONS: -Djava.vendor="New Oracle" save: bootstrap level=full, 36 MB 00:00:23 412 files completed savetime=1488561188 7167:save: save completion time: 3/3/2017 11:13:31 AM 94694:save: The backup of save set 'bootstrap' succeeded Bootstrap saveset: 2025432100 Volume:POOLFILESERVER.001
-
中に
nsr\logs\policy\Server Protection\Server backupでは、プールまたはボリュームに関する情報を含むファイルを見つけることもできます。例:
3/3/2017 11:13:08 AM 2025432100 POOLFILESERVER.001 datadomain datadomain_FILESERVER datadomain:/ddnw/FILESERVER
-
すべてのNetWorkerサービスを停止します。
下のresフォルダー名を変更
<NetWorker Installation path>\nsr -
NetWorkerサービスを開始します。
-
NMCを開き、セーブセットが保存されているデバイスを再構成します。
-
コマンド プロンプトから、ユーザー、管理者、またはrootとして次のコマンドを実行します。
nsrdr -B {bootstrap_saveset_id} -d {device}
-
nsrdrを対話モードで開きます。例:
nsrdr -B 2025432100 -d ddnw
-
完了後、すべてのNetWorkerサービスを再起動します。
空の場合、またはエラー メッセージが表示される場合はNMCを開きます。
An error occurred while validating user credentials. Verify that NetWorker Authentication Service is running.
-
GSTサービスを停止します。
-
NWSを使用してNMCを再承認します。
gstauthcfg -ct -h New_authentication_service_hostname -p port_number nsrauthtrust -H Authentication_service_host -P Authentication_service_port_number nsraddadmin -H Authentication_service_host -P Authentication_service_port_number
Additional Information
Affected Products
NetWorkerArticle Properties
Article Number: 000063048
Article Type: Solution
Last Modified: 25 Mar 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.