NetWorker: Aktualizacja kończy się niepowodzeniem z komunikatem "Unable to connect server, Remote system error..."

Summary: Nie można połączyć się z serwerem, błąd systemu zdalnego, nie można nawiązać połączenia, ponieważ komputer docelowy aktywnie odmówił.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Uaktualnij NetWorker do wersji 9.1, aby korzystać z oprogramowania vSphere 6.5.

 

Następujący komunikat o błędzie w NMC:

Unable to connect server, Remote system error, No connection could be made because the target machine actively refused it


nsrctld NSR notice Daemon nsrd terminated


C:\Program Files\EMC NetWorker\nsr\logs>nsrrpcinfo -t <Networker_server_name> 390103
nsrrpcinfo: Remote system error - Only one usage of each socket address (protocol/network address/port) is normally permitted.


nsrjobd severe Unable to query RAP database for initial RDZ value: RPC send operation failed; peer = ::1:[8992], errno = An existing connection was forcibly closed by the remote host.

 

Cause

Proces nsrd ciągle kończy się niepowodzeniem i uruchamia się ponownie.
NSRDB jest uszkodzona.

 

Resolution

Czynności:

  1. Postępuj zgodnie z tą procedurą, aby odzyskać nsrdbZa pomocą nsrdr.
    Otwórz wiersz polecenia jako użytkownik admin lub root i uruchom:
    mminfo -B

  2. Jeśli funkcja MM jest niedostępna, zaloguj się do \nsr\logs\policy\Server Protection\Server backup, wyszukaj najnowszą kopię zapasową Bootstrap i zanotuj wyróżnione informacje.
    Przykład:

129292:save: Successfully established Client direct save session for save-set ID '2025432100' (networker.com:bootstrap) with Data Domain volume 'POOLFILESERVER.001'.
Picked up JAVA_TOOL_OPTIONS: -Djava.vendor="New Oracle"
save: bootstrap                   level=full,     36 MB 00:00:23    412 files
completed savetime=1488561188
7167:save: save completion time: 3/3/2017 11:13:31 AM
94694:save: The backup of save set 'bootstrap' succeeded
Bootstrap saveset: 2025432100
Volume:POOLFILESERVER.001

 

  1. Wewnątrz nsr\logs\policy\Server Protection\Server backupmożesz również znaleźć plik z informacjami o puli lub woluminie. Przykład

3/3/2017 11:13:08 AM  2025432100  POOLFILESERVER.001 datadomain datadomain_FILESERVER datadomain:/ddnw/FILESERVER

 

  1. Zatrzymaj wszystkie usługi NetWorker.

    Zmień nazwę folderu res w obszarze <NetWorker Installation path>\nsr

  2. Uruchom usługi NetWorker.

  3. Otwórz NMC i ponownie skonfiguruj urządzenie, na którym zapisano zestaw zapisów.

  4. Z wiersza poleceń jako użytkownik administrator lub root uruchom polecenie:

nsrdr -B {bootstrap_saveset_id} -d {device}

 

  1. Aby otworzyć nsrdr w trybie interaktywnym. Przykład
    nsrdr -B 2025432100 -d ddnw

  1. Po zakończeniu uruchom ponownie wszystkie usługi NetWorker.

 

Otwórz NMC, jeśli jest puste lub pojawi się komunikat o błędzie:

An error occurred while validating user credentials. Verify that NetWorker Authentication Service is running.

 

  1. Zatrzymaj usługi GST.

  2. Dokonaj ponownej autoryzacji NMC za pomocą NWS.

gstauthcfg -ct -h New_authentication_service_hostname -p port_number
nsrauthtrust -H Authentication_service_host -P Authentication_service_port_number
nsraddadmin -H Authentication_service_host -P Authentication_service_port_number

 

Additional Information

Affected Products

NetWorker
Article Properties
Article Number: 000063048
Article Type: Solution
Last Modified: 25 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.