SourceOne pro systém souborů – Obnovení souborů pomocí příkazu "add to restore list" pro sdílenou složku Isilon SMB selhalo.

Summary: SourceOne-for-File-System-Restoring-files-using-add-to-restore-list-failed-for-Isilon-SMB-share

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Obnovení souborů pomocí příkazu "add to restore list" selže u souborů umístěných ve sdílené složce SMB Isilon, zatímco u souborů umístěných ve sdílených složkách systému Windows funguje správně.

V ExJBRestore jsou zobrazeny následující chyby:
CExFileSystem::iWriteFileProperties|
VERBOSE|
iWriteFileProperties calling ::CreateDirectory with perm for \\?\UNC\SMBPath\sourceone_test\|

CExFileSystem::iWriteFileProperties|
VERBOSE|
Checking that user 'SourceOneServiceAccount' has write permissions to the directory '\\\?\UNC\SMBPath\sourceone_test\'|

CExFileSystem::iWriteFileProperties|
ERROR|
Error encountered checking permissions (0x80072147)|

CoExFileProvider::StoreDoc|
ERROR|
Failed to restore file to original location (MessageID). (0x86044701) The specified property 20 does not exist (0x86044002)|

CExRestoreThread::ProcessRun|
WARNING|
Failed restore item: Unable to verify that the user has required file system permissions to restore the file.  Try restoring to an alternate location. (0x86044710)|

CExRestoreThread::ProcessRun|
ERROR|
CExRestoreThread failed msgid: MessageID result hr=86044710|


 

Cause

Připojte se k systému OneFS a zkontrolujte sdílenou složku SMB. Ve sdílené složce SourceOne se nenachází žádný uživatel účtu služby SourceOne. Účet služby tam musí být.
To je způsobeno nedostatečným oprávněním ze strany Isilon pro účet služby SourceOne. Isilon potřebuje referenční bod pro ověřování, může to být LDAP, NIS nebo místní uživatelé. Aby bylo možné jej rozpoznat, musí mít zdroj na UID.

Resolution

Připojte se k systému OneFS. Pokud účet služby SourceOne nemá žádného uživatele, je nutné jej vytvořit pomocí následujícího postupu:

Postup vytvoření uživatele služby SourceOne:
1- V systému OneFS přejděte do části "Access a poté klikněte na "Membership & Roles"2
- Vyberte aktuální zónu přístupu: Systém
3 – Klikněte na kartu "uživatel" a vyberte svého poskytovatele: "MÍSTNÍ: Systém"
4 – Klikněte na Vytvořit uživatele vpravo.
Rozhraní OneFs 
5- Vyplňte následující:
Uživatelské jméno: "název účtu služby"
Heslo: "service account password"
Celé jméno: Primární skupina servisního účtu
SourceOne: --->Klikněte na položku Select Group, poté vyberte možnost Provider "LOCAL:system" a spusťte vyhledávání. Zde vyberte "Uživatelé Isilon"
Klikněte na Vytvořit uživatele.
Obrazovka Správa uživatelů 
6 – Povolit uživatele

Nyní budete muset přidat tohoto uživatele do sdílené složky SMB:
1 – Přejděte do části Protocol a poté do části SMB Share.
2 – Vyberte aktuální přístupovou zónu: Systém
3 – Ve sdílené složce SourceOne SMB vyberte možnost Edit
4 – Edit Users and groups a poté zvoltemožnost "Add a user or Group". Vyberte poskytovatele systému Local: a najdete účet služby SourceOne, který byl vytvořen dříve. Udělte úplná oprávnění a přidejte uživatele. Na prvním místě zadejte servisní účet a ušetřete.
5 – Nyní jsou oprávnění ze strany OneFS v pořádku
Rozhraní OneFS 

Affected Products

SourceOne for File Systems

Products

SourceOne for File Systems
Article Properties
Article Number: 000064614
Article Type: Solution
Last Modified: 27 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.