Dell Unity : Réception du code d’erreur « Le client DNS ne parvient pas à se connecter au serveur de noms xx.xx.xx.xx »

Summary: Dell Unity : Réception du code d’erreur « Le client DNS ne parvient pas à se connecter au serveur de noms xx.xx.xx.xx » (corrigible par l’utilisateur)

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Symptoms

L’utilisateur reçoit le message d’erreur ci-dessous à plusieurs reprises sur la baie de destination :

The DNS client is unable to connect to name server xxx.xxx.xxx.xxx :I/O error

 

Cause

  • Lors de l’utilisation de la réplication de serveur NAS, le système de destination signalait parfois de manière inexacte que les services DNS, NIS ou LDAP n’étaient pas accessibles et que le correctif se trouvait dans la version 4.2.1.9535982

  • Le code Unity OE Code (4.2.1.9535982) est disponible pour effectuer la mise à niveau

  • Un autre scénario a été identifié, dans lequel la configuration de CEPA sur la baie source peut déclencher ces erreurs sur la baie de destination à chaque synchronisation de la réplication. Cela peut être observé dans toutes les versions du code Unity OE jusqu’à la version 5.0.2.x. Le correctif sera implémenté dans une future version d’Unity OE

 

Resolution

Solution de contournement #1 :

Supprimez les alertes DNS/LDAP/NIS en appliquant la modification de paramètre suivante sur la baie source :

Remarque : Cette solution de contournement ne s’applique pas actuellement au scénario dans lequel CEPA est configuré et déclenche les erreurs. Reportez-vous à la solution de contournement suivante pour les erreurs liées à CEPA.

DNS :

svc_nas   -param -facility dns -modify suppressDnsStatus -value 1

NIS:

svc_nas   -param -facility nis -modify suppressNisStatus -value 1

LDAP:

svc_nas   -param -facility ldap -modify suppressLdapStatus -value 1

Solution de contournement #2 :

Dans le cas où CEPA est considéré comme le facteur contribuant aux erreurs DNS sur le serveur NAS de destination, la suppression de l’alerte ne fonctionne pas pour le moment. Pour limiter les erreurs, configurez les serveurs NAS sur la baie source afin qu’ils utilisent les adresses IP des serveurs CEPA. Cela élimine la nécessité d’une résolution de noms.

 

Additional Information

Pour confirmer le problème :

  • Performed : tailf /EMC/C4Core/log/c4_safe_ktrace.log | grep 'Le client DNS ne parvient pas à se connecter au serveur de noms' et les erreurs ci-dessous sont apparues :

    2017/11/14-11:24:07.434651   14     7F8A96254707     sade:DNS: 1: 3:[<nas_server>] The DNS client is unable to connect to the name server xxx.xxx.xxx.xxx : I/O error
    2017/11/14-11:24:07.434754   10     7F8A96254703     sade:DNS: 1: 3:[<nas_server>] The DNS client is unable to connect to the name server xxx.xxx.xxx.xxx : I/O error
  • Confirmez que tous les serveurs NAS fonctionnent normalement à l’aide de :

    uemcli /net/nas/server show
  • Confirmez également que les interfaces du serveur NAS fonctionnent correctement en utilisant

    uemcli /net/nas/if show

 

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family
Article Properties
Article Number: 000064779
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
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