Dell Unity: Codice di errore ricevuto "Il client DNS non è in grado di connettersi al server dei nomi xx.xx.xx.xx"

Summary: Dell Unity: Codice di errore ricevuto "Il client DNS non è in grado di connettersi al server dei nomi xx.xx.xx.xx" (correggibile dall'utente)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

L'utente riceve più volte il seguente errore sull'array di destinazione:

The DNS client is unable to connect to name server xxx.xxx.xxx.xxx :I/O error

 

Cause

  • Quando si utilizza la replica del server NAS, il sistema di destinazione a volte segnalava erroneamente che i servizi DNS, NIS o LDAP non erano accessibili e che la correzione era nella versione 4.2.1.9535982

  • Il codice Unity OE (4.2.1.9535982) è disponibile per eseguire l'aggiornamento

  • È stato identificato un ulteriore scenario in cui la configurazione di CEPA sull'array di origine può attivare questi errori sull'array di destinazione ogni volta che viene sincronizzata la replica. Questa condizione può essere visualizzata in tutte le versioni del codice Unity OE fino alla 5.0.2.x. La correzione verrà implementata in una versione futura di Unity OE

 

Resolution

Soluzione alternativa #1:

Eliminare gli avvisi DNS/LDAP/NIS applicando la seguente modifica dei parametri sull'array di origine:

Nota: Questa soluzione alternativa non si applica attualmente allo scenario in cui CEPA è configurato e attiva gli errori. Consultare la soluzione alternativa successiva per gli errori relativi a CEPA.

DNS:

svc_nas   -param -facility dns -modify suppressDnsStatus -value 1

NIS:

svc_nas   -param -facility nis -modify suppressNisStatus -value 1

LDAP:

svc_nas   -param -facility ldap -modify suppressLdapStatus -value 1

Soluzione alternativa #2:

Nel caso in cui si ritenga che CEPA sia il fattore che contribuisce agli errori DNS sul server NAS di destinazione, l'eliminazione dell'avviso non funziona in questo momento. Per attenuare gli errori, configurare i server NAS sull'array di origine in modo che utilizzino gli indirizzi IP per i server CEPA. In questo modo si annulla la necessità di risoluzione dei nomi.

 

Additional Information

Per confermare il problema:

  • Esecuzione: tailf /EMC/C4Core/log/c4_safe_ktrace.log | grep 'Il client DNS non è in grado di connettersi al server dei nomi' e sono apparsi i seguenti errori:

    2017/11/14-11:24:07.434651   14     7F8A96254707     sade:DNS: 1: 3:[<nas_server>] The DNS client is unable to connect to the name server xxx.xxx.xxx.xxx : I/O error
    2017/11/14-11:24:07.434754   10     7F8A96254703     sade:DNS: 1: 3:[<nas_server>] The DNS client is unable to connect to the name server xxx.xxx.xxx.xxx : I/O error
  • Confermato che tutti i server NAS funzionano normalmente utilizzando:

    uemcli /net/nas/server show
  • Confermato inoltre che le interfacce del server NAS funzionano correttamente con

    uemcli /net/nas/if show

 

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family
Article Properties
Article Number: 000064779
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.