Avamar: İstemciye göz atma ve yedekleme sorunları

Summary: Yönetici Grafik Kullanıcı Arayüzü (UI), yardımcı yazılım düğümü istemciye Avagent bağlantı noktasında (varsayılan 28002, 28003+ veya sertifikalı 30002) erişemediğinden istemciye göz atamıyor veya yedeklemeleri çalıştıramıyor (bekleme-istemcisi). Etki Alanı Adı Sisteminin (DNS) adları çözümlediğini doğrulayın, avagent'ın çalıştığından emin olun, telnet bağlantısını test edin ve güvenlik duvarlarında 28001-28011/30001-30011 bağlantı noktalarına izin verin. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

İstemciye göz atma ve yedekleme sorunları

Avamar Admin kullanıcı arayüzü bir istemciyle iletişim kuramadığında gözlemlenen belirtiler.

  • Yönetici kullanıcı arayüzü, istemcinin dosya sistemine göz atamaz.
  • Yedekleme işleri bekleyen istemci durumunda kalır ve asla başlatılmaz.
  • Manuel yedekleme denemeleri, "waiting-client" durumuyla başarısız oluyor.
  • İstemcideki Avagent günlüğü aşağıdaki gibi hatalar içeriyor:
2017-03-06 05:16:16 avagent Error <5365>: Cannot connect to <ip address>:28001.
2017-03-06 05:16:16 avagent Error <5365>: Cannot connect to AVAMAR_GRID:28001.
  •  İstemcinin dinleme bağlantı noktasına (28002, 28003, 30002 gibi) Telnet zaman aşımına uğruyor veya bağlanamıyor.
  • İstemci veya yardımcı düğüm için DNS araması başarısız oluyor veya yanlış bir IP adresine çözümleniyor.
  • Komutta avagent.bin İşlem istemcide çalışmıyor.
  • Güvenlik duvarı günlükleri engellenen bağlantı noktalarını gösterir (örneğin, 28011 veya 30011'in üzerindeki bağlantı noktaları).

Cause

Avamar Utility Node ile istemci arasındaki iletişim hataları

Bağlantı noktası ve hizmet kullanılabilirliği sorunları:

Yönetici kullanıcı arayüzü, her istemciyle belirli bir dinleme bağlantı noktasında iletişim kurar. Gerekli bağlantı noktası açık değilse, dinlemiyorsa veya engellenmişse kullanıcı arayüzü istemciye göz atamaz ve yedekler "waiting-client" durumunda kalır.

  • Linux/UNIX dosya düzeyinde yedeklemeler bağlantı noktasını kullanır 28002 istemcide.
  • NDMP istemcileri bağlantı noktalarını kullanır 28003 ve daha yüksek (veya 30002 Sertifika kimlik doğrulaması etkinleştirildiğinde).
  • Yardımcı yazılım düğümü bağlantı noktalarını dinler 28001 (veya 30001 sertifika kimlik doğrulaması ile).

Avagent process not running:

Eğer avagent.bin İstemcide işlem yoktur, istemci atanmış bağlantı noktasını dinlemez ve bağlantı hatalarına neden olur.

# Verify avagent processes
ps -ef | grep avagent

 Beklenen çıktı bir içerir avagent.bin İstemci başına örnek, her biri --listenport bağımsız değişkeninden sonra eklenebilecek ek parametreler bulunmaktadır.

DNS çözümleme sorunları:

Yardımcı yazılım düğüm adının çözümlenememesi (örneğin, AVAMAR_GRID) istemciden istemcinin TCP bağlantısı kurmasını engeller.

nslookup AVAMAR_GRID

 Ad çözülmezse istemci, Yardımcı Program düğümünü bulamaz ve bu da yedekleme hatalarına yol açar.

Güvenlik duvarı veya yönlendirme blokları:

Yardımcı yazılım düğümündeki veya istemcideki güvenlik duvarları, gerekli bağlantı noktası aralıklarını (28001-28011, 30001-30011 vb.) engelleyerek zaman aşımlarına veya "sunucuya giden yol yok" hatalarına neden olabilir.

# Example of a blocked connection
telnet <ip address> 28001
telnet: connect to address <ip address>: Connection timed out

 Yanlış veya eksik avfirewall kuralları

Avamar'a özel güvenlik duvarı ( avfirewall) Yardımcı program düğümünde yukarıdaki bağlantı noktalarını engeller 28011 ve 30011 dizinindedir. İstemci daha yüksek bir bağlantı noktası kullanırsa iletişim reddedilir.

# Sample avfirewall rule set
exec_rule -A INPUT  -p tcp --dport 28001:28011 -j ACCEPT
exec_rule -A INPUT  -p tcp --dport 30001:30011 -j ACCEPT
Not: İstemcinin dinleme bağlantı noktasını veya Yardımcı Ağ düğümünün servis bağlantı noktalarını engelleyen güvenlik duvarı kuralları, göz atmayı engeller ve yedeklemelerin bekleme durumunda kalmasına neden olur.

Resolution

Yönetici Kullanıcı Arayüzü istemcisine göz atma ve yedekleme hataları

için sorun giderme adımları1. İstemci ve yardımcı yazılım düğümü için DNS çözümlemesini doğrulayın.
İstemci adının ve Avamar Yardımcı Yazılım Düğümü adının doğru IP adreslerine çözümlendiğinden emin olun.

  • İstemciden, yardımcı yazılım düğümü için bir DNS araması çalıştırın.
  • Yardımcı yazılım düğümünden istemci için bir DNS araması çalıştırın.
# On the client
$ nslookup AVAMAR_GRID

# On the utility node
$ nslookup client_name
Dikkat: Düzenlemeden önce her zaman /etc/resolv.conf dosyasını yedekleyin.
  • Ad çözümlenmezse, /etc/resolv.conf dosyasını doğru ad sunucusu IP'lerini gösterecek şekilde düzenleyin ve aramayı yeniden deneyin.

2. Gerekli bağlantı noktalarının erişilebilir olduğunu onaylayın.
Yardımcı yazılım düğümünden istemciye ve istemciden yardımcı yazılım düğümüne olan bağlantıyı Avagent tarafından kullanılan bağlantı noktalarında test edin.

  • İstemcinin dinleme bağlantı noktasını tanımlayın (Linux/UNIX dosya düzeyinde yedeklemeler için varsayılan 28002, NDMP için 28003+, sertifika kimlik doğrulaması etkinse 30002).
  • Yardımcı yazılım düğümünden istemcinin bağlantı noktasına telnet.
  • İstemciden yardımcı düğümün bağlantı noktasına (28001 veya 30001) telnet üzerinden bağlanın.
# From utility node to client
$ telnet client_ip 28002
Trying client_ip….
Connected to client_ip.
Escape character is '^]'.

# From client to utility node
$ telnet AVAMAR_GRID 28001
Trying utility_ip….
Connected to utility_ip.
Escape character is '^]'.
Uyarı: Zaman aşımı veya "bağlantı reddedildi", bir güvenlik duvarı veya yönlendirme sorunu olduğunu gösterir. Bağlantı noktaları açılana kadar devam etmeyin.
  • avagent.bin işlemi kontrol edin.
  • Çalışmıyorsa hizmeti başlatın.
  • Hata olup olmadığını belirlemek için avagent.log gözden geçirin.
# Check for avagent processes.
$ ps -ef | grep avagent

# Start the service if missing.
$ service avagent start

# Verify the process again.
$ ps -ef | grep avagent

# View the log (path may vary)
$ cat /usr/local/avamar/var/avagent.log
Not: Her istemci için bir avagent.bin işlemine ek olarak Linux yardımcı yazılım düğümü için bir işlem mevcut olmalıdır.

4. Güvenlik duvarı ayarlarını gözden geçirin ve düzenleyin.
Hem Avamar güvenlik duvarı (avfirewall) hem de ana bilgisayar tabanlı güvenlik duvarları gerekli bağlantı noktası aralıklarına izin vermelidir.

  • Engellemeyi ortadan kaldırmak için avfirewall'u geçici olarak durdurun.
  • Yardımcı yazılım düğümünün güvenlik duvarı kurallarının 28001-28011 ve 30001-30011 aralıklarını içerdiğini doğrulayın.
  • Ana bilgisayar tabanlı bir güvenlik duvarı (iptables, firewalld vb.) kullanıyorsanız aynı aralıklara izin vermek için kurallar ekleyin.
# Stop avfirewall (temporary)
$ service avfirewall stop

# Example iptables rules (adjust as needed)
$ iptables -A INPUT -p tcp --dport 28001:28011 -j ACCEPT
$ iptables -A OUTPUT -p tcp --dport 28001:28011 -j ACCEPT
$ iptables -A INPUT -p tcp --dport 30001:30011 -j ACCEPT
$ iptables -A OUTPUT -p tcp --dport 30001:30011 -j ACCEPT
Uyarı: Güvenlik duvarlarını devre dışı bırakmak, sistemi yetkisiz erişime açık hale getirebilir. Testten sonra bunları yeniden etkinleştirin ve yalnızca gerekli bağlantı noktalarının açık olduğundan emin olun.
Güvenlik duvarı yapılandırmasını manuel olarak değiştirmeniz önerilmez.
Bir sonraki yükseltmede bu veriler kaybolacaktır.
IP erişim listesini güncellemek için edit-firewall-rules.sh veya goav komut dosyalarının kullanılması önerilir.
 
Avamar sunucusu:
edit-firewall-rules.sh çalıştırmayla ilgili ayrıntılar KB 19911 de bulunabilir.
Avamar: edit-firewall-rules.sh

ile özel Avamar güvenlik duvarı kuralları ekleme veya kaldırma
Or

NDMP accelerator:
Goav ndmp firewall [command]
Avamar: Goav Network Data Management Protokolü Güvenlik Duvarı Menüsü Nasıl Kullanılır
?Bu, edit-firewall-rules.sh ile aynı yapılandırmada ancak daha basit bir işlemde size yol gösterir.
 
5. İstemciyi IP adresini kullanarak kaydetme (DNS sorunları için geçici çözüm)
DNS hızlı bir şekilde düzeltilemezse, istemciyi IP ile ızgaraya kaydedin.

 

# Run avregister on the client
$ avregister -g AVAMAR_GRID -i client_ip

Not: IP adresinin kullanılması, ad çözümlemesini atlar ancak uygun bir DNS düzeltmesinin yerini almaz.

6. Çözümü doğrulayın

  • Avamar Admin kullanıcı arayüzünden istemciye göz atmayı deneyin.
  • Manuel yedeklemeyi başlatın ve yedeklemenin artık "waiting-client" olarak görünmediğini doğrulayın.
  • Bağlantı noktalarının açık kaldığını doğrulamak için telnet testlerini yeniden çalıştırın.
  • Başarıyla tamamlanıp tamamlanmadığını görmek için yedekleme günlüklerini kontrol edin.
# Example backup log snippet indicating success
[2025-10-13 10:45:22] INFO Backup job completed successfully for client_name

 

Tüm adımları tamamladıktan sonra sorun devam ederse Dell Desteği ile iletişime geçin ve günlük alıntılarını ve güvenlik duvarı kural setini sağlayın.

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000065540
Article Type: Solution
Last Modified: 14 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.