ViPR SRM 3.7 :: NetApp discovery center testing authentication through SSH fails with status 255

Summary: This article explains the solution when NetApp discovery center testing authentication through SSH fails with status 255.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

None

Discovery center test for NetApp array fails with below error:-

Testing Authentication through SSH on array (IP address of Netapp array)
line 19: ssh: command returned with a non-zero status (status: 255) !

FINER level logging to the script engine logs during discovery center test showed below messages:-

FINE     -- [YYYY-MM-DD hh:mm:ss EDT] -- JSchLogger::log(): (jsch): Caught an exception, leaving main loop due to Read timed out
FINE     -- [YYYY-MM-DD hh:mm:ss EDT] -- JSchLogger::log(): (jsch): Disconnecting from IP_address_of_NetApp port 22
FINE     -- [YYYY-MM-DD hh:mm:ss EDT] -- ScriptEngine::invokeScript(): deviceTest failed with the following error !
com.watch4net.script.core.engine.ScriptEngineException: line 19: ssh: command returned with a non-zero status (status: 255) !
    at com.watch4net.script.core.engine.ScriptEngineException.commandFailed(ScriptEngineException.java:90)

Cause

Connectivity issue between collector host and NetApp.

Resolution

In one environment where this issue was encountered, it was identified that NetApp SP collector host was unable to SSH to the array.

To confirm whether collector host can communicate to the NetApp, below test can be performed if the host is a linux collector host:-

# ssh user@ip_address_of_netapp "version"

This will attempt to connect to the NetApp from the collector host over SSH and run the command "version" and obtain the output back.  In one environment this command did not return any data and timed out.  This was the same message seen in the script engine logs configured in debug level logging

 FINE     -- [YYYY-MM-DD hh:mm:ss EDT] -- JSchLogger::log(): (jsch): Caught an exception, leaving main loop due to Read timed out

Customer will have to engage the network and storage team to identify the connectivity issue.

Affected Products

SRM
Article Properties
Article Number: 000065744
Article Type: Solution
Last Modified: 12 Dec 2025
Version:  5
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