Avamar: SQL Backup completed with the exception: Force Incremental after full is failing with the error: "Error: A log gap was identified, or a full backup was not found"

Summary: Avamar SQL Backup completed with exception: Force Incremental after full is failing with the error: "Error: A log gap was identified, or a full backup was not found"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Avamar SQL backup for AlwaysON Databases completes with exceptions.
Force Incremental backup after full is failing with the error: "Error: A log gap was identified, or a full backup was not found"

Here is the snippet from the log:
2017/11/09-18:48:57.86599 [avsql_assist]  ===> sqlconnect::~sqlconnect
2017/11/09-18:48:57.86599 [avsql_assist]  <=== sqlconnect::~sqlconnect
2017/11/09-18:48:57.86599 [avsql_assist]  <=== avsql_assist::snapup_check_timestamps
2017-11-09 13:48:57 avsql Error <15762>: Skipping incremental backup after full for <AlwaysON_DB_Name> database. Error: A log gap was identified or a full backup was not found.
Secondary Replica is selected for the backup in the Dataset.
There is not a third-party or native backup taken.

Cause

Log Sequence Number (LSN) number in the SQL Server and backup metadata is not matching.
The issue is caused when a Full + incremental backups are taken on Primary Replica.
 

Resolution

To resolve this issue, upgrade the Avamar Server to the following Avamar software release:
  • 19.4.100-124 or later

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000065986
Article Type: Solution
Last Modified: 07 Mar 2024
Version:  9
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