XtremIO: XtremIO Dizisinde SSD arızası performans etkisi

Summary: XtremIO Dizisinde SSD arızası performans etkisi

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

XtremIO DPG deki Tek veya Birden Fazla SSD arızası, XtremIO Dizisi üzerinde performans etkisine neden olabilir. Bu duruma neyin sebep olduğunu anlamak için DPG Operasyonlarını ve DPG Durumlarını açıklamalıyız:

- Ana DPG Operasyonları:

DPG Yeniden Oluşturma:

  • Ne zaman: Bir SSD arızalandığında
  • Neden: Çift eşlik korumasını geri yükleme

DPG Entegrasyonu:

  • Ne zaman: Bir teknisyen arızalı bir SSD'yi yepyeni bir sürücüyle değiştirdiğinde
  • Neden: DPG'ye yeni bir SSD ekler

DPG şöyle diyor:

  • Sağlıklı: Çift eşlik koruması
  • Tek Düşürülmüş: Tek eşlik koruması
  • Çift Düşürülmüş: Eşlik koruması yok
  • Başarısız: Veri kaybı

XtremIO, İçeriğe Duyarlı Depolamadır (CAS olarak da bilinir). Bu nedenle DPG'ye yapılan tüm G/Ç işlemleri istatistiksel olarak rastgeledir. Bu durum, kullanıcının rastgele veya sıralı iş yükünden bağımsız olarak aynı performansı elde etmemizi sağlar. Diğer bir avantajı da, bir SSD arızalanırsa kümenin bir sayfayı orijinal konumuna döndürmesinin gerekmemesidir.

CAS olmayan diğer dizilerin hem sıralı mantıksal veriler hem de sıralı fiziksel veriler için gereksinimleri vardır; Verileri orijinal konumuna döndürmezseniz sıralı G/Ç performansını kaybedersiniz.

Not: Kullanıcı yazma işlemleri için kullanılan SSD alanı, veri kurtarma için de kullanılır. XtremIO'nun Hot-Spare özelliği aslında yataydır.

DPG Rebuild'in açıklaması:
Bir SSD çıkarıldığında veya SYM otomatik olarak DPG yeniden oluşturma işlemi yayınladığında DPG yeniden oluşturma işlemi için iki işlem gerçekleştirilmelidir:

1. Aşama: Tüm kayıp verileri kurtarın ve başka bir yere yazın:
Kayıp sayfalar (veri + eşlik) DPG'ye (yeni yazma akışı)
geri yüklenir PLBM/HMD tabloları güncellenir.

2. Aşama: Tüm şeritlerin eşlik bilgilerini güncelleştirme:
Verileri/eşlik sayfalarını taşımak için tüm eşliklerin güncelleştirilmesi gerekir (tüm şeritler arasında)Zamandan
tasarruf etmek ve yazmaları azaltmak için her iki işlem de tüm şeritlerin güncelleştirilmesini gerektirir. Her ikisi de tek bir yinelemede gerçekleştirilir.

Not: DPG yeniden oluşturma akışı, kullanıcı alanını yamyamlaştırmayı gerektirir, ancak XtremIO uygulaması, ilk hatadan kurtarmak için bir SSD değerinde alan bırakır. Bu, X-Brick başına bir gerekliliktir!
Not: DPG ilk SSD'yi kaybettiğinde. DPG'nin kullanılabilir kapasitesi düşmez. Böyle bir senaryo için önceden alan ayırıyoruz
Not: DPG ikinci SSD'yi kaybettiğinde. DPG'nin kullanılabilir kapasitesi bir SSD'nin kapasitesi kadar düşer.

DPG Entegrasyonundan ayrıntılı açıklama: DPG'ye yeni bir SSD eklemek için manuel müdahale gerekir.

  • Bir teknisyenin manuel müdahalesini gerektirir (DAE yuvasına yeni bir SSD yerleştirin)
  • Çok az kritiklik var/hiç yok (yeniden oluşturmaya karşı)

İstendiğinde, DPG entegrasyon işlemi eşlik bloklarını dengeler. Yalnızca eşlik blokları orijinal SSD'ye kurtarılır (eşit bir eşlik dağılımı elde etmek için). Bu, yeni SSD'nin Atanması, Eklenmesi ve Entegre edilmesiyle yapılır.

 

Cause

XtremIO DPG de Tek veya Birden Fazla SSD arızası

 

Resolution

Yukarıdaki bilgilere göre, DPG yeniden oluşturma/tümleştirme sırasında küme kaynağı kullanımında bir miktar artış olur ancak genellikle gözle görülür bir performans veya gecikme süresi artışı olmamalıdır. Ancak çift DPG yeniden oluşturma işlemi sırasında küme, veri bütünlüğünü sağlamak ve veri kaybını önlemek için kaynaklarının neredeyse tamamını arızalı SSD'leri mümkün olan en kısa sürede yeniden oluşturmaya odaklar. Tasarım gereği bu beklenen bir durumdur ve tüm işlemler tamamlandıktan sonra performans normal performansına geri dönmelidir.

 

Affected Products

XtremIO Family

Products

XtremIO Family
Article Properties
Article Number: 000071340
Article Type: Solution
Last Modified: 09 Jan 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.