NetWorker:バックアップは次のエラーで失敗します。「クライアントがNetWorkerサーバー上で正しく構成されていません」

Summary: NetWorkerクライアント ベースのバックアップが、「client CLIENT_NAME;がNetWorkerサーバー上で正しく構成されていません。

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Symptoms

バックアップが次のエラーで失敗します。
Error: 'client (Client_name); is not properly configured on the NetWorker Server'
Error: 'Cannot start session with server (ServerName): client `(Client Name)' is not properly configured on the NetWorker Server'

Cause

最も可能性の高い原因:

  • クライアントのTCP/IP構成が正しくありません。
  • クライアント リソース構成のクライアント名とエイリアスの不整合。
  • クライアントのエイリアス名全体が、クライアント マシンのエイリアス リストで更新されません。

Resolution

チェック1:

リアルタイム イベントを監視するには、 nslookup CLIEN_NAME NetWorkerサーバから取得します。CLIENT_NAMEは、NetWorkerで構成されているNetWorkerクライアントの名前に置き換えます。クライアント構成は、NMC(NetWorker管理コンソール)またはNWUI(NetWorker Webユーザー インターフェイス)のProtection->Clientsで確認できます

NetWorkerサーバーとクライアント上のhostsファイルを確認して、NetWorkerサーバーまたはクライアントで競合する名前が入力されていないことを確認します。

Linuxの場合 /etc/hosts
Windowsの場合: C:\Windows\System32\drivers\etc\hosts

NetWorker:名前解決のトラブルシューティングに関するベスト プラクティス

いずれかのシステムでドメイン ネーム システム(DNS)の問題またはホスト ファイルの競合が発生した場合。適宜修正します。 


チェック2:

NetWorkerサーバーがNetWorkerクライアントに接続できることを確認し、クライアント ポートを確認します。

nsrrpcinfo -p CLIENT_NAME

root@lnx-nwserv:~# nsrrpcinfo -p win-client01.prod.lan
PROGRAM VERSION PROTOCOL PORT SERVICE
100000  2       tcp      7938 nsrportmapper  Port Mapper
100000  2       udp      7938 nsrportmapper  Port Mapper
390436  1       tcp      9896 nsrexecd       GSS Authentication
390435  1       tcp      7989 nsrexecd       Resource Mirror
390440  1       tcp      8305 nsrexecd_nsrfa Remote File Access
390113  1       tcp      7937 nsrexecd       Remote Execution

NetWorkerクライアントから、NetWorkerサーバーに接続できることを確認します。

nsradmin -p nsrexecd -s NSR_SERVERNAME

ここでNSR_SERVERNAMEは、NMC(NetWorker管理コンソール)またはNWUI(NetWorker Webユーザー インターフェイス)に表示されるNetWorkerサーバー名です。

NetWorkerクライアントに拡張クライアント パッケージがある場合は、 nsrrpcinfo クライアントからサーバーへ。拡張クライアント ソフトウェアがインストールされていない場合は、 nsrrpcinfo クライアント上。

Linuxの場合 rpm -qa | grep lgtoxtdclnt
Windowsの場合:[プログラムと機能]をチェックして、NetWorker拡張クライアントがリストされているかどうかを確認するか、次のコマンドを使用します。

wmic product where "Name = 'NetWorker Extended Client'" get name, IdentifyingNumber, PackageName

nsrrpcinfo -p NSRE_SERVERNAME


デフォルトのNetWorkerサービス ポート範囲は7937-9936です

NetWorkerプロセスとポート

メモ: クライアントまたはサーバーがNetWorkerサービス ポートを介して相互に通信できない場合は、オペレーティング システムのファイアウォールでこの通信をブロックするルールがないか確認します。この通信をブロックしているオペレーティング システムのファイアウォールがない場合は、これらのポートをブロックしている可能性のあるネットワーク ファイアウォールがないか、ネットワーク管理者に確認してください。

 

チェック3:
クライアントは、NetWorkerで1つの名前を使用して構成されていても、別の名前で応答している場合があります。 

1.NMC(NetWorker管理コンソール)またはNWUI(NetWorker Webユーザー インターフェイス)のProtection->Clientsで、NetWorkerサーバーに表示されているクライアント名を確認します。

2.NetWorkerサーバーで、次のコマンドを実行します。

nsradmin -p nsrexecd -s CLIENT_NAME

3.から nsradmin プロンプトで次のように入力します。

show name

4.以下を入力します。 

print type: nsrla

Example:

root@lnx-nwserv:~# nsradmin -p nsrexecd -s win-client01.prod.lan
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> show name
nsradmin> print type: nsrla
                        name: win-client01.amer.lan;
nsradmin> quit
クライアントはNetWorkerで1つの名前で構成されていますが、クライアントのnsrexecdプロセスは別の名前で応答しています

5.クライアントの[エイリアス]フィールドを更新して、クライアント のnsrla エントリーに表示される名前を含めます。

NetWorkerクライアント エイリアス

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000072315
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  5
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