NetWorker: NVP vProxy: Error enabling storage migration, retrying, error: VDDK Error: 3014

Summary: NVP: Error enabling storage migration, retrying, error: VDDK Error: 3014: Insufficient permissions in the host operating system.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker VMware Protection integration is configured with the vProxy Appliance.  The backup session fails with one of the following messages:
YYYY/MM/DD HH:MM:SS TRACE: Attempting to disable storage migration of virtual machine "vm-85" ...
YYYY/MM/DD HH:MM:SS ERROR: Failed to disable storage migration for virtual machine "VDDK Error: 3014: Insufficient permissions in the host operating system.":  %!v(MISSING)
...
YYYY/MM/DD HH:MM:SS INFO:  Enabling storage migration of virtual machine ...
YYYY/MM/DD HH:MM:SS ERROR: Failed to enable storage migration for virtual machine: "VDDK Error: 3014: Insufficient permissions in the host operating system.": %!v(MISSING)

Cause

The vProxy backup workflow will disable storage migration for the virtual machine at the start of the backup and enable it once it completes.  The configured VMware View (NSR Hypervisor) user role does not have sufficient permissions to either enable or disable storage migration.

Resolution

The required minimum user role permissions are documented in the "Creating a dedicated vCenter user account and EMC Backup and Recovery role" section of the Dell NetWorker VMware Integration guide.  To confirm which permissions the vCenter user account is missing, the ProxyHC utility can be used:
NVP-vProxy: How to use health check tool ProxyHC on vProxy appliance

The syntax to confirm permissions is: 
./ProxyHC perm

Affected Products

NetWorker Series

Products

NetWorker Series
Article Properties
Article Number: 000077917
Article Type: Solution
Last Modified: 10 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.