Avamar: SQL back-up of bladeren mislukt met "avsql Error <15760>: Geen doelstellingen na uitbreiding"

Summary: Op Avamar SQL gebaseerde back-up- en bladerbewerking mislukt voor SQL standalone server- en clusterclients. Avamar SQL back-up of bladeren door database mislukt met "avsql Error <15760>: Geen targets na uitbreiding." Dit komt door ontbrekende systeembeheerdersrollen, verbindingsproblemen, verbindingsproblemen met Windows Management Instrumentation (WMI)-services, communicatieproblemen met de Avamar-poort of ontbrekende SQL Server Management Objects (SMO) DLL-bestanden. ...

:-geen-doelstellingen-na-uitbreiding"" />
This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Er is een probleem met Avamar SQL-back-up en het doorbladeren van databases in zowel zelfstandige SQL- als clusteromgevingen.

Casescenario

Maak een back-up van het probleem en blader door het probleem met behulp van de avsql-plug-in van de Avamar Administrator Console GUI of AUI.

Back-up foutcodes: avsql Error <15760>: Geen targets na uitbreiding!

Wanneer deze fout aanwezig is in de back-ups, geeft dit aan dat er geen bladerprobleem en databasegegevens worden opgehaald met behulp van het avsql diensten.

Back-up van Avamar SQL (avsql) of bladeren door databases mislukt met "avsql Error <15760>: No targets after expansion!"

Back-up- en bladerbewerking op basis van Avsql mislukt voor SQL standalone server- en clusterclients.

 

Cause

Er zijn verschillende mogelijke oorzaken voor dit gedrag.
  1. Ontbrekende systeembeheerdersrollen voor het gebruikersaccount of de Active Directory-gebruiker (SQL 2012 en hoger) die wordt gebruikt onder back-upagentservices.
  2. Verbindingsprobleem tussen SQL SMO en Avamar SQL-plug-in.
  3. Verbindingsprobleem met WMI-services tussen SQL Server en Windows-services.
  4. Avamar-communicatiepoorten zijn niet toegankelijk. 
  5. Ontbrekende SMO dll-bestanden of andere vereiste bestanden die functioneren om de databasegegevens op te halen.

Resolution

De volgende stappen kunnen worden gevolgd om de back-up- en browseproblemen in standalone en clusterconfiguraties te beperken:

SQL standalone servers
 
  1. Ontbrekende systeembeheerdersrollen voor het gebruikersaccount dat wordt gebruikt onder Backup Agent Services. Raadpleeg het KB-artikel over het toewijzen van systeembeheerdersrollen:
  2. Configureer machtigingen voor volledig beheer voor AD-account dat wordt gebruikt voor SQL Server 2012 en hoger. Meer gedetailleerde informatie vindt u op pagina 11 van Avamar SQL gebruikershandleiding V19.9
  3. Vereiste SMO-bestanden ontbreken voor de SQL Server-services.
  4. Avamar SQL-services (avsql) kunnen geen verbinding maken met SQL SMO-bestanden die aanwezig zijn op SQL vanwege een gemengde omgeving
  5. Voer de onderstaande opdracht uit om te controleren of de SQL-instantie wordt doorzocht.
avsql.exe --debug --operation=browse --verbose 
    1. De volgende vlagsyntaxis --usesmoversion="SMO version" kan worden gebruikt om te controleren welke vlag kan worden gebruikt om verbinding tussen SMO en avsql-services af te dwingen:
    2.  Voorbeeld voor SQL 2016:
 avsql.exe --debug --operation=browse --verbose --usesmoversion=13 
  1.  Voer de volgende opdracht uit om te zien of de SQL-databases worden doorzocht:
avsql --operation=browse (local) 
  1. Test de connectiviteit tussen SMO en SQL Server met behulp van de onderstaande KB:
[reflection.assembly]::LoadWithPartialName("Microsoft.SQLServer.SMO") 
      1. Voer de volgende instructie in:
$SQLServer = new-object ("Microsoft.SQLServer.Management.SMO.Server") 
      1. Voer de volgende instructie in:
foreach($SQLDatabase in $SQLServer.databases) {$SQLDatabase.name} 
      1. Dit resulteert in een lijst van de databases op de client. Dit bevestigt dat de SMO correct is geladen en verbinding maakt met SQL Server. Als het resulteert in een fout, moet dit worden opgelost voordat Avamar kan slagen.
  1. Controleer de cmd-uitvoer van avsql.exe --debug --operation=browse --verbose en zoek naar SQL-services-gerelateerde fouten:
  1. Afhankelijk van de bitversie van SQL Server kan de onderstaande vlag eerst worden getest met bladeren op basis van CLI en later indien nodig aan avsql.cmd worden toegevoegd om de bladerbewerking mogelijk te maken:
    1. Voorbeeld:
avsql.exe --debug --operation=browse  verbose --provider-architecture=64bit
  1. Zorg ervoor dat de SQL-browserservices en benoemde pipes zijn ingeschakeld onder de SQL-configuratietool, SQL Network Protocol voor de specifieke SQL-serverinstantie.
  2. Zorg ervoor dat de vereiste smo.dll bestanden aanwezig zijn onder c:\programfiles\avs\bin op de clientversie. Controleer de gebruikte SQL server-versie om te controleren op de vereiste versie van het smo.dll-bestand.
    • SQL Active/passive of Always-On cluster
      1. Meld u aan bij het primaire knooppunt of het eigenaarsknooppunt van de clusterconfiguratie
      2. Stappen 1 - 9 van SQL standalone server probleemoplossing kan worden bekeken en gevolgd vanaf het eigenaarsknooppunt van het cluster.
      3. De opdracht die wordt gebruikt voor het uitvoeren van CLI-bladeren om informatie over SQL-instanties op te halen:
avsql --operation=browse --sqlserver=SQLCluster_name --hostnamesql=SQLCluster_name 
      1. Zorg voor communicatie tussen het IP-adres van de clusterclient en Avamar die door door de poorten 28002 en 28003 (of 30002 en 30003) bladert
      2. Als er een vermoedelijk communicatieprobleem is tussen de SQL-clusterclient en SQL-listener, voegt u de volgende vlag toe in avsql.cmd onder de gedeelde var-locatie:
--sqlserver=listenerIP,listenerPortnumber 
    • Opmerking: De bovenstaande details zijn aanwezig in de SQL Studio-tool>>, SQL-instantie>>, Beschikbaarheidsgroep, listenerlistener>>met hoge beschikbaarheid>>en klik met de rechtermuisknop op eigenschappen.
      1. Voeg clusterknooppuntvlaggen toe aan avsql.cmd bestand onder gedeelde var-locatie om afzonderlijke SQL-servers op te geven voor communicatiefouten "Kan geen verbinding maken met de externe client '<IP_ADDRESS>', foutcode: 2. Zorg ervoor dat de externe back-upagent wordt uitgevoerd:
--clusternode=<SQL_node_name>(<IP_ADDRESS>) 
      1. Controleer de wisselpoort die wordt gebruikt voor de clusterclient van Avamar GUI>>Navigatiebeleid>>>> Selecteer de client en bewerk deze.
        1. Voeg 280002/28003 toe, gevolgd door het deactiveren van de client, het wijzigen van de onderstaande opstartparameters en het opnieuw activeren van de clusterclient.
        2. Vervang --disable-gui en voeg --listenport=28002 of 28003 toe in de opstartparameters van het cluster die te vinden zijn onder Failover cluster tool>>Selecteer de gebruikte>> rol Klik met de rechtermuisknop op eigenschappen van back-upagentservices voor het cluster.
        3. Voorbeeld:
          1. Vóór wijzigingen:
            --service  --mcsaddr=coeavr01.coe.int --mcsport=28001 --dpndomain=clients --vardir="E:\Program Files\Backup Agents for Cluster Groups\COEWINFILE\var" --logfile="E:\ProgramFiles\Backup Agents for Cluster Groups\COEWINFILE\var\avagent.log" --sysdir="E:\Program Files\Backup Agents for Cluster Groups\COEWINFILE\etc" --netbind=. --disablegui=true --pin_include=windows.pin,sql.pin
          2. Na wijzigingen: 
            --service  --mcsaddr=coeavr01.coe.int --mcsport=28001 --dpndomain=clients --vardir="E:\Program Files\Backup Agents for Cluster Groups\COEWINFILE\var" --logfile="E:\Program Files\Backup Agents for Cluster Groups\COEWINFILE\var\avagent.log" --sysdir="E:\Program Files\Backup Agents for Cluster Groups\COEWINFILE\etc" --netbind=. --listenport=28002 --pin_include=windows.pin,sql.pin 
        4. De onderstaande vlag kan worden toegevoegd in avsql.cmd onder de gedeelde var-locatie om de SQL-databases op knooppuntniveau weer te geven:
          --show_db_in_availability_group=true 

           

Affected Products

Avamar Plug-in for SQL

Products

Avamar
Article Properties
Article Number: 000082137
Article Type: Solution
Last Modified: 19 Nov 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.