How to Use and Troubleshoot the Dell Wireless Dock D5000
Summary: Learn how to setup, use, and troubleshoot Dell Wireless Dock D5000. Find information about drivers, setting up multiple monitors and steps to resolve common issues.
Symptoms
Cause
The Dell Wireless Dock D5000 is a device that links all your electronic devices to your laptop with a WiGig interface. When you connect the laptop to the docking station, you can gain access to all your peripherals without having to plug them to the laptop. (For example: Mouse, keyboard, stereo speakers, external hard drive, and large-screen displays, and so on.)
Resolution
For help with specifications, setup, connecting an external monitor, troubleshooting common issues, and so on, see the matching expanding section below.
| Personal computer Connectivity |
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|---|---|
| Frequency |
|
| Video ports |
|
| Data rate |
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| Audio ports |
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| Network ports |
|
| USB ports |
|
The docking station is supported on PCs with Dell Wireless 1601 Tri-Band Combo half mini card.
Dell Wireless 1601 Tri-Band Combo Half Mini Card supports: (The WiGig Specification v1.1 and IEEE 802.11ad D6.0; Wireless Local Area Networks (WLAN) IEEE 802.11 a/b/g/n; Bluetooth Enhanced Data Rate, High Speed, and Low Energy operation.) It is featured with: (A steady stream of up to 4.6 Gbps WiGig, 300 Mbps WLAN, and Bluetooth combo function. Which provides three technologies for enterprise, home wireless LAN, and PAN access.)

Figure 1: Front view of Dell Wireless Dock D5000
| 1 | Pairing Button |
| 2 | USB 3.0 Connector |
| 3 | Audio/Microphone Combo Connector |
| 4 | Docking Status LED |

Figure 2: Rear view of Dell Wireless Dock D5000
| 1 | Power Switch |
| 2 | Power Connector |
| 3 | Network Port |
| 4 | USB 3.0 Connector x2 |
| 5 | HDMI Connector |
| 6 | DisplayPort Connector |

Figure 3: Left view of Dell Wireless Dock D5000
| 1 | Security Cable Slot |

Figure 4: Right view of Dell Wireless Dock D5000
| 1 | Reset Button |
Dell Wireless Dock D5000 works with the Wireless Docking software. The software comes preinstalled on your personal computer that is equipped with a Dell 1601 Tri-Band WiGig card. If you must download and install the driver manually, follow the instructions below.
- Browse to Dell Drivers & Downloads page
- Enter the Service Tag of your computer or click Browse all products
- Select your Dell computer from the list
- Click Download next to the respective Dell Wireless card driver and save the file to your computer
- Browse to the folder where the file was saved and double-click the driver installation file
- Follow the screen instructions until the installation is complete
- Restart the computer
- Connect all the external devices to the docking station
Once the Wireless Dock software and drivers are successfully installed on your personal computer, follow the steps below to connect to the Dell Wireless Dock D5000
- Click the Wireless Docking software icon in the taskbar notification area. The Dock Station dialog appears and displays all the available docks
- Select the Dell Wireless Dock D5000. The available options for the Dell Wireless Dock D5000 are displayed
- Select the check box Connect Automatically if you want to connect to the Dell Wireless Dock D5000 automatically from the next time (optional)
- Select Connect, you are prompted to enter a password or push the paring button on the Dell Wireless Dock D5000 and press return key on your desktop/laptop
- The Dell Wireless Dock D5000 is now connected to your desktop/laptop
SSID: D5000_xxxxxx (xxxxxx represents 6 alphanumeric).
Password: 12345678
To delete all associated settings stored on your Dell Wireless Dock, press and hold down the reset button for 10 seconds. All dock settings are deleted, and you have to reestablish a connection. To reestablish a connection to a wireless dock, you must repeat the connection process.
| Symptom | Possible Solution |
|---|---|
| No video on the monitor attached to the HDMI port on the dock |
|
| No video on the monitor attached to the DisplayPort port on the dock |
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| Video on the attached monitor is distorted or flickering |
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| Video on the attached monitor is not displayed as an extended monitor |
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| The audio jack is not functioning or is lagging |
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| USB ports are not functional on the docking station. |
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| HDCP content is not able to be displayed on the attached monitor |
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| LAN port is not functional |
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| Wireless Hub Connection Manager is not loaded |
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| A WiGig connection is not established |
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| An intermittent drop in connectivity with dock when the antenna on a laptop LCD panel is pressed. Alternatively, when there is movement obstructing the signal or a different angle between the laptop and the dock |
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| Webcams usage likely shows issues at higher or default video resolutions |
|
Frequently asked questions
Windows 10
After the Windows 10 upgrade from Windows 8.1, the WiGig refresh button is disabled. It is confirmed that there is no Windows 10 1601 WIGIG driver for D5000. There is a workaround to reenable the WiGig refresh button in Windows 10 as described below.
Registry Edit
Prior to the Registry edit, install the Windows 8.1 version of the Dell Wireless 1601 WiGig Application from Dell Drivers & Downloads. (Compatible products: Latitude 6430u, E5440, E5540, E7240, E7440, and the Precision M4800, M6800)
You must download and install the latest DisplayLink driver for Windows 10 from the: DisplayLink Site
- Open Windows Registry Editor by typing:
regeditin the Start menu and pressing enter. - Go to the following key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1AE9&DEV_0101&SUBSYS_00000000&REV_0?\????????????\Device Parameters
orHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1AE9&DEV_0101&SUBSYS_00000000&REV_0?\????????????\Device ParametersNote: The Question marks means that you should open the first and only sub key in there, whatever it is. It looks like 4&232ce1b2&0&00E3. (The value is system-dependent.)
If you can find the key paths, modify both and follow up steps 3 to 6. - Add a new subkey Under Device Parameters:
- Right-click the Device Parameters key.
- From the context menu, select New -> Key.
- Paste
e5b3b5ac-9725-4f78-963f-03dfb1d828c7instead of the New Key #1 name of the newly created item.
- Add a new DWORD value under the newly added subkey:
- Right-click
e5b3b5ac-9725-4f78-963f-03dfb1d828c7key. - From the context menu, select New -> DWORD (32-bit) value.
- Paste
EnableAllBridgeInterruptsinstead of the New Value #1 name of the newly created item. - Double-click the
EnableAllBridgeInterruptsitem. - In the window that appears, Edit the DWORD (32-bit) value window type
1instead of0in the Value data: Field. - Press OK.
- Right-click
- Exit the Registry Editor.
- Reboot the computer.
Example:
Figure.5 Editor Screenshot (English Only)
To resolve this error, follow the steps below:
- Go to the
"%WinDir%\Microsoft.NET\Framework\%version%\CONFIG"directory - Right-click machine.config and select Properties
- On the Security tab, click Edit and add the User Account to the permissions for the
machine.configfile. Ensure the minimum User permissions granted are Read and Execute
C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\CONFIG
You may experience an issue with no sound from the headphone jack on the D5000 Wireless Dock. The computer does detect the headphones when plugged into the jack and unplugged. If the D5000 is connected to an HDMI or Display Port cable, the audio plays through speakers connected to the Monitor or TV. Reinstalling the Dell 1601 WiGig driver from Dell Support does not resolve the issue.
To resolve the issue, update the DisplayLink USB Graphics Software for Windows to the latest version.
- Download and install the latest DisplayLink driver from the DisplayLink.com/downloads
page.
- Follow the screen instructions until the installation is complete.
- Restart the computer.
These instructions are to install the Dell Wireless 1601 WiGig card in a supported computer: (For example: Dell 6430u, M6800, E7440, and so on with the Dell Wireless (DW) 1601 ordered from the factory.)
- Before beginning the installation, ensure that the BIOS and wireless card drivers are up to date for the computer. These two are updated BEFORE starting the installation of the WiGig application and Drivers.
Note: If the computer is already working fine with the drivers loaded, and they must be updated, the removal/clean install section can be skipped, and the drivers could be updated in the order prescribed starting at STEP 4.
- If the installation has been attempted without success, ALL existing software must be removed from the computers Programs and Features in the following order:
Note: A restart is not required after every uninstall. While uninstalling the software you may get errors saying the software has already been uninstalled or that an .inf file is missing, this in not unusual. Ensure that all the above software is uninstalled then restart the computer.
- D5000 Wireless Dock - say no to keeping existing network profiles and select yes to remove the Marlon driver with prompts.
- Dell USB Docking Software
- DisplayLink Core Software
- DisplayLink Graphics (may not be installed)
- Fresco Logic USB3.0 Host Controller
- Qualcomm Atheros Communications Inc.(R) AR81 Family Gigabit/Fast Ethernet Driver
- Wilocity Monitor (The D5000 uninstaller may uninstall this.)
- After the reboot, ensure that the dock is turned off, and nothing but the power cable is plugged in before continuing.
- Download the following two files before starting the installation:
- DisplayLink USB Software for Windows
- Dell Wireless 1601 WiGig Application (download the latest version on the Dell Support Website)
- DisplayLink USB Software for Windows
- After completing the download, install the 1601 WiGig Application first. You should get a window that appears on the screen with the status of the install as shown below (See Figure.6). Ensure that the status of all items are listed as "PASS." If any items DO NOT show a "PASS" or show "FAIL," then the software must be uninstalled as shown in STEP 2, the computer rebooted, and the installation must start over.

Figure 6. InstallShield Wizard - After all items have passed, reboot the computer. After the reboot, double-click the D5000 Dock icon on the desktop or the D5000 icon in the system tray near the clock (See Figure.7). This opens the D5000 Wireless Hub Connection Manager.

Figure.7 Dock Icon Menu - When the Connection Manager opens, click the gear icon at the top of the screen. (See Figure.8.)

Figure.8 Wireless Hub Connection Manager - When the settings menu opens after clicking the gear icon, click on the "Advanced" tab on the left side of the screen and scroll to the bottom. Locate the "Upgrade local Firmware" field and click the "…" icon to open the file browser (See Figure.9).

Figure.9 Settings - The browser should default to the location of the 1601 firmware upgrade but if it does not the file path is: C:\Program Files (x86)\Dell Wireless\DW1601\DockImages\
- Double-click the '1.3.0.3283_wilocity_img.bin' then click the 'Start' button to begin the flash. Select yes on the following prompt. You see the status at the bottom of the settings window, once it is finished you see a success window.
- Now go ahead and install the Display Link driver file you downloaded earlier but DO NOT restart when/if it is prompted to restart. After the install window disappears, go into Programs and Features and verify that "DisplayLink Core Software," and "DisplayLink Graphics" are both at the latest version. Once verified that entries are present, restart the computer.
- After the restart, turn on the dock and open the D5000 connection manager. The computer recognizes the dock, and the dock LED is solid amber. Connect to the dock by pressing and holding the orange power button to begin the sequence. (See Figure.10)

Figure.10 Dock Power Button on front of dockNote: If the computer does not pair properly using the button on the dock, you can also use the "Connect" button in the Connection Manager using the default text password of 12345678. - Once the dock and computer see each other, they begin the autonegotiation of the connection. Ensure that the "Connect Automatically" box is checked to have this dock connect automatically in the future (See Figure.11).

Figure.11 Connection Manager - After everything is finished installing the dock should show as connected, and the physical LED on the dock should be solid white. There is a Green icon in the task bar that lets you know that the computer synced properly. (See Figure.12)

Figure.12 Green menu Icon - After pairing successfully, you may see a message that will appear stating that the dock firmware is being updated. If this message appears or asks if you want to update, select "Yes" and let this finish. (See Figure.13.)

Figure.13 Upgrade screen - After the firmware update, the dock tries to automatically power cycle itself. If it errors out when it tries to automatically restart the dock, then you can manually power cycle it to finish the dock update. When you do so, it reconnects with no issues.
- After the dock is power cycled, test a USB device and/or display connected to the dock. You can also verify connectivity within the Connection Manager by viewing the status of the dock. Ensure that it is showing as "Connected." (See Figure.14)

Figure.14 Installation screen
