Rozwiązywanie problemów z trybem uśpienia i hibernacji na komputerach Dell z systemem Windows 10 i 11
Summary: Masz problemy z trybem uśpienia lub hibernacji w notebooku lub komputerze stacjonarnym firmy Dell? Dowiedz się, jak rozwiązywać problemy z trybem uśpienia, ustawieniami hibernacji i zasilaniem w systemie Windows 10 i 11 za pomocą rozwiązań. ...
Symptoms
Czy występują problemy z trybem uśpienia lub hibernacji w komputerze?
Ten artykuł omawia szereg kolejnych kroków. Dowiedz się, jak identyfikować i rozwiązywać problemy z trybem uśpienia i hibernacji w systemie operacyjnym Windows 11 i Windows 10.
Stany zasilania komputera
- S1/S2/S3 — uśpienie: Komputer wygląda jakby był wyłączony. Zużywa mniej energii niż w przypadku pozostawienia go z włączonym zasilaniem, ale więcej energii niż w przypadku hibernacji. Stan S3 zużywa mniej energii niż S2, a stan S2 mniej niż S1. Komputer zwykle obsługuje tylko jeden z tych trzech stanów. W tych stanach pamięć nietrwała komputera osobistego jest odświeżana w celu utrzymania stanu, w którym komputer przeszedł w tryb uśpienia. Niektóre podzespoły wewnętrzne nadal są zasilane, aby komputer mógł zostać wybudzony sygnałem wejściowym z klawiatury, sieci LAN lub urządzenia USB. (Jest to podobne do wstrzymywania i wznawiania komputera).
- S4 — hibernacja: Komputer wygląda jakby był wyłączony. Ten tryb wykazuje najniższy poziom poboru energii z wyjątkiem wyłączenia komputera. W tym stanie komputer zapisuje zawartość pamięci nietrwałej w pliku hibernacji. Umożliwia to utrzymanie stanu komputera w stanie hibernacji. Niektóre podzespoły wewnętrzne pozostają zasilane, aby komputer mógł zostać wybudzony sygnałem wejściowym z klawiatury, sieci LAN lub urządzenia USB. Kontekst roboczy może zostać przywrócony, jeśli został zapisany w pamięci nieulotnej. (To jak skopiowanie wszystkich otwartych i uruchomionych aplikacji na nośnik i zamknięcie systemu, a następnie ponowne wczytanie zapisanych aplikacji i danych podczas uruchomienia).
Więcej informacji na temat stanów zasilania komputera można znaleźć w następującym dokumencie:
Cause
Brak dostępnych informacji o przyczynie.
Resolution
Czynności rozwiązywania problemów
Wykonaj poniższe kroki, aby zidentyfikować i rozwiązać problem:
Pierwszym krokiem jest ustalenie, czy komputer jest w stanie wyłączenia, uśpienia czy hibernacji poprzez sprawdzenie wskaźników komputera:
- Interpretacja kodów dźwiękowych w komputerze firmy Dell
- Przewodnik po wskaźnikach diagnostycznych przenośnych stacji roboczych Precision
- Przewodnik wskaźników diagnostycznych komputera Dell Latitude
- Przewodnik po wskaźnikach diagnostycznych notebooka XPS
- Przewodnik po wskaźnikach diagnostycznych notebooka Vostro
- Przewodnik po wskaźnikach diagnostycznych notebooka Inspiron
- Interpretacja kodów dźwiękowych w komputerze stacjonarnym firmy Dell
- Przewodnik po wskaźnikach diagnostycznych stacji roboczych Precision
- Przewodnik po wskaźnikach diagnostycznych komputera Dell OptiPlex
- Przewodnik po wskaźnikach diagnostycznych komputera stacjonarnego XPS
- Przewodnik po wskaźnikach diagnostycznych komputera stacjonarnego Vostro
- Przewodnik po wskaźnikach diagnostycznych komputera stacjonarnego Inspiron
- Gdy komputer wznowi pracę ze stanu uśpienia, przejdzie bezpośrednio do ekranu logowania
- Gdy komputer wznawia pracę ze stanu hibernacji, ponownie przechodzi przez procedurę testową POST. Zanim przejdzie do ekranu logowania, komunikuje, że przywraca system Windows.
Sprawdź fizyczną konfigurację komputera, aby upewnić się, że nie wpływa ona na sposób działania komputera:
- Sprawdź wszystkie kable wchodzące do i wychodzące z komputera. Czy są mocno osadzone w miejscu?
- Sprawdź, czy wszystkie urządzenia mają zasilanie.
- Sprawdź, czy żaden nośnik nie znajduje się w żadnym czytniku podczas uruchamiania komputera.
- Sprawdź, czy inne urządzenie lub przedmiot nie miażdży ani nie aktywuje urządzenia wejściowego.
- Sprawdź, czy nie doszło do uszkodzenia lub zalania płynem komputera lub jego urządzeń.
Metody wybudzania ze stanu uśpienia
Wznowienie ze stanu uśpienia powinno być możliwe przy użyciu dowolnego urządzenia wejściowego. Może to być naciśnięcie dowolnego klawisza na klawiaturze, kliknięcie lub przesunięcie myszy lub naciśnięcie przycisku zasilania. (Alternatywnie, jeśli ustawiono funkcję Wake-on-LAN, zaplanowano timer albo dotknięcie touchpada, otwarcie pokrywy lub naciśnięcie przycisku uśpienia).
Metody wybudzania ze stanu hibernacji
Naciśnij migający przycisk zasilania lub klawisz na klawiaturze. (Jeśli funkcja hibernacji została skonfigurowana do wybudzania po naciśnięciu klawisza).
-
Otwórz w przeglądarce witrynę pomocy technicznej firmy Dell.
-
Wprowadź kod Service Tag komputera, aby wyświetlić stronę dopasowaną do komputera dostarczonego przez firmę Dell. (Możesz także wybrać typ komputera z listy produktów, aby wyświetlić listę informacji ogólnych dla danego typu komputera).
-
Wybierz opcję Sterowniki i pliki do pobrania po lewej stronie.
-
W menu rozwijanym poniżej opcji Kategoria wybierz opcję Basic Input/Output System (BIOS).
-
Kliknij przycisk pobierania znajdujący się po prawej stronie pliku BIOS na liście.
-
Kliknij dwukrotnie pobrany plik i postępuj zgodnie z instrukcjami na ekranie.
-
Podczas tego procesu komputer zostanie zamknięty i uruchomiony ponownie (nie wyłączaj komputera, gdy będzie się to działo).
-
Gdy komputer uruchomi się ponownie, system BIOS zostanie zaktualizowany do najnowszej wersji.
-
Zaktualizuj chipset.
-
Otwórz w przeglądarce witrynę pomocy technicznej firmy Dell.
-
Wprowadź kod Service Tag komputera, aby wyświetlić stronę dopasowaną do komputera dostarczonego przez firmę Dell. (Możesz także wybrać typ komputera z listy produktów, aby wyświetlić listę informacji ogólnych dla danego typu komputera).
-
Wybierz opcję Sterowniki i pliki do pobrania po lewej stronie.
-
Z menu rozwijanego pod nagłówkiem Kategoria wybierz pozycję Chipset.
-
Kliknij przycisk pobierania znajdujący się po prawej stronie pliku chipset na liście.
-
Kliknij dwukrotnie pobrany plik i postępuj zgodnie z instrukcjami na ekranie.
-
Komputer wyświetli monit o wyłączenie i ponowne uruchomienie po zakończeniu tego procesu. (Nie wyłączaj komputera podczas tego procesu. Zrób to tylko wtedy, gdy pojawi się taki monit).
-
Znajdowanie i aktualizacja innych sterowników komputera na komputerze.
Postępuj zgodnie z instrukcjami krok po kroku zawartymi w artykule bazy wiedzy firmy Dell Pobieranie i instalacja sterowników firmy Dell.
-
Otwórz okno Windows Update.
-
Kliknij przycisk Start systemu Windows i wpisz Windows Update, a następnie wybierz z listy pozycję Ustawienia aktualizacji systemu Windows.
-
Czy widzisz opcję Kompilacje w wersji Preview w menu po lewej stronie?
-
Jeśli odpowiedź brzmi Tak, kliknij opcję Kompilacje w wersji Preview.
-
Kliknij przycisk Sprawdź.
-
Pobierz i zainstaluj nową kompilację.
-
-
Jeśli odpowiedź brzmi Nie, czy Twoja firma lub organizacja ukrywa tę funkcję lub zarządza nią?
-
Aby zaktualizować system operacyjny, skontaktuj się z działem IT Twojej organizacji lub firmy.
-
-
-
Otwórz Opcje zasilania w panelu sterowania
-
Kliknij prawym przyciskiem myszy przycisk menu Start i wybierz Opcje zasilania z wyświetlonego menu
-
Kliknij opcję Zmień ustawienia planu obok bieżącego planu zasilania.
-
Zmień ustawienie opcji Przełącz komputer w tryb uśpienia na nigdy.
-
Kliknij przycisk Zapisz zmiany
-
Otwórz wiersz Polecenie lub PowerShell z uprawnieniami administratora.
-
Kliknij prawym przyciskiem myszy przycisk Start systemu Windows i wybierz odpowiednią opcję z wyświetlonego menu
-
Wpisz następujące polecenie i naciśnij klawisz Enter:
powercfg.exe /h off -
Zamknij okno wiersza.
Czy urządzenie przestało działać lub być wykrywane po wznowieniu działania komputera ze stanu uśpienia lub hibernacji? Wykonaj następujące kroki rozwiązywania problemów:
-
W przypadku podłączenia do zasilania zewnętrznego popraw kabel zasilający.
-
Popraw kabel łączący urządzenie z komputerem.
-
Jeśli problem będzie się powtarzał, zamknij i uruchom ponownie komputer.
W systemie BIOS
-
Uruchom do systemu BIOS. Naciskanie klawisza F2 podczas rozruchu powoduje przejście bezpośrednio do systemu BIOS w większości komputerów firmy Dell
-
W menu Power Management (Zarządzanie energią) upewnij się, że funkcja USB Wake Support (Obsługa wybudzania przez USB) jest włączona, a funkcja Deep Sleep Control (Kontrola głębokiego uśpienia) jest wyłączona.
-
Zapisz zmiany i Zamknij system BIOS
W systemie Windows
-
Otwórz okno Zaawansowane opcje zasilania.
-
Naciśnij jednocześnie klawisze Windows + R, aby otworzyć okno Uruchom, a następnie wpisz control.exe powercfg.cpl,,3 i kliknij przycisk OK.
-
Wybierz plan, którego używasz z listy rozwijanej.
-
Kliknij opcję Przywróć domyślne ustawienia planu.
-
Kliknij przycisk OK i zamknij okno.
-
Otwórz okno PowerShell.
-
Kliknij prawym przyciskiem myszy przycisk Start systemu Windows i wybierz opcję Windows PowerShell (Administrator) lub Wiersz CMD (Administrator) na większości komputerów z systemem Windows 10
-
Wpisz następujące polecenie:
powercfg /a -
Otrzymasz następujący raport:
The following sleep states are available on this system:Standby (S3)The following sleep states are not available on this system:Standby (S1)The system firmware does not support this standby state.Standby (S2)The system firmware does not support this standby state.HibernateHibernation has not been enabled.Standby (S0 Low Power Idle)The system firmware does not support this standby state.Hybrid SleepHibernation is not available.The hypervisor does not support this standby state.Fast StartupHibernation is not available.
Co to jest uśpienie hybrydowe?
Uśpienie hybrydowe — połączenie trybu uśpienia i hibernacji. Wszystkie otwarte dokumenty i programy są zapisywane w pamięci i na dysku twardym, a następnie komputer przechodzi w stan niskiego poboru mocy. Dzięki temu możesz szybko wznowić pracę. Jeśli wystąpi awaria zasilania, system Windows może przywrócić stan pracy z dysku twardego. Może to być przydatne w przypadku komputerów domowych, ale niezbyt w przypadku notebooków. Ta opcja jest ustawieniem domyślnym dla komputerów stacjonarnych. Jest odwrotnie w przypadku notebooków, które są dostarczane z wyłączoną funkcją. (Komputery stacjonarne są uzależnione od zasilania sieciowego, a notebooki mają wbudowane baterie, które ograniczają ryzyko problemów z zasilaniem).
Wyłączanie uśpienia hybrydowego
-
Otwórz okno Zaawansowane opcje zasilania.
-
Naciśnij jednocześnie klawisze Windows + R, aby otworzyć okno Uruchom, a następnie wpisz control.exe powercfg.cpl,,3 i kliknij przycisk OK.
-
Wybierz plan, którego używasz z listy rozwijanej.
-
Przejdź przez opcje planu i rozwiń opcję Uśpienie (klikając symbol plusa).
-
Rozwiń opcję Zezwalaj na uśpienie hybrydowe.
-
Upewnij się, że wszystkie opcje w obszarze Zezwalaj na hybrydowy tryb uśpienia są wyłączone (kliknij niebieski tekst, aby je zmienić).
-
Kliknij przycisk OK i zamknij okno.
-
Otwórz Narzędzie do rozwiązywania problemów z zasilaniem.
-
Kliknij przycisk Start systemu Windows i wpisz Rozwiązywanie problemów, wybierz wyświetloną ikonę rozwiązywania problemów, aby otworzyć narzędzie do rozwiązywania problemów.
-
Przewiń listę opcji i wybierz pozycję zasilanie.
-
Kliknij przycisk Uruchom narzędzie do rozwiązywania problemów.
-
Postępuj zgodnie z instrukcjami na ekranie i sprawdź, czy problem zostanie rozwiązany.
Tworzenie czystego rozruchu w celu rozwiązywania problemów
-
Otwórz narzędzie MSConfig.
-
Naciśnij jednocześnie klawisze Windows + R, aby otworzyć okno Uruchom, a następnie wpisz msconfig i kliknij przycisk OK.
-
Przejdź do karty Ogólne.
-
Kliknij przycisk opcji Uruchamianie selektywne.
-
Usuń zaznaczenie pola wyboru obok pozycji Załaduj elementy startowe.
-
Przejdź do karty Usługi.
-
Zaznacz pole wyboru obok pozycji Ukryj wszystkie usługi Microsoft w dolnej części okna.
-
Kliknij opcję Wyłącz wszystkie w prawej części tej samej strony.
-
Przejdź do zakładki Uruchamianie i kliknij łącze Menedżer zadań .
-
Na karcie Uruchamianie w narzędziu Menedżer zadań kliknij prawym przyciskiem myszy każdy z włączonych elementów startowych i wybierz opcję Wyłącz
-
Zamknij narzędzie Menedżer zadań i wróć do narzędzia MSConfig.
-
Kliknij przycisk OK i kliknij opcję Uruchom ponownie.
Przywracanie komputera po wykonaniu czystego rozruchu.
-
Otwórz narzędzie MSConfig.
-
Naciśnij jednocześnie klawisze Windows + R, aby otworzyć okno Uruchom, a następnie wpisz msconfig i kliknij przycisk OK.
-
Przejdź do karty Ogólne.
-
Kliknij przycisk opcji Uruchamianie normalne.
-
Przejdź do karty Usługi
-
Usuń zaznaczenie pola wyboru obok pozycji Ukryj wszystkie usługi Microsoft w dolnej części okna.
-
Kliknij opcję Włącz wszystkie w dolnej części tej samej strony.
-
Przejdź do zakładki Uruchamianie i kliknij łącze Menedżer zadań .
-
Na karcie Uruchamianie w narzędziu Menedżer zadań kliknij prawym przyciskiem myszy każdy z włączonych elementów startowych i wybierz opcję Włącz
-
Zamknij narzędzie Menedżer zadań i wróć do narzędzia MSConfig.
-
Kliknij przycisk OK i kliknij opcję Uruchom ponownie.
Jak odświeżyć plik hiberfil.sys
Możesz odświeżyć plik hiberfil.sys poprzez wyłączenie i włączenie przełącznika. Spowoduje to zresetowanie pliku w przypadku jego uszkodzenia:
-
Otwórz wiersz polecenia z podwyższonym poziomem uprawnień lub program PowerShell (kliknij prawym przyciskiem myszy przycisk Start systemu Windows i wybierz z menu polecenie Wiersz CMD (administrator) lub Windows PowerShell (administrator) ).
-
Wpisz następujące polecenie i naciśnij klawisz Enter, aby wyłączyć plik:
powercfg -h off -
Uruchom ponownie komputer osobisty i wróć do wiersza polecenia z podwyższonym poziomem uprawnień lub do programu PowerShell.
-
Wpisz następujące polecenie i naciśnij klawisz Enter, aby włączyć plik:
powercfg -h on
Wyłączanie/usuwanie pliku hiberfil.sys
Pozostawienie pliku wyłączonego spowoduje usunięcie pliku hiberfil.sys z komputera:
-
Otwórz wiersz polecenia z podwyższonym poziomem uprawnień lub program PowerShell (kliknij prawym przyciskiem myszy przycisk Start systemu Windows i wybierz z menu polecenie Wiersz CMD (administrator) lub Windows PowerShell (administrator) ).
-
Wpisz następujące polecenie i naciśnij klawisz Enter, aby wyłączyć plik:
powercfg -h off -
Uruchom ponownie komputer osobisty i wróć do wiersza polecenia z podwyższonym poziomem uprawnień lub do programu PowerShell.
Sprawdź, czy przywracanie systemu jest włączone.
-
Otwórz Panel sterowania.
-
Kliknij przycisk Start systemu Windows i wpisz Panel sterowania , a następnie kliknij ikonę panelu sterowania, która pojawi się na liście.
-
Kliknij ikonę System.
-
Kliknij opcję Ochrona systemu w menu po lewej stronie.
-
Kliknij kartę Ochrona systemu w oknie, które się pojawi.
-
W menu Ustawienia ochrony sprawdź, czy dysk komputera jest wyświetlany jako WŁĄCZONY.
-
Jeśli odpowiedź brzmi Tak, przywracanie systemu jest włączone, przejdź do następnego zestawu kroków.
-
Jeśli odpowiedź brzmi Nie, przywracanie systemu jest wyłączone, przejdź do następnej sekcji.
-
Użyj przywracania systemu, aby wrócić do poprzedniego punktu kontrolnego.
-
Otwórz Panel sterowania.
-
Kliknij przycisk Start systemu Windows i wpisz Panel sterowania , a następnie kliknij ikonę panelu sterowania, która pojawi się na liście.
-
Kliknij ikonę System.
-
Kliknij opcję Ochrona systemu w menu po lewej stronie.
-
Kliknij kartę Ochrona systemu w oknie, które się pojawi.
-
Pod nagłówkiem Przywracanie systemu kliknij przycisk Przywracanie systemu.
-
Postępuj zgodnie z instrukcjami na ekranie, aby wybrać żądany punkt przywracania z listy (pamiętaj, aby wybrać punkt utworzony zanim problem zaczął występować).
-
Możesz kliknąć przycisk Skanuj w poszukiwaniu zagrożonych programów, jeśli chcesz sprawdzić, które programy zostaną dotknięte tym wycofaniem.
-
Kliknij przycisk Dalej, aby przywrócić komputer do stanu z wybranej daty.
Uruchamianie narzędzia SFC (System File Check).
-
Otwórz wiersz Polecenie lub PowerShell z uprawnieniami administratora.
-
Kliknij prawym przyciskiem myszy przycisk Start systemu Windows i wybierz odpowiednią opcję z wyświetlonego menu.
-
Wpisz następujące polecenie i naciśnij klawisz Enter:
SFC /scannow. -
Jeśli narzędzie SFC nie zostało uruchomione, spróbuj wykonać następujące czynności, aby uruchomić narzędzie DISM.
Uruchamianie narzędzia Deployment Image and Servicing Management (DISM).
-
Otwórz wiersz Polecenie lub PowerShell z uprawnieniami administratora.
-
Kliknij prawym przyciskiem myszy przycisk Start systemu Windows i wybierz odpowiednią opcję z wyświetlonego menu.
-
Wpisz następujące polecenie i naciśnij klawisz Enter:
DISM /Online /Cleanup-Image /RestoreHealth. -
Narzędzie DISM sprawdza magazyn składników systemu Windows pod kątem uszkodzeń i naprawia znalezione błędy.
Dysk twardy można wymieniać na dwa sposoby.
Najszybszym i najłatwiejszym sposobem wykluczenia systemu operacyjnego jest zamiana rozruchowego dysku twardego. Użyj rozruchowego dysku twardego z działającego przykładu tego samego modelu komputera.
- Jeśli awaria nadal występuje na komputerze, system operacyjny został wykluczony i zalecamy skontaktowanie się z pomocą techniczną firmy Dell w celu uzyskania dalszej pomocy.
- Jeśli awaria jest przenoszona z dyskiem twardym, prawdopodobnie jest związana z systemem operacyjnym i należy przejść do następnego zestawu kroków.
- Jeśli nie ma odpowiedniego komputera do zamiany części, należy przejść do następnego zestawu kroków.
Zainstaluj ponownie system operacyjny dostarczony przez firmę Dell.
Skorzystaj z artykułu pod następującym łączem, który opisuje krok po kroku proces ponownej instalacji systemu operacyjnego na komputerze:
Additional Information
Brak gwarancji? Żaden problem. Odwiedź witrynę Dell.com/support i wpisz kod Dell Service Tag, a następnie zapoznaj się z naszymi ofertami.