No se encontró el administrador de arranque en el primer reinicio después de una instalación de MDT mediante UEFI
Summary: Información sobre cómo corregir un error de "Administrador de arranque no encontrado" después de una instalación de Microsoft Deployment Toolkit (MDT) mediante Unified Extensible Firmware Interface (UEFI). ...
Symptoms
Cambio en el orden de arranque
Si recibe un error durante la implementación de Windows 10 mediante:
- Microsoft Deployment Toolkit versión 8443
- Windows 10 ADK 1703 o 1709
Mientras que las computadoras de destino utilizan firmware UEFI.
Después de arrancar WinPE y realizar la fase de instalación (aplicar sistema operativo), la computadora se inicia nuevamente en el disco de red/USB en lugar de utilizar el firmware UEFI (Bootmgfw.efi).
Cause
Debido a los cambios en la optimización de las herramientas bcdboot, MDT 8443 no utiliza la línea de comandos bcdboot correcta de Windows 10 1703/1709 ADK para actualizar el orden de arranque del firmware de UEFI. Este problema se elevó al equipo de productos de MDT y se debe corregir para la próxima versión de MDT a finales de este año.
Resolution
Editar scripts de implementación
En el recurso compartido de implementación, diríjase a la carpeta Scripts.
Respalde LTIApply.wsf.
Abra LTIApply.wsf con su editor de texto y reemplace la siguiente línea:
TestAndFail RunBCDBootEx( sDestinationDrive & "\windows", " /s " & left(oBootDrive.Drive,2) & " /f UEFI"), 5616, "Verify BCDBootEx"
Con esta línea:TestAndFail RunBCDBootEx( sDestinationDrive & "\windows", " /c"), 5616, "Verify BCDBootEx"
Más información: /c Opcional. Especifica que no se debe migrar ningún elemento BCD existente. Novedades de Windows 10: De manera predeterminada, durante una actualización, se conservan los elementos de BCD, como debugsettings o flightsigning.
Opciones de línea de comandos de BCDBootMDT v. 8443 + ADK v. 1703 = orden de arranque cambiado después de la instalación posterior mediante UEFI