Boot Manager non trovato al primo riavvio dopo un'installazione di MDT tramite UEFI
Summary: Informazioni sulla correzione di un errore "Boot Manager non trovato" dopo l'installazione di Microsoft Deployment Toolkit (MDT) utilizzando UEFI (Unified Extensible Firmware Interface). ...
Symptoms
Modifica dell'ordine di avvio
Se viene visualizzato un errore durante la distribuzione di Windows 10 utilizzando:
- Microsoft Deployment Toolkit versione 8443
- Windows 10 ADK 1703 o 1709
Mentre i computer di destinazione utilizzano il firmware UEFI.
Dopo l'avvio in WinPE e aver eseguito la fase di installazione (Applica sistema operativo), il computer si riavvia su rete/disco USB anziché utilizzare il firmware UEFI (Bootmgfw.efi).
Cause
A causa delle modifiche apportate all'ottimizzazione degli strumenti bcdboot, MDT 8443 non utilizza la riga di comando bcdboot corretta da Windows 10 1703/1709 ADK per aggiornare l'ordine di avvio del firmware UEFI. Questo problema è stato segnalato al team prodotto di MDT e dovrebbe essere risolto per la prossima versione di MDT entro la fine dell'anno.
Resolution
Modifica script di deployment
Nella condivisione di deployment, passare alla cartella Scripts.
Eseguire il backup di LTIApply.wsf.
Aprire LTIApply.wsf con l'editor di testo e sostituire la riga seguente:
TestAndFail RunBCDBootEx( sDestinationDrive & "\windows", " /s " & left(oBootDrive.Drive,2) & " /f UEFI"), 5616, "Verify BCDBootEx"
Con questa riga:TestAndFail RunBCDBootEx( sDestinationDrive & "\windows", " /c"), 5616, "Verify BCDBootEx"
Ulteriori informazioni: /c Facoltativo. Specifica che gli elementi BCD esistenti non devono essere migrati. Novità di Windows 10: Per impostazione predefinita, durante un aggiornamento vengono mantenuti gli elementi BCD, ad esempio debugsettings o flightsigning.
Opzioni della riga di comando di BCDBootMDT v. 8443 + ADK v. 1703 = ordine di avvio modificato dopo la post-installazione tramite UEFI