解決作業系統升級後 NVIDIA 安裝程式故障的問題
Summary: 下列文章提供四種方法的相關資訊,以解決 NVIDIA 安裝程式在升級 Windows 10 後失敗的問題。
Symptoms
在升級 Windows 10 後,NVIDIA 安裝程式在每次嘗試安裝時都會出現錯誤
有好幾份關於升級至最新版 Windows 10 作業系統後,NVIDIA 安裝程式失敗的報告。本指南可協助您解決 Dell 電腦上的此問題。
Cause
工程部門將此識別為軟體問題。排除圖形驅動程式,將防病毒排除在外,並終止任何正在運行的 NVIDIA 進程。
Resolution
依序執行下列各種方法,直到問題解決為止。
- 備份所有個人資料。如需更多資訊,請參閱:備份與復原
- 如果在筆記本電腦上執行更新,請連接交流電變壓器。
-
更新 NVIDIA 驅動程式:
-
在電腦上將驅動程式更新至最新版本可解決問題。若要下載和安裝驅動程式,請參閱:如何下載和安裝 Dell 驅動程式和韌體
-
某些防病毒應用程式可能會導致 NVIDIA 安裝程式失敗。在執行特定安裝程式時暫時關閉防毒軟體可能會解決此問題:
-
在 Dell 平台上,防毒軟體會在 Windows 作業系統的系統工作列中顯示圖示。
-
以滑鼠右鍵按一下該圖示可開啟更多選項,視防毒軟體製造商而定:
-
開啟防毒應用程式或代理程式以將其關閉
-
關閉主動式掃描器
-
關閉防病毒軟體,直到下次重新啟動
-
-
安裝完成後,請確定已重新開啟防毒軟體。請勿讓您的裝置不受保護。
冗餘的 NVIDIA 檔案和程序可能會導致安裝失敗:
-
以滑鼠右鍵按一下工作列的空白部分,或同時按住 CTRL、 Shift 和 Esc 鍵,然後從出現的功能表中選取 工作管理員 ,以開啟工作管理員:
-
按一下 程序 標籤。
-
選取與 NVIDIA 相關的每個程序 。
-
以滑鼠右鍵按一下每個按鈕,然後選取 結束工作 以關閉程序。
-
-
前往開機磁碟機資料夾,並移除下列檔案:
-
C:\windows\system32\DRiverStore\FileRepository\nvdsp.inf file -
C:\windows\system32\DRiverStore\FileRepository\nv_lh file -
C:\windows\system32\DRiverStore\FileRepository\nvoclock file -
C:\Program Files\NVIDIA Corporation\ -
C:\Program Files(x86)\NVIDIA Corporation\
-
-
將裝置重新開機。
-
嘗試以 自訂 安裝方式重新執行 NVIDIA 安裝程式。
請遵循這些步驟,從 NVIDIA 安裝程式執行全新安裝:
-
讓系統閒置 20 分鐘,以確保 Windows 已完成升級作業系統的任何更新。
-
與方法 I 一樣,將最新版本的驅動程式下載到您的電腦。
-
以管理員權限執行驅動程式解壓縮/安裝,方法是以滑鼠右鍵按一下下載的檔案,然後選取 以系統管理員身分執行。
-
按照畫面中的指示進入 安裝選項 畫面。
-
選取 自訂 ,並在 執行全新安裝旁加上核取記號。
-
安裝完成後,請將電腦重新開機。
如果這樣做無法解決問題,請聯絡技術支援:
- Dell 支援網站:與我們聯絡